1. Mike-Mike's Avatar
    i am trying to get Tasker (or any app) to auto start my hotspot when I get in my vehicle. I feel like I have it setup correctly, but it doesn't work.

    I have a Moto Z Force Droid on Verzion, I can manually start a Hotspot without issue, I have no known restrictions on my phone, other than it not being rooted. however every app I ever try to auto start a hotspot never works.

    i followed these directions, trying to get my Hotspot to come on when it sees a bluetooth connection to my head unit:

    I prefer to create my tasks first.

    Enter Task
    Go to the Tasks tab and click the plus sign. Name your enter task, for example, "Hot Spot On". Click the plus sign to add an action, select "Net", "WiFi Tether", and set to on.

    Exit Task
    Go to the Tasks tab and click the plus sign. Name your exit task, for example, "Hot Spot Off". Click the plus sign to add an action, select "Net", "WiFi Tether", and set to off.

    Profile
    Go to the Profile tab and click the plus sign. Select "State" as the first context. Next, select "Net", followed by "BT connected". Under the "Name" heading (where it shows optional) click the magnifying glass and select the Joying BT address.

    Add the "Hot Spot On" task for the enter task. Then longpress the "Hot Spot On" task and select the option to add an exit task. Add the "Hot Spot Off" as the exit task.

    Now, each time your phone connects to your Joying it will automatically turn on your hot spot. When your connection ends, your hot spot will turn off.


    and when I'm in my Jeep, it does see my head unit, but the Hotspot did not come on:

    01-10-2017 12:29 PM
  2. doogald's Avatar
    I did some Googling. This may help: https://groups.google.com/forum/#!to...er/q5uSgqtwBkY though it may not.

    I wanted to have a shortcut on my home to turn on and off hotspot but as a Verizon customers, I can not do that, I tried 10 different apps none of them worked, here is why

    Verizon added a hook into hotspot functionality that check for subscription, so if you turn it on, it will check if you are eligible for hotspot (I am) and only then will turn the hotspot on, but while it check it turn it back off (so all the apps , I guess get confused, they turn it on, but it turned off immediately)
    This is probably why a simple toggle in Tasker does not work.

    Two ideas, if that post is not helpful (I am not a Talker expert AT ALL.):

    - maybe a pause when you switch on the hotspot??
    - maybe toggle your WiFi radio off first, to make sure that you are not connected to WiFi when you turn on the hotspot??
    01-10-2017 01:01 PM
  3. Mike-Mike's Avatar
    thanks, I'll give that a shot. I dont know how to pause, but I think I can set it up to turn off Wi-Fi first
    01-10-2017 02:46 PM
  4. doogald's Avatar
    I dont know how to pause,
    I believe that's the "wait" command.
    01-10-2017 04:22 PM

Similar Threads

  1. Nexus 6P Wifi hotspot problems.
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-03-2017, 04:51 PM
  2. Hotspot issue
    By asmok1 in forum Huawei Mate 9
    Replies: 5
    Last Post: 01-12-2017, 05:46 PM
  3. Tethering / Hotspot error
    By chryssy67 in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2017, 01:19 AM
  4. timer turn off moto 6 mobile hotspot
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-05-2017, 07:45 AM
  5. Wifi is slow at free hotspot but fast at my house
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-02-2017, 04:32 PM
LINK TO POST COPIED TO CLIPBOARD