1. ksefan's Avatar
    Is anyone having a problem with it? All my cords just pop out. They never stay in snuggly and I always have to plug it back in
    ASD Dad likes this.
    06-27-2017 07:36 AM
  2. Scott337's Avatar
    Good morning. I have not had any issues with my Z Force charging port. Since these phones are less than a year old it should be covered under warranty. Have you contacted Moto customer support, or Verizon (depending on where you bought it)?
    06-27-2017 08:18 AM
  3. ASD Dad's Avatar
    Mine are doing the same thing! I have the original Moto cord, the one from my Nexus 5X and some others I use in the car and all of them pop out or are very loose. Starting to drive me nuts since I think it is charging only to come back and see it came loose and never did charge.
    06-27-2017 11:49 AM
  4. jesta192's Avatar
    Had this problem with micro-USB on my Galaxy Nexus when I bought it used. It had lots of lint stuffed deep into the port, and it was keeping the plug from going all the way in. A toothpick and a gentle touch, and the problem was solved completely. I think that might have been why the guy sold it.
    06-28-2017 06:47 PM
  5. ASD Dad's Avatar
    Mine has gotten to the point where I gave up and went to Verizon. They tried a brand new Moto charger and you have to hold the plug just right to get it to charge and then not touch it even the tiniest bit. The port is clean, we looked at with a lit magnifying glass. You really have to jam the charger in there and they agreed it is not they way it should be.

    I can send it back under warranty and get a refurb sent out. They wont guarantee the condition of the refurb and my Z is mint having lived in a case with a full screen protector it's whole life. My buddy got a refurb S7 Edge once and it looked beat up by a kid using it as a hockey puck! Sure, it all worked but it looked rough! OTOH my Z just isnt going to last much longer if this keeps up.
    07-23-2017 06:54 PM
  6. Doug Moffat's Avatar
    Had this problem with micro-USB on my Galaxy Nexus when I bought it used. It had lots of lint stuffed deep into the port, and it was keeping the plug from going all the way in. A toothpick and a gentle touch, and the problem was solved completely. I think that might have been why the guy sold it.
    Worst phone I ever owned.
    07-23-2017 10:45 PM
  7. turbochgd's Avatar
    Mine has gotten to the point where I gave up and went to Verizon. They tried a brand new Moto charger and you have to hold the plug just right to get it to charge and then not touch it even the tiniest bit. The port is clean, we looked at with a lit magnifying glass. You really have to jam the charger in there and they agreed it is not they way it should be.

    I can send it back under warranty and get a refurb sent out. They wont guarantee the condition of the refurb and my Z is mint having lived in a case with a full screen protector it's whole life. My buddy got a refurb S7 Edge once and it looked beat up by a kid using it as a hockey puck! Sure, it all worked but it looked rough! OTOH my Z just isnt going to last much longer if this keeps up.
    I'd go for the exchange. I sent mine back and received a perfect refurb in return. Couldn't tell it from new. Like yours, my original Force was perfect too. Except for the fact it had a Bluetooth issue which led to the exchange.

    I know the options aren't great, but you can't have a phone with that issue. It'll definitely effect the resale value too.
    07-24-2017 05:24 PM
  8. ASD Dad's Avatar
    I got my exchange this morning. You're right, it looks brand new. There is not a mark on it anywhere and it has protective plastic cling on it. The charging port is nice and tight and it "clicks" into place like it should. Pretty happy now.
    turbochgd and benjamminh like this.
    07-27-2017 02:59 PM
  9. turbochgd's Avatar
    I got my exchange this morning. You're right, it looks brand new. There is not a mark on it anywhere and it has protective plastic cling on it. The charging port is nice and tight and it "clicks" into place like it should. Pretty happy now.
    Excellent! Enjoy.
    benjamminh likes this.
    07-27-2017 04:19 PM
  10. YAYTech's Avatar
    Make sure that the phone's case isn't keeping the cord from plugging in all the way. Mostly sounds like a worn out port. This is part of why I like using wireless charging on my phones.
    07-28-2017 05:33 AM
  11. ASD Dad's Avatar
    Make sure that the phone's case isn't keeping the cord from plugging in all the way. Mostly sounds like a worn out port. This is part of why I like using wireless charging on my phones.
    I did check it without the case as did the Verizon store guy when I brought it in. I think you are correct that it simply wore out. I charged it every night and sometimes in the car if I was using GPS. I would use wireless charging on this phone if it had it natively, I didnt want to add the battery mod just for that option.
    YAYTech likes this.
    07-28-2017 07:45 AM
  12. YAYTech's Avatar
    I did check it without the case as did the Verizon store guy when I brought it in. I think you are correct that it simply wore out. I charged it every night and sometimes in the car if I was using GPS. I would use wireless charging on this phone if it had it natively, I didnt want to add the battery mod just for that option.
    Yeah, wish they would've offered the wireless charging style shell sooner.
    07-28-2017 10:03 AM

Similar Threads

  1. Why quick charge doesn't work anymore on my Note 5 phone?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 5
    Last Post: 07-26-2017, 02:34 AM
  2. Replies: 1
    Last Post: 06-26-2017, 11:52 AM
  3. Replies: 1
    Last Post: 06-26-2017, 11:44 AM
  4. Replies: 1
    Last Post: 06-26-2017, 07:37 AM
  5. Replies: 1
    Last Post: 06-26-2017, 07:37 AM
LINK TO POST COPIED TO CLIPBOARD