1. dookie.'s Avatar
    This is interesting:
    https://forums.lenovo.com/t5/Moto-Z/...e/td-p/3758100

    Thought my battery was just getting old, but maybe not. I have high drain and unreliable stats just as described. GSam has been ADB-adjusted to allow real data to be collected, and it fingers the OS/system processes as the culprit.
    12-20-2017 07:58 AM
  2. SoccerRef12's Avatar
    Did you try reinstalling the latest OS?
    12-20-2017 10:43 AM
  3. dookie.'s Avatar
    No, but I've done both cache wipe (first) and factory reset (when it didn't help) from recovery.

    I've definitely had it power off showing 20+ left, only to show a few pct when plugged in. Battery life is suddenly half what it has been.
    12-20-2017 11:28 AM
  4. SoccerRef12's Avatar
    Go to the Motorola site and download the latest OS and reinstall it. That should fix your problem.
    12-20-2017 12:01 PM
  5. dookie.'s Avatar
    Why is this not discussed in the Lenovo support?

    Furthermore, isn't the "OS" kept current by the carrier? Can you point me to a link for the Verizon USA image?

    I'm current with everything pushed OTA.
    12-20-2017 05:44 PM
  6. SoccerRef12's Avatar
    You should probably check Verizon support for the image. I've never had to reinstall on my Moto, but have had to do it on other devices.
    12-20-2017 05:53 PM
  7. dookie.'s Avatar
    You should probably check Verizon support for the image. I've never had to reinstall on my Moto, but have had to do it on other devices.
    Per Verizon, I am running the latest (NCLS26.118-23-13-3). And it has already been factory reset. And per Lenovo support, this is a widespread problem.

    Have you actually remedied this problem, on this device, with this solution?

    Anyone else with ideas?
    12-20-2017 07:24 PM
  8. SoccerRef12's Avatar
    Sometimes, when a new software install, something gets corrupt and ends up draining your battery. It's happened to me in the past on another device and reinstalling the software fixed it.
    12-20-2017 07:31 PM

Similar Threads

  1. Another battery post.
    By chuck1984 in forum Samsung Galaxy Note 8
    Replies: 24
    Last Post: 12-23-2017, 10:11 AM
  2. Battery Bluetooth issue
    By Jon Pluta in forum General Help and How To
    Replies: 1
    Last Post: 12-20-2017, 12:06 PM
  3. My Battery is draining very fast
    By Android Central Question in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 12-20-2017, 12:04 PM
  4. My Battery is draining very fast
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-20-2017, 12:41 AM
  5. My battery life is draining on my Galaxy Note 5 since the software update.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-19-2017, 05:21 PM
LINK TO POST COPIED TO CLIPBOARD