1. bchandler02's Avatar
    Having a weird issue with a new Z Play i picked up.
    The phone sees the SD card, but when i tap on the SD card (where it should take me to the usage screen) it flashes the screen and then stays on the main storage screen. I also can't browse the SD card in file manager. Play Music also didn't see it as well.

    However the phone has no issues writing pictures and video to it, and looking at them later. The SD card also shows up and works fine when the phone is plugged into my PC.

    Any ideas?
    12-09-2016 12:53 PM
  2. Rukbat's Avatar
    Is the card formatted as internal or external? (You got the choice the first time you had the card in with Marshmallow.)

    Run SD Insight on the card (install it first, of course). Is the card the full size? What's the date of the card?
    12-09-2016 01:07 PM
  3. bchandler02's Avatar
    I wasn't given the choice. My plan was to insert it, then go reformat it (it came out of my S7) and be good to go. I also tried a card out of my tablet as well, same results.

    The card is a 128GB Sandisk card purchased at Best Buy in summer 2015. Model SL128, from 4/2015
    12-09-2016 01:59 PM
  4. mobrules's Avatar
    Is the card formatted as internal or external? (You got the choice the first time you had the card in with Marshmallow.)

    Run SD Insight on the card (install it first, of course). Is the card the full size? What's the date of the card?
    Rukbat, curious on your thoughts, good and bad, of internal vs external????
    12-09-2016 07:48 PM
  5. Bosgarage57's Avatar
    Your card is probably about dead. Same thing just happened to me. File manager under category I was able to see it but if I tried to browse to it it wouldn't recognize
    12-10-2016 08:18 AM
  6. bchandler02's Avatar
    I considered that, but what's the odds of me having 2 cards that work in 2 different devices but not this one? The other card is a 32GB Sandisk - they are both Ultra cards.
    12-11-2016 03:31 PM
  7. dby2011's Avatar
    I would copy everything from the sdcard to your PC. Then format the card using your phone and transfer everything back to your sdcard.
    12-11-2016 09:03 PM
  8. bchandler02's Avatar
    That's the issue - without getting to this page I do not have an option to format the card.
    12-12-2016 07:13 AM
  9. bchandler02's Avatar
    I found one more SD card to test with (out of my digital camera). 32GB Kingston card. Same thing.

    So I have 3 cards that work fine in other devices but don't in this phone - but this phone has no issue using the SD card (I just pulled 5GB worth of video off the original 128GB card that I shot on the phone over the weekend - no issue).
    12-12-2016 07:26 AM
  10. NX1977's Avatar
    Are you rebooting the phone or hot swapping the cards?

    As the card is reading from it we know it's fine.
    12-12-2016 12:47 PM
  11. bchandler02's Avatar
    I've tried both actually. Just to be sure now, I did the following:

    1. Eject/unmount card in settings
    2. power down phone, remove SD card
    3. boot phone with no SD card, shut phone down
    4. reinstall 128gb card, reboot phone

    Same issue. It still shows 4.51GB used (which is what WAS used this weekend, before I removed the videos I mentioned above via USB this morning). There should be almost nothing used on the card at the moment.
    12-12-2016 01:29 PM
  12. jbird68's Avatar
    I can't use my 32gb card either. I can see it in system/storage. But that's it. ES Explorer or File Manager can't access the card. There are apps on the card. So I think it was working at one time. I also can't put a check to view external storage data. It is grayed out.
    03-14-2017 11:38 PM
  13. bchandler02's Avatar
    It was fixed for me under Marshmellow in one of the recent security updates.

    I just upgraded to Nougat last week and after the upgrade, the phone was rebooting every few hours. I've since wiped the phone and added everything back over a few days. The only thing I haven't done is re-encrypt the SD card, which I am about to do now. Nervous to do that as I am curious if the encryption is broken again under Nougat.
    See this thread for more details: https://forums.lenovo.com/t5/forums/...ht/true/page/2
    03-15-2017 08:50 AM
  14. jbird68's Avatar
    I ended up reformatting my card and it is reading OK now. I didn't have much on the card so I didn't lose much.
    03-19-2017 08:41 PM

Similar Threads

  1. Text messaging issue
    By mizz_ordo in forum LG V20
    Replies: 14
    Last Post: 12-15-2016, 11:05 AM
  2. Replies: 1
    Last Post: 12-09-2016, 09:44 AM
  3. how do you get a ZTE Max sim card to read
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-09-2016, 08:54 AM
  4. Samsung Galaxy tab 3 / debit card payments?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-09-2016, 07:02 AM
  5. moving apps to sd card
    By Soundman72 in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 12-09-2016, 04:16 AM
LINK TO POST COPIED TO CLIPBOARD