1. 312MotoGus's Avatar
    I bought an open-box Z4 from Best Buy, described as being in "excellent" condition. Set it up today, and it won't connect to my JBL 2 or projector mods.

    In addition, it will connect to the Incipio Vehicle Dock, once- if you remove it and put it back on, there is no power or audio through the dock. A look at the Connected Devices menu shows that the phone isn't recognizing the Dock at all.

    Lastly, the cellular signal drops to zero every once in a while, it shuts off occasionally, and when you hit Restart, it just shuts off and does not restart.

    It sure looks new and perfect, but it's got real problems under the hood. It's getting exchanged tomorrow.
    05-30-2020 01:38 AM
  2. PapaGary's Avatar
    So, now you know what "open box" means: it was returned.

    FYI- Several years ago I bought an expensive Canon digital camera from Best Buy that was "open box" and looked like new for over $100 off. I got it home and ran it through its paces and found it worked perfectly with the exception of the on board flash. Investigation showed that it had a cover on the flash hot shoe which when removed resulted in the flash working as it should. Apparently it has a connector on the hot shoe which tells the camera that a flash is connected and shuts off the internal flash. I told a friend who worked at Best Buy that I had purchased that model of camera that was open box and he replied: "Oh no, that was the one that had the flash that didn't work." I just smiled...
    312MotoGus likes this.
    05-30-2020 09:09 PM
  3. 312MotoGus's Avatar
    That was my first thought too- I'd been bitten by the open-box curse. But I exchanged it for a new, unopened one (Best Buy literally just took this one and gave me a new one), and it wouldn't connect to my Mods either!

    Actually, it connected to some sometimes and others other times, but never all of them. It kept doing system updates during setup, and once it got done and all my apps were updated, none of the Mods worked. I'm stumped.

    I'm returning it this week, already ordered a Z3 Play to replace my Z Play, which has a wonky screen occasionally.
    06-01-2020 12:04 AM
  4. Kizzy Catwoman's Avatar
    Hi. I am glad you got the exchange but am sorry your mods don't work. Are they meant to be compatible with the Z4 or for a different model? It is a weird the JBL do not connect either. Are they Bluetooth?
    06-01-2020 02:00 AM
  5. bill-e's Avatar
    I've noticed that with a new phone sometimes the mod has to be installed with the power off and then the phone turned on....kind of like Window hardware detect. Once the mod starts the first time it will work on that phone from then on.
    06-07-2020 03:25 PM

Similar Threads

  1. End of the line for the Moto Z Series
    By kingstu in forum Moto Z
    Replies: 3
    Last Post: 07-02-2020, 01:04 PM
  2. Replies: 28
    Last Post: 06-09-2020, 08:41 PM
  3. 3XL - 15 seconds @ 2 feet DOA = totally bummed
    By kenorian in forum Google Pixel 3 & Pixel 3 XL
    Replies: 8
    Last Post: 05-28-2020, 12:18 AM
  4. Replies: 2
    Last Post: 05-25-2020, 08:21 PM
  5. Moto G8 Forums?
    By itic in forum Site Feedback & Help
    Replies: 1
    Last Post: 05-25-2020, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD