1. Android Central Question's Avatar
    I have a Moto Z2 that connects perfectly at 300 Mbps (5GHz) and 150 Mbps (2.4 GHz) with my older routers (Cisco, Netgear and Apple).

    My brand new Moto Z3 isn't half as good: it won't go beyond 150 and 72, respectively.

    With newer routers, the Z3 it will connect at 433 Mbps. It also connects at 433 Mbps with my Moto Z2.

    The Z3 runs Android 8.1 and the Z2 runs Android 8.0.

    Any idea?

    Thank you so much.
    12-01-2018 11:54 AM
  2. Rukbat's Avatar
    Since you'll probably never see 72mbps downloads before you've replaced both phones, my suggestion is to not worry about it. Unless you're doing a speed test with a local server, you'll barely get above 5mbps from a really good server that's close. Downloading from a server halfway around the world that's running a core duo CPU probably will get you close to 1mbps. (About the only time the connection-to-the-router soeed matters is in transferring data or files from the phone to or from something else on the LAN, and an SD card is a faster way than even 300mbps wifi.)
    12-01-2018 03:56 PM

Similar Threads

  1. Why does my Android Central app crash every time i open it?
    By Brad Bilger in forum Android Central Apps
    Replies: 6
    Last Post: 12-03-2018, 11:31 AM
  2. Issues with Sounds Setting on Samsung Tab A after update 30/11/18
    By Android Central Question in forum Samsung Galaxy Tab A (8 & 9.7)
    Replies: 1
    Last Post: 12-01-2018, 04:10 PM
  3. what does E with 2 arrow un derneath mean
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-01-2018, 03:08 PM
  4. Replies: 6
    Last Post: 12-01-2018, 01:13 PM
  5. Replies: 1
    Last Post: 12-01-2018, 09:17 AM
LINK TO POST COPIED TO CLIPBOARD