Yeah that's right, my Defy is running ICS 4.0.4!

Printable View