1. MofoMan2000's Avatar
    Original post: Permenantly bypass Motoblur and keep your apps! (root required) - Android Forums
    First of all, I need to say how simple this really was. The main problem is when you use the ##BLUROFF command, the next time you boot up the phone it is forced to do a "factory reset" from recovery, wiping the data partition. The solution? Obtain root as quickly as possible and get rid of the app forcing the factory reset.

    Follow these steps in order:
    1. If you already do ##BLUROFF you can skip this step. But if you're already a seasoned Devour root user, you might want to do an SBF flash to restore everything to TRUE factory settings. To do that, use RSD Lite and CALAND_X_01.15.08P_MONSTER_01.sbf. Otherwise, just reboot into recovery mode (when turning the phone on, hold R+SPACE, then power on) and perform a factory reset by pressing Z+M. In any case, get your phone back to the first-time activation screen. Keep in mind, either of these things will delete all your apps and settings!
    1.5. If the original SBF file was flashed, rename Blur_Version.1.15.83.calgary.Verizon.en.US.zip to "update.zip" and put it on the root of your SD card. Apply it through recovery mode (Z+N).
    2. Turn your phone on.
    3. Bypass Verizon/Motoblur activation by ##BLUROFF
    4. Go into Settings -> Applications -> Development -> Turn USB Debugging ON
    5. Obtain root. Use the procedure at Android Central and SKIP ALL STEPS INCLUDING AND AFTER 26. You will need rootshell later on.
    6. From ADB shell, after completing the root process, you should still be in the superuser terminal (you will see a #). Run:
    Code:
    rm /system/app/Setup-release.apk
    rm /system/app/Setup-release.odex
    Alternatively, you may use an app such as Root Explorer to navigate to the /system/app folder and manually delete from there, or rename them.
    7. Disconnect your phone from your computer.
    7.5. If you are not reactivating your Devour on Verizon, wifi will stop working. Now might be a good time to follow the quick procedure here to try to get wifi to work.
    8. Restart your phone. It will do this automatically if step 7.5 was performed. It will kick itself into recovery mode and perform a "factory reset" and will reboot two or three times during the process.
    9. When your phone eventually turns back on, you should not have to bypass activation by ##BLUROFF!!!
    10. Turn on USB debugging again.
    11. Connect your phone to your computer.
    12. Run: ADB shell
    13. Run: rootshell
    14. Type the password: "secretlol"
    13. Run: mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
    14. Run: chmod 4755 /system/bin/su
    15. Run: chmod 4755 /system/bin/busybox
    16. Now you may run: rm /system/bin/rootshell
    17. Run twice: exit
    18. If you're still on contract with Verizon, I assume you want to keep using your phone. Dial *228 to reactivate your phone if necessary (you won't be getting 1X or 3G service if you need to activate).

    Congratulations! You should now have a rooted Motorola Devour with Motoblur bypassed! Feel free to get rid of bloatware, etc. I have placed apps and widgets on my home screen and they didn't get wiped after I restarted, and I haven't seen any Force Close errors as of yet. Please post comments or results in this thread, and if something messes up and/or you manage to brick your phone, always remember you can start over by flashing the SBF file as outlined in step 1. I'll be watching this thread closely.

    EDIT: Got wifi working! See http://androidforums.com/motorola-de...-required.html for how and please post feedback there!

    Also, see http://androidforums.com/devour-all-...-new-post.html for a list of APKs which seem safe to remove. Back them up, just in case.
    mikaccess808 likes this.
    11-04-2011 03:28 PM
  2. MofoMan2000's Avatar
    Just an update for ya'll, my parents finally upgraded from their Devours, so now I have two Devours in my possession, one which will connect to wifi and one which won't. The one which will connect was formerly activated and I ran a /data wipe on it, so it's completely stock (it was never rooted) and the other one was SBF flashed. I'll root them both and try to find the difference. If I'm successful, it may make all the difference.
    12-25-2011 12:18 PM
  3. erickrocks1126's Avatar
    Can I do this if I root using Androot 1.6.2.? The instructions says to obtain root but stop at step 25 of the manual root process.
    01-15-2012 06:54 PM
  4. MofoMan2000's Avatar
    I imagine you could do it using Androot. You'd just have to run the two rm commands as su rather than using the rootshell exploit. Either that or use Root Explorer or similar.
    01-15-2012 11:55 PM
  5. silverred_10's Avatar
    When I tried to do a update it says ERROR can you help me?
    10-29-2012 06:38 PM
LINK TO POST COPIED TO CLIPBOARD