1. UncleVanya's Avatar
    I'm currently testing a Droid 2 Global to determine if I want to transition from another OS to this phone. I have this setup as a wifi only device during testing, but I'm having problems where the wifi ends up not restarting after the phone goes idle for a while.

    What I see is no wifi icon on the status bar. If I try something like the marketplace it fails saying not connected or something like that. To get this working I have to go toggle wifi off and back on - it works correctly after that. It's not a problem each and every time either - only sometimes does this fail to come back on - most of the time it is resuming correctly.

    It may be important to note that I have the phone in airplane mode 95-99% of the time. Once airplane mode is on I then turn up the wifi which should stick - at least on all of my other phones.

    The phone started with Froyo, but it was updated to Gingerbread before I had spent any real time with it so I can't comment if this came as a result of Gingerbread or if this would have been an issue with Froyo.

    While I'm a newbie here - I'm technical just not very savvy with Android yet.
    11-07-2011 12:52 PM
  2. w3rfa's Avatar
    I'm having the same problem. If I walk out of WiFi range and then back it usually doesn't reconnect to WiFi until I toggle the WiFi on and off.

    It didn't do this until 2.3.3. uploaded

    I've turned WiFi sleep mode off but to no avail.

    Very annoying. If I don't remember to turn it back on I miss Skype calls.
    02-13-2012 02:10 PM
  3. w3rfa's Avatar
    Just downloaded an app called WiFiFixer.

    It seemed to solve the problem.
    02-13-2012 02:36 PM
  4. scarryman04's Avatar
    Go into settings/wireless and networks/click menu, select advanced and from there change wifi sleep policy to never.
    02-13-2012 10:08 PM
LINK TO POST COPIED TO CLIPBOARD