1. tarekahf's Avatar
    I have Motorola Droid 2 and using it only with WiFi connection. Not using Mobile. I got it from USA as a gift in Adobe MAX 2011, and it is working fine until today (in Saudi Arabia).

    Today, suddenly, I cannot use most application which requires internet connection such as twitter, Google Play ...etc.

    Only the Browser, Dolphin Browser and Email are working fine.

    When I try to use Twitter, I get error message something like "cannot retrieve tweets now". Same situation in Youtube, Gmail, Google+ ...and most other apps.

    Tried to reboot, clear data, clear app cache ... not working...

    Also tried to remove the app which I updated today, but I cannot remember which apps I updated exactly (I remember I updated 3 apps) .. after that, I noticed this problem, but not 100% sure that this is the cause of this problem.

    I will try to connect from another WiFi (not my home WiFi) and check the status.

    Appreciate your help.

    02-08-2013 05:50 PM

Similar Threads

  1. no internet connection after upgrade
    By Zman1001 in forum Motorola Xoom
    Replies: 6
    Last Post: 11-08-2011, 11:45 AM
  2. How to use Portable Hotspot with no Internet Connection
    By hanexs in forum General Help and How To
    Replies: 0
    Last Post: 10-26-2011, 08:53 PM
  3. No Internet connection
    By Ascbrain in forum T-Mobile G2
    Replies: 2
    Last Post: 10-31-2010, 09:38 PM
  4. No internet connection, wifi, 3g, email, facebook...
    By shaester21 in forum Verizon Droid Incredible
    Replies: 2
    Last Post: 09-07-2010, 12:50 AM
  5. Twitter-Client No Internet Connection
    By MissMe in forum Android Apps
    Replies: 3
    Last Post: 05-05-2010, 07:28 PM