01-09-2014 09:43 AM
47 12
tools
  1. brgreene's Avatar
    I made the switch from the BlackBerry Tour to the Droid 2 today. I am extremely happy with the phone except for a problem with the WiFi.

    If I turn on the WiFi. It cuts on and off continuously. I must power the phone off and then back on to get WiFi to stay on. Now if the WiFi is on I can cut it off without a problem.

    Is this a problem with a setting or do I have a defective phone?

    Thanks,

    Brian
    08-12-2010 10:25 PM
  2. dbdynsty25's Avatar
    Go to your Wifi settings and press menu button and then advanced. Turn off the wifi sleep policy.
    08-12-2010 11:28 PM
  3. EJT's Avatar
    No, I don't think it's that. I just had the exact same thing happen to me. On/off/on/off, about every second or two, non stop. Can't do anything but shut the phone off to stop it. Not a huge problem, as it's only happened once, but I'd love to know what the cause is and how to fix it.

    Edit: Ok. It does it every time I turn the wifi on now. Dunno.

    Edit 2: Ok, weirdness. If you go into Wi-Fi settings, and turn Wifi on from there, it does the same thing as if you use the widget or the normal wifi on/off in settings.................however if you hit it again in the middle of its epileptic convulsions, it says scanning and then connects. It ONLY works from the Wifi Settings menu. Doesn't work from the widget or the regular wifi toggle in settings.
    08-13-2010 06:16 PM
  4. bworley50's Avatar
    Happening to me now. WTF.
    08-14-2010 12:47 AM
  5. bworley50's Avatar
    VZW phone rep told me to return mine to the store for a new in the box droid 2. Bought it online. He even called my local store to check stock. Good there. Return your phone. We both got bad phones.
    08-14-2010 01:29 PM
  6. vincey2kr1's Avatar
    have you tried the new phone? is it working?
    08-14-2010 01:46 PM
  7. karnovaran's Avatar
    Same issue here.. gotta be a software bug
    08-14-2010 02:49 PM
  8. karnovaran's Avatar
    I seem to have no problem activating and deactivating Wifi from the Wifi Settings area. So it's only the widgets that give me problems, which should be fixable.
    08-14-2010 03:34 PM
  9. Dirrk's Avatar
    you could also probably download a new wifi widget until it is fixed
    08-14-2010 04:45 PM
  10. karnovaran's Avatar
    Same issue with Beautiful Widgets too.. haven't bothered to try others.
    08-14-2010 06:01 PM
  11. SecretAsianMan#AC's Avatar
    Just happened to my phone too.
    08-14-2010 06:56 PM
  12. bworley50's Avatar
    Same problem with the new phone


    Same problem with the new phone. I don't know that
    much about routers. I have one. My Droids Eris, Incredible, and X have NOT done this. Somebody tell me how to fix this, please.
    08-14-2010 07:11 PM
  13. blulite's Avatar
    Same problem with me. I went into my router and change channel from Auto to 7 (auto set it at 6). All my neighbors are on 6, but other devices don't seem to care. The D2 wifi is rock solid now.
    08-14-2010 07:34 PM
  14. karnovaran's Avatar
    If everything works properly in Wi-Fi Settings, then I think we have to assume it's a problem with the software not the hardware.
    08-14-2010 09:07 PM
  15. bworley50's Avatar
    How do you go into your router? Presumably use the software it came with? Have a Cisco Linksys WRT400N.
    08-14-2010 10:23 PM
  16. jb31's Avatar
    I had the same exact problem. I tryed everything everyone mentioned with no success. My issues was directly related to the "encryption type" my router was using. I originally set my router to use wpa / wpa2 per. security mode and using "AES" as the encryption type. I did this becasue it is suppose to me more secure then the alternative "TKIP". Anyways, as soon as I re-configured my router to use "TKIP" as the encryption type all of my dropped signal problems were no more. Keep in mind I set everything else to mirror the suggestions from people on this forum. example: channel 7, etc ... so read through this whole forum and your issues should be taken care of.
    08-14-2010 10:49 PM
  17. maverick96's Avatar
    Same wifi problem here, the droid x I had never did this and the Evo I still have never does this...
    08-15-2010 12:32 AM
  18. billybob123's Avatar
    My droid 2 also is having problems with WiFi. It turns on and off repeatedly if the router is using N. When the router (DLink DIR-615) is set to "G only" I can connect. "G or N" does not work. So its great that I can connect to my home network with very specific settings, but not being able to use WiFi anywhere the router is broadcasting an n signal is not ok.

    Droid X people have been having similar WiFi-N problems since that phone came out, too, and these phones are nearly identical inside.

    Also, heard from verizon tech support by email, the guy claimed the Droid 2 only supports b/g. Um, huh?
    08-15-2010 04:34 PM
  19. brgreene's Avatar
    Since I started this thread my WiFi problems have cleared up. The more I used WiFi the less it would cut on and off before it would finally connect. Over the last few days I have not experienced the problem at all. It does not matter if I turn WiFi on with the Widget or from the settings menu.

    I have tried the WiFi on two different routers. At home I am using a DLink "N" router with G and N enabled. At work we have a Linksys "N" router with both G and N enabled.

    I hope the problem clears for everyone else.

    Brian
    08-18-2010 05:58 PM
  20. SpaceMuffin's Avatar
    Happens intermittently for me too. But always manages to make a connection after a dozen or so "I'm off..I'm on..I'm off..I'm on" iterations.
    08-19-2010 05:21 PM
  21. Kmcferrin's Avatar
    Same problem with me. I went into my router and change channel from Auto to 7 (auto set it at 6). All my neighbors are on 6, but other devices don't seem to care. The D2 wifi is rock solid now.
    That shouldn't matter, as any wifi device should be capable of scanning all of the channels looking for APs. You typically only set your AP channel if you are deploying a WLAN with multiple APs and need roaming and handoff capability. Or if there are a large number of APs in your area and you want to use a different slice of spectrum for bandwidth issues.
    08-20-2010 04:03 PM
  22. blulite's Avatar
    That shouldn't matter, as any wifi device should be capable of scanning all of the channels looking for APs. You typically only set your AP channel if you are deploying a WLAN with multiple APs and need roaming and handoff capability. Or if there are a large number of APs in your area and you want to use a different slice of spectrum for bandwidth issues.
    Agreed, shouldn't matter. But Droid2 works on 7, not on 6. Set to Auto and the router lands on 6.
    08-20-2010 09:03 PM
  23. Bushido Brown's Avatar
    I experienced this for the first time yesterday. Thankfully it was brief. This occurred while using Switch Widget Pro, so 3rd party widgets or not, it happens. Hopefully this latest update that got pushed out today patches that little bug, since regardless of how rare it happens, it can be very annoying.
    08-21-2010 12:18 AM
  24. jkcm725's Avatar
    Get the same thing and just got the phone friday, from what my store rep said they know of the issue.
    08-21-2010 10:31 PM
  25. vincey2kr1's Avatar
    Well the over the air update we had did NOt fix the wifi dropped/reconnecting issue Im having with my droid2. Never had this problem on my Pre or Evo. Did anyone fix this problem by exchanging thier d2?
    08-24-2010 02:06 PM
47 12
LINK TO POST COPIED TO CLIPBOARD