1. Rev2010's Avatar
    Traveling internationally and for some reason my D2 connects to every wifi connection I try (hotel, restaurant, etc) but simply will not transmit and receive any data. Every web page fails to load and I am starting to lose it. My wifes iPhone works perfectly and now I'm stuck with my Droid looking ******ed. I'm an IT tech for a living and have many years experience with wifi. It won't work with secured networks using wep keys nor fully open unsecure networks. It's almost like it keeps trying to connect via cellular. What the heck is up here?? It worked fine on my home network and I even removed it. So now my device is 100% completely useless abroad for any data use. Please help or I'm going to return this thing. Not having world phone usage is one thing.... but no wifi at all either??? Come on now.


    Rev.
    12-01-2010 02:25 PM
  2. blaisedinsd's Avatar
    I know nothing,

    But have you tried turning on airplane mode and then enabling wi-fi?

    When you go to settings>about>status what does it say for your mobile network?
    12-01-2010 05:09 PM
  3. ishore99's Avatar
    This might sound stupid, but did you advise Verizon that you were going out of the country?
    12-01-2010 06:04 PM
  4. thebizz's Avatar
    Wifi should still work out of country as always try a factory reset if that doesn't work take it to VZW and ask for another that's unacceptable
    12-01-2010 07:15 PM
  5. corydunbar's Avatar
    This isn't an out of the country thing. My Droid 2 has had the same problem in multiple buildings at USF that all have wifi. Some connet fine. And others just dance around a connection even though the signal is strong. I think I has something to do with the wifi router setup

    Sent from my DROID2 using Tapatalk
    12-01-2010 11:58 PM
  6. Rev2010's Avatar
    Some more info... The wifi worked in the airport because that side of the island has CDMA coverage. The French side does not. So I know for certain the wifi works when the phone has a cell signal, even if only voice with data roaming turned off. If there's no CDMA signal then the wifi will connect to networks but the data just won't work. I've tried everything, airplane mode, all data and network settings, and nothing works. What could it possibly be. Again I'm typing this from the wifes iPhone.


    Rev.
    12-02-2010 09:47 AM
  7. corydunbar's Avatar
    it sounds like there is a problem with the motorola software that links mobile data to wifi. It will have to be fixed in an update. because the motorola software skin was designed with the D2G and DPro in mind and they would have signal where you are, so they'd also have wifi. perhaps send motorola an email so they are aware of the issue.
    12-02-2010 11:26 AM
  8. Rev2010's Avatar
    I've solved it!!!!! Woohoo!! OK, so it turns out when you have a static IP address set, like I do for my home wireless, it turns OFF the Auto IP option under the advanced menu. Like an ***** I didn't even think to press the menu button so I didn't even realize that Advanced section was there. I found this out by connecting my boss' Droid X and my Droid 2 to our work wireless. I noticed immediately I was getting a 192. address and he was getting a 10. address. I eventually hit the menu button and got the advanced option that I hadn't seen before and when into it.

    That's where I saw the options "Enable Auto IP" and "Use Static IP". Static was checked but the only time I set up a static IP was when creating the wireless profile for my home network. When choosing "Enable Auto IP" and connecting to the work network I now got a 10. address and data flowed fine.

    So, at least I know what was causing this and how to resolve it. The only annoyance now is that I have to switch back to static manually each time using the home wireless, which I rarely use anyway for the phone. Every other phone I've had, like my iPhone, saves this info under a wireless profile so you never need to switch. Why is the static IP address I put in for my router becoming a global static IP for the phone?

    BTW, would a Mod be kind enought to put *SOLVED* in the title? This might come in handy to others having the same issue.


    Rev.
    12-09-2010 09:20 AM
  9. markm's Avatar
    Nice sleuthing Rev. I would have guessed that setting to be on the profile level also. (Fortunately, I leave my wireless on auto IP including the home network). Thanks for updating the thread with the solution.
    12-09-2010 09:25 AM
LINK TO POST COPIED TO CLIPBOARD