1. shadao shai's Avatar
    My phone was stuck on the bootup motorola icon. I could get into stock recovery and bootloader. Read many posts about using RSD Lite to flash a stock SBF file to my phone. I followed the instructions to the letter but every time it fails at switching phone to bp pass through mode.

    Now whenever I boot it only goes to the bootloader:


    Code Corrupt

    Battery OK
    OK to Program
    Connect USB
    Data Cable"

    I heard that there was a way to flash the phone with SBF inside of Linux instead. I was wondering if my problems might simply be driver related and if this might fix it? Also what is the process to flash a SBF file from Linux?

    Thanks alot.
    01-29-2011 05:47 PM
  2. corydunbar's Avatar
    make sure you have the latest SBF i believe it is v2.3.20

    Update: sorry 2.3.340 is whats currently on the X.
    01-30-2011 08:23 PM
  3. shadao shai's Avatar
    So I used a ubuntu live cd and flashed my phone from the terminal it seemed to complete and the phone rebooted. It then loaded up the Motorola boot logo and I thought this nightmare was finally over, but unfortunately after about 3 seconds or so it goes from the Motorola logo straight into the Bootloader. Only now the "Code Corrupt" message is no longer in the bootloader.

    I can now boot into the stock recovery. Not sure why the SBF flash seems to have worked and not worked at the same time. Maybe now that I can get into recovery I can flash an update.zip to my phone?

    Please help.
    02-01-2011 01:06 PM
  4. corydunbar's Avatar
    It sounds like you need to retry the SBF
    02-02-2011 11:36 AM
  5. blaisedinsd's Avatar
    make sure you have the latest SBF i believe it is v2.3.340
    Will this work if your rooted and running something else?

    I have been running the Motoblur leak Version.3.0.0.A955.Verizon.en.US and I guess I didn't properly do a backup before I did it.

    I was wondering how to go back to stock if I need to....I have had some occasional issues with the screen not coming up and the phone not turning on.

    I downloaded the SBF but haven't tried it....will it work?
    02-04-2011 02:19 PM
  6. corydunbar's Avatar
    Unfortunately, I think when you switched to the 3.0.0 ROM you upgraded what your e-fuse checks. So until Motorola leaks an SBF for the 3.0.0 you're out of luck. Don't hold me to it, but the TBH may be able to help you out.

    sent from my Motorola DROID X / DROID 2
    02-04-2011 04:54 PM
  7. blaisedinsd's Avatar
    I was able to use the SBF with no problems after 3.0

    I use VRZ_A955_2.3.20_1FF_01.sbf

    What is v2.3.340 ? Is that a VZW update?
    02-07-2011 11:35 PM
  8. corydunbar's Avatar
    sorry i mixed up my Droid 2 and Droid X updates. the 2.3.20 is the latest SBF for the Droid 2.
    02-08-2011 02:13 PM
  9. shadao shai's Avatar
    I found an interesting post on xda about reflashing the actual bootloader and then flashing the system sbf. Finally flashing the bootloader sbf one more time should get the phone to actually boot again.

    xda-developers - View Single Post - Motorola Droid 2 Bootloader and 2.2 Stock SBF's

    Just wondering of you've ever heard of this or have any idea why it would work? I haven't been able to try it yet. I've been using my friend's battery evertime mine runs out from trying to flash over and over, and he's been busy the last few days.

    Thanks for all the help.
    02-15-2011 12:50 AM
  10. corydunbar's Avatar
    dont hold me to this
    but i think that process should work. Your hardware is likely not at fault. So all you have to do is get official software booting up again.
    shadao shai likes this.
    02-15-2011 02:52 PM