1. Phil Nickinson's Avatar

    Windows only for now, but it's quick and painless.

    1. Put your phone in USB debugging mode.
    2. Connect your Droid 4 to the computer via USB
    3. Make sure you have the latest drivers and what-not (get them here if you don't)
    4. Download Dan Rosenberg's exploit
    5. Extract to a folder, and double-click run.bat.

    That's it. Easy as pie. And (cough) free.
    Renee09, atminside and Eric Brich like this.
    02-11-2012 12:15 PM
  2. cmonson91's Avatar
    I have tried to root my phone but it will not root. I followed all the directions and ran and administrator when i run it it says it failed to do every thing
    02-18-2012 12:17 PM
  3. Blackhawk33's Avatar
    I have tried it like cmonson91 but is getting the same message. Anyone has an answers?
    02-21-2012 10:34 AM
  4. k1ick's Avatar
    All right im not a complete noob at this but i need some help: I would like to get the Mac version of this but for some reason when i download it from the website it does not include the adb.osx file which im assuming is the mac version of adb.exe and when i execute "./run.sh" it goes crazy trying to find the file. Im not sure why it is not included or if i have to some how convert the adb.exe file to .osx which im pretty sure is impossible.
    02-22-2012 04:06 PM
  5. atminside's Avatar
    Great writeup, this is what I used on my Droid 4.
    03-03-2012 08:03 PM
  6. motorcycle_monkey's Avatar
    How about unrooting if you need to return your phone? I would love to try this, but want to be sure it is reversible. I suppose a master reset would do it, no? Cheers
    03-15-2012 08:11 AM
  7. gaudenti's Avatar
    I have the same question. From what I've read, you do a Nandroid backup?

    But to do a Nandroid backup, you have to first root the phone? So won't the backup be also rooted?
    03-23-2012 02:57 AM
  8. hyrulejedi86's Avatar
    How do you unroot now that it's rooted? I've rooted so that I can move all my files back from the old droid and want to unroot now.
    03-29-2012 07:00 PM
  9. gaudenti's Avatar
    I think this unroots?

    goto Goo.im Downloads - Browsing mattlgroff
    and download "Droid4Utility0.3.zip"
    03-30-2012 12:24 AM
  10. cdbeiser's Avatar
    I'm new to the whole smart phone droid world... What does root do? why should I root the phone and will it help me with mobile hotspot?
    05-23-2012 12:03 PM
  11. 4jws's Avatar
    I have tried a bunch of different ways to root my droid 4 on my mac but still get the "No such file or directory" Are there any other ways to root it? Can I root it any other way?
    06-16-2012 05:58 PM
  12. MERCDROID's Avatar
    I have tried a bunch of different ways to root my droid 4 on my mac but still get the "No such file or directory" Are there any other ways to root it? Can I root it any other way?
    I used my friend's mac to root my Droid 4. It does work but it's a little tricky. Just download the files from Dan Rosenberg's website, and then open terminal on a mac and invoke ./run.sh from a shell. It took me all of 15min. Good luck
    06-24-2012 03:21 AM
  13. biboon1's Avatar
    Rooting app is not moving past *daemon started successfully*. Any suggestions? (I'm in debugging, charge only mode, and connected via USB)
    06-29-2012 11:03 AM
  14. joyceface2's Avatar
    after success in rooting do you uncheck the usb debugging option?
    09-21-2012 11:01 AM
  15. IC3D's Avatar
    After successfully extracting the Dan Rosenberg's exploit.zip , and running the run.bat and adb.exe, it went thru the processes and said complete, rebooted my phone and all, but I see nothing different, no SuperUser installed, nothing. Tried to download an app for only rooted users and no luck, said phone didn't have root access. I'm no rookie @ this either.. I hack/mod Droid X, X2, iPhone's and was the first person to turn a Sprint iPhone4S into an AT&T iPhone4S, fully functional [which on plenty of forums tell you that is impossible.. it's not! (will post how I did it some day here shortly.. Just became a member... BUT....So I know what I'm doing here, yet having no luck. Any advice?
    11-18-2012 11:09 PM
  16. kingben8's Avatar
    Did not work, getting same message as everyone else.
    12-08-2012 05:44 PM
  17. wiill's Avatar
    what do we do after we click the link to get the drivers
    12-14-2012 02:46 PM
  18. Jimgantic's Avatar
    [TOOL][ROOT/UnROOT][Razr] EternityProject EasyRootICS v1.5 [Win/Linux] - xda-developers

    I had the same problems this worked GREAT!!! May have to finger and play around like me.....but I got it!!!!! Good Luck!
    Loved Disciple likes this.
    02-08-2013 12:19 AM
  19. joyceface's Avatar
    can't get the link to the exploit to work?
    06-28-2013 02:00 PM
  20. Nick Monreal's Avatar
    I got the exact same response when trying to root my Droid 4. Not understanding the problem. I have the latest drivers installed and USB debugging enabled. So frustrating.
    09-24-2013 12:15 PM
  21. cantide1's Avatar
    i keep trying to root my droid 4
    i did all the stuff and it said on the first it said failed to put motofail in data/local/motofail by not allowed to do so this is my first root am i doing something worng
    11-16-2013 10:07 PM
  22. atticusnari's Avatar
    Uhh, ran a virustotal scan and it came up a **** ton of malware
    07-15-2019 08:56 PM
  23. B. Diddy's Avatar
    Uhh, ran a virustotal scan and it came up a **** ton of malware
    What are you referring to? This is a 7 year old thread about rooting the ancient Droid 4, and the most recent post was in 2013.
    07-16-2019 03:53 AM

Tags for this Thread