1. dcs0582's Avatar
    Is there an option somewhere to force the keyboard backlight on when it is extended for typing. I don't use the hardware keyboard that often, but when I do, I'd like the backlight to be on each time, all the time, when the hardware keyboard is extended regardless of ambient light level.

    Thank you kindly.
    07-10-2012 02:00 PM
  2. Luce2012's Avatar
    This was a question on another thread which prompted me to register for this forum as noone replied with the CORRECT answer. I felt bad for the person as he was given so much bs. Now that I registered I lost that thread and can't figure how to get back to it? So, if anyone is reading, the Droid 4 keyboard light is a BUG in how it is setup. Most people however are satisified with reasonable acceptance with the performance of their keyboards but going into Settings/Display/Brightness - if you just got your Droid 4 or never changed this setting most likely the Auto box is checked. REMOVE THE CHECK. It is primarily the auto "dimmer" setting that is making your keyboard randomly go on /off for no reason. On mine it is a BUG because the theory behind auto dimmer is the phone is to adjust in lighting to bring the keyboard on when necessary. Well I consider a completely black garage a good time for it to come on, and it did not. It would randomly appear then disappear in seconds. so much so it is enough to drive one bonkers watching it go on /off without changing anything.

    If you remove the auot dimmer, MOST people find that is enough. Adjust the dimmer setting to the furthest right (brightest). That should do it. Your light will now work every time you use the keyboard. I also adjusted the time out light on Display setting to alittle longer but it is the DIMMER that is affecting the keyboard.

    Now, the reason I say "most" are satisfied once they change the dimmer to off auto, is because my lovely brand new Droid 4..3 days of working beautiful has now decided it doesnt like the non auto and is randomly shutting off anyway. Not sure why.

    The solution..not one. I did get a suggestion to go in safe mode (this doesnt do anything to your top menu) so it is harmelss. In safe mode, uncheck the auto dimmer again and that (hopefully) will stick once you turn phone on regular. But I have not tried that yet.

    My phone randomly starts working again later in day. I am so frustrated but will go to the iPhone if this continues to happen one more day.

    I am on day 5 tomorrow. 2 days it worked unchecking the dimmer. Some people say if you go back an check then un-check the dimmer setting when it starts to act up (again) that usually does it. Or turn the power on/off but none of that worked. So I am left with changing the settings but it still is not coming on until some time late in day..then its as if everything works fine???

    Some teck geek told me he thought it was random apps running effecting my brightness setting (evern though I had it un checked to auto, and had my brightness set to all), an app was causing an over ride so phone still thought it was on auto. or it wasnt registering any setting hense why it wasnt turning on at all in some cases. Either on/off in seconds of itself or nothing or it would randomly stay on.

    But I have not installed any apps. Everything is still factory set settings and nothing has been done to it. I just put my contacts in and made minor setting changes thta's it.

    I am still under 14 day review so my next phone is the iPhone as this is a known issue and the fact no Tech person from Verizon Wireless OR Motorolla has been able to help is beyond fathom since this is a feature I paid for.

    to say "live with it" when you have it for 2 full days working great then to suggest it is the way it is is ridiculous.
    07-15-2012 04:32 PM
  3. Phil Edwards's Avatar
    It is a gyro issue. Just hold the phone straight up and down either horizontally or vertically and, according to which lights you want to come on (keyboard or quick keys (home, search, back, menu)) will come on and stay on. At least that is the fix that worked on mine.
    10-18-2012 09:14 PM