1. fumeii's Avatar
    I've had this phone for a while but I am completely new to this rooting concept. I tried some 'one-click' rooting such as motofail and razrs edge but none seem to work. I have made sure to USB Debugging and made sure to connect the phone as a media device. I have installed the latest drivers as well. I have searched for a while now yet I have not found an answer. This is what appears on my command prompt. Please help!

    [*][*] Motofail: Universal Motorola Android Root Exploit (Windows version)[*] by Dan Rosenberg (@djrbliss)[*][*] Tested on Droid 3, Droid Bionic, Droid RAZR, and Droid 4[*][*] Before continuing, ensure USB debugging is enabled, that you[*] have the latest Motorola drivers installed, and that your phone[*] is connected via USB.[*][*] Press enter to root your phone...
    Press any key to continue . . .[*][*] Waiting for device...[*] Device found.[*] Deploying payload...
    failed to copy 'motofail' to '/data/local/motofail': Permission denied
    Unable to chmod /data/local/motofail: No such file or directory[*] Owning phone...
    /system/bin/sh: /data/local/motofail: not found[*] Rebooting device...[*] Waiting for phone to reboot.[*] Attemping persistence...
    remount failed: Operation not permitted
    failed to copy 'su' to '/system/bin/su': Read-only file system
    Unable to chmod /system/bin/su: No such file or directory
    link failed Read-only file system
    failed to copy 'busybox' to '/system/xbin/busybox': Read-only file system
    Unable to chmod /system/xbin/busybox: No such file or directory
    /system/bin/sh: /system/xbin/busybox: not found
    failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
    stem[*] Cleaning up...
    /system/bin/sh: /data/local/motofail: not found
    rm failed for /data/local/motofail, No such file or directory[*] Rebooting...[*] Exploit complete![*] Press any key to exit.
    Press any key to continue . . .
    taariqq likes this.
    02-21-2014 02:31 PM
  2. sd_shadow's Avatar
    Only razr edge will work on Droid 4 with ics
    Only razr blade will work on d4s jellybean
    Motofail only worked with gingerbread

    Sent from my XT862 using Tapatalk
    02-21-2014 02:34 PM
  3. sd_shadow's Avatar
    For razr blade root
    if you are seeing
    failed on '/data/logger' - Permission denied
    mkdir failed for /data/logger, File Exists
    Unable to chmod /data/logger: Operation not permitted

    try these steps
    -Settings > Apps > Smart Actions > Clear data
    -Settings > Storage > ≡ Button > USB computer connection > Select "Media device (MTP)
    -Run the exploit again.
    every time it says "rebooting" as soon as the device goes off, disconnect usb, waited for device to fully boot before reconnecting usb and then it will continue the process.

    It's not unusual for virus scanners, to see rooting tools as viruses or trojans, because they often are.
    a Virus scanner may remove the exploit used in gaining root access, without any notification
    If rooting is failing, try turning off virus protection before downloading and during rooting.

    Sent from my XT862 using Tapatalk
    Zosoled and taariqq like this.
    02-21-2014 02:39 PM
  4. fumeii's Avatar
    I did exactly what you said, worked perfectly. Thank you so much
    02-21-2014 03:47 PM
  5. Zosoled's Avatar
    This was what finally worked for me. Thank you!
    08-25-2014 11:33 PM
  6. sd_shadow's Avatar
    Next time just use Saferoot
    08-26-2014 09:22 AM
  7. taariqq's Avatar
    Incredible little hint. May Allaah reward you.
    06-14-2015 02:37 PM

Similar Threads

  1. If I root....
    By AxlMyk in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 4
    Last Post: 02-22-2014, 12:12 AM
  2. Droid razr m / Moto x
    By methedz in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 02-21-2014, 04:35 PM
  3. Optimizing Droid Bionic with no cell plan
    By bloodninja212 in forum Bionic Rooting, ROMs, and Hacks
    Replies: 0
    Last Post: 02-21-2014, 02:24 PM
  4. Charging Issue
    By monotok in forum Sony Xperia Z1 Compact
    Replies: 1
    Last Post: 02-21-2014, 11:55 AM
  5. root
    By aungzaw7097 in forum Samsung Galaxy 3
    Replies: 0
    Last Post: 02-21-2014, 09:58 AM