1. dirtyterp's Avatar
    My Maxx has no problem recognizing when I am driving and states that Assist is in driving mode in the notification bar. However, even though I have all the settings checked for it to read text messages out loud. I have had no success. Has anyone else had this problem or know how to go about fixing the issue? Thanks
    09-14-2013 03:41 PM
  2. 18t's Avatar
    the one time i have tried this so far, i believe it asked me to state a command if i wanted it read out loud. which i gave and it read the message. didnt experience any problems on the one occasion.
    09-14-2013 03:59 PM
  3. jamontoast1291's Avatar
    I'm not sure if it depends on the media volume or the notification volume, but if it's off/quiet that might be why
    09-16-2013 10:59 AM
  4. SteelGator's Avatar
    the one time i have tried this so far, i believe it asked me to state a command if i wanted it read out loud. which i gave and it read the message. didnt experience any problems on the one occasion.
    That is correct, it will tell you you have a text message and who it is from, then is say to say listen if you want the message read. After it reads it, you are asked if you want to reply with a message that you are driving. I think it tells you to say send to do so.
    This has worked very well on my phone.

    Sent from my XT1080 using Tapatalk 4
    09-16-2013 12:45 PM
  5. mm356's Avatar
    I had this same problem with a Moto X. Yesterday I finally got it to read aloud simply by toggling bluetooth on, even though I had nothing to pair it with. Then it worked great. Until I quit driving, that is, after which it still kept announcing EVERYTHING. Power cycled - still announced. Uninstalled Dragon - still announced. Got on phone with tech support and cleared the Assist app data - still announced everything. Cleared all Google app data - still announced everything. Later on while ending a drive I specifically clicked "I'm not driving" and it went back to announcing nothing anymore (yes, even when driving). So my experience has been an all or nothing - Assist detects I'm driving pretty well, but the hands-free announcements seem to be totally independent of that.

    Last night I worked with Level 2 support and he ended up clearing up some more app data and today it seems to be working OK. But now it seems to have trouble determining when I stop driving. The L2 guy said he thought it was having trouble with the GPS part of it. Said he'd look into it some more and call me back this evening. If I get him on the phone again I'll ask him specifically what he cleared to at least get the announcements to work properly today.

    So today the Moto X properly knows when I start driving and announces properly, but when I'm done I need to tell it I'm not driving anymore and it will silence the announcements as it should. Would like to have to not click that, but compared to the "all or nothing" I was seeing before I'll take it.

    But what bugs me most is that this feature is one of the main selling points and one of the main reasons I chose this over the LG G2. If they can't get this major feature right, I'm wondering if I should switch while I still can...
    09-16-2013 12:53 PM
  6. mm356's Avatar
    Well I'll be... level 2 just called back 5 hours earlier than they were supposed to!

    Rep said he actually cleared out all data/cache from all Motorola Assist apps under "Apps->All". When I cleared it earlier I just cleared only the main "Motorola Assist" listing. So definitely try this.

    In regards to not detecting when I've stopped driving, he said he thinks it's a problem with the phone getting the location information from the Verizon network. He suggested to go into location services and only use Google and GPS location services and to un-check the Verizon services. I haven't tried this yet, but it sounds logical to me to eliminate any middle man that I can. I'll report back after a day or two and see if things are good.

    I'd love to hear back to see if clearing the data and cache also works for you. Would love to know if it's a solid fix to the problem or if I just got lucky.


    EDIT: I don't see an option to un-check any Verizon services, so not sure exactly what to do here. I only see options for satellites and Google, both of which I want. Is this even possible? Anyone?
    09-16-2013 01:21 PM
  7. Eclipse2K's Avatar
    mm356, it appears Motorola doesn't have this option in the Droid Maxx. All other phones I've used have had "Use Verizon Towers" for location access but not this one.

    Sent from my Motorola Droid Maxx using Tapatalk 4
    09-16-2013 02:36 PM
  8. doogald's Avatar
    This post from motorola's forums has some information, as well as a "pain in the neck" work-around:

    https://forums.motorola.com/posts/1d...=727975#727975

    I have some help from the experts.

    There are two possible causes for calls/text being announced when you are not in a moving vehicle:

    • Drive detection falses. If you have the Talk-to-Me options enabled in Assist, check is to see if the drive mode detection notification (the icon that looks like a road) is in your notification bar. If it is and you're not driving, "swipe down" on the notification curtain. Swipe down again on the notification item itself. You'll see the "I'm not driving" option. Select that and the device will get out of drive mode.
    • We're aware of a rare condition when calls and text will be announced even when you can't see the "drive mode" notification on the status curtain. We're fixing this in the next upgrade. (The simplest way to get out of this situation -- and it's not that simple -- is to leave Assist's drive mode settings on, get in a vehicle, allow drive mode to kick in again. When you do that, Assist will get back to the correct state. After the issue is fixed, you should rarely encounter the issue again. Yeah, I know. Not something anyone is eager to do but we wanted to put it out there.)

    The next software release will also reduce the those false drive detections (first cause above), and as I said, it should fix the second one.
    09-16-2013 02:40 PM
  9. gamefreak715's Avatar
    The only thing I've noticed is if you check to resume music playback, it'll start playing music even when I didn't have anything playing beforehand. Is it supposed to do that?

    Posted via Android Central App
    09-16-2013 03:06 PM
  10. mm356's Avatar
    mm356, it appears Motorola doesn't have this option in the Droid Maxx. All other phones I've used have had "Use Verizon Towers" for location access but not this one.

    Sent from my Motorola Droid Maxx using Tapatalk 4
    Interesting. While I sincerely appreciate the help tech support gave me, you'd think Motorola support would know this about Motorola devices.
    09-16-2013 03:34 PM
  11. mm356's Avatar
    So the app didn't detect me driving on the way home yesterday, despite traveling 75 mph on the interstate, but after clearing all cache and data again it seems to be both detecting my driving properly and properly announcing/not announcing now automatically. Definitely appears to be a software bug that'll hopefully get fixed soon.
    09-17-2013 06:59 AM
  12. lordbah's Avatar
    The only thing I've noticed is if you check to resume music playback, it'll start playing music even when I didn't have anything playing beforehand. Is it supposed to do that?
    This might be why I occasionally see a notification from Play Music with Unknown Artist and no song. I went to Assist and Resume Music was checked, even though I believe I had unchecked it before. Unchecked it again and we'll see if that problem goes away. Even so, this would mean it thought I was driving at times when I definitely wasn't.
    09-19-2013 06:26 AM

Similar Threads

  1. Anyone else spooked by all these problems?
    By mkreef in forum Moto X (2013)
    Replies: 94
    Last Post: 09-16-2013, 12:55 PM
  2. Screen problem
    By Faithful9 in forum HTC One M7
    Replies: 4
    Last Post: 09-15-2013, 05:12 AM
  3. Battery Problem?
    By BonMay in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 09-14-2013, 06:06 PM
  4. problem with connecting note 2 to desktop
    By viper31573 in forum Verizon Galaxy Note 2
    Replies: 1
    Last Post: 09-14-2013, 09:29 AM
  5. problem with reset the call option to the defaults.
    By Majd Yonan in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 09-14-2013, 07:51 AM
LINK TO POST COPIED TO CLIPBOARD