1. beeare's Avatar
    I didn't realize What's App wouldn't work on Art so I went back to Davlik.

    Unfortunately, while trying to get it to work in Art, I uninstalled it and then went back to Davlik where I tried to reinstall it.

    Now when I tried to reinstall, it won't work and I keep getting this error message.

    Somebody please help. What do I need to do to get it to install properly.?

    Sent from my XT1080 using AC Forums mobile app
    Attached Thumbnails Problem with WhatsApp after Art to Davlik-1390691665191.jpg  
    01-25-2014 06:14 PM
  2. doogald's Avatar
    I found this: https://code.google.com/p/android/is...etail?id=61916

    Last comment from somebody at Google:

    I'll reiterate that this is not the fault of the WhatsApp application. The ART verifier was blocking the installation of this app, but we are going to fix ART to address this issue. I'll update this bug when the fix is in AOSP.

    The issue with installation failures for Dalvik or ART causing an app not allowing the app to be installed in the future is a serious bug, but not a new issue in Android 4.4 KitKat. The only solution that I know of for a non-rooted device is to factory reset (aka wipe data). If you root, removing the /data/app directory seems sufficient to allow reinstall.
    I've heard other people say the same - that a switch from ART back to Dalvik messed up a few apps and the only solution that worked was a factory data reset.

    If you are rooted you should be able to delete the folder for whatsapp in /data/data/whateverTheWhatsappFolderIs but you probably need to be rooted for that. I just tried to look in /data with Astro and it comes up empty, so I do think you need root for that solution.

    Somebody mentioned that they could successfully install from the play store on the web, but I'm not sure if I buy that.
    01-25-2014 08:38 PM
  3. beeare's Avatar
    Found a fix last night that I didn't see in any forums.

    I went into settings/apps/download manager and cleared data. It worked for me and I was able to reinstall whatsapp.

    Hopefully this allows others with the same problem to fix this simply, because none of the other options above seemed to work for me, and this is way better than a full reset.

    Sent from my XT1080 using AC Forums mobile app
    doogald and xweb10 like this.
    01-26-2014 02:17 PM

Similar Threads

  1. Problem with Viber 4.2
    By usdima in forum General Help and How To
    Replies: 23
    Last Post: 05-14-2015, 05:06 PM
  2. Home button goes to home screen after 4.4 update
    By Christopher Ford1 in forum Android 4.4 KitKat
    Replies: 16
    Last Post: 04-01-2014, 10:44 AM
  3. Looking for guide to update from 4.2 to latest (4.4.3?) on an already rooted Nexus 7
    By Louis6507 in forum Google Nexus 7 (2012) Rooting, ROMs, & Hacks
    Replies: 4
    Last Post: 01-26-2014, 11:11 PM
  4. Samsung Galaxy S4 Issue Download to SD Card Unsuccessfull
    By Maynor Bustamante in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 01-25-2014, 08:52 PM
  5. Can I transfer apps to SD Card?
    By DominusHD in forum Droid RAZR M
    Replies: 2
    Last Post: 01-25-2014, 05:45 PM