1. kobe24b's Avatar
    Well... I have a Droid 2.2.3. Whenever I connect it to my windows 7, it shows up as "device has malfunctioned, device.. unknown" everytime. I have tried reinstalling drivers, etc but the Computer never recognizes it as a Motorola device.

    Also, my phone doesn't charge when the phone is on and connected to the pc, but when the phone is connected to the PC and I turn the phone off, it charges (but then it wont turn on unless I disconnect it).

    Also, whenever it is connected, it never shows the USB icon/ or anything in the notification bar. So, I havent been able to root it yet. I have tried on 3 other computers (XP, 7, 7) and 3 other USB cables. Same results.

    I want to root my Droid 2.2.3, I have tried z4root app, but it doesn't support 2.2+

    How can I root my Droid without a PC, can I use terminal, etc and do it on the phone itself?
    03-11-2012 08:28 PM
  2. chris mart's Avatar
    Before connect your device install its drivers. If your PC doesn't have require drivers then operating system can't identify new hardware (your phone). So first do it. Then use any root application.

    I think "z4root" is good but its not work with latest devices. Never mid give a try.
    03-12-2012 06:30 AM
  3. kobe24b's Avatar
    Tried installing drivers, then connecting. Didnt work. Same result. Phone screen turns on when I connect it, but nothng shows up in notificaiton bar and phone doesnt charge either.
    03-12-2012 01:08 PM
  4. cammykool's Avatar
    Phone should charge regardless

    Sent from my iPad using Tapatalk
    06-21-2012 01:08 PM