1. anon(14828)'s Avatar
    I have a droid running stock on 2.1 that i updated to when it was pushed to my phone but i have this echo problem i hear my self loudly in ear. I have exchanged it few times and yet yielded no change. ive heard you can change the vacode and yet changed nothing, i have done soft and hard resets and nothing, any ideas should i go back to blackberry or exchange it again.

    p.s Verizon with full bars and its everytime and no matter calling 1800 numbers or cell lines or home numbers

    04-07-2010 02:50 PM
  2. shotgunbelly's Avatar
    Dont go back to BlackBerry first off. Although I Dont know why your phone is echoing, you could try dialing *228 and choosing option 2 to update your PRL. I can say with all honesty though that the 2.1 update was very disappointing to me. I am SO happy that I went back to 2.0.1 through RSD lite. the procedure can be found on droidforums.net , anyway, I am back rooted again and using adamz's smoked glass rom, overclocked a little and able to tether if I want to. My Droid is so much smoother, battery life is awesome, and the UI looks better. 2.1 blew, in my opinion, and I will never go to it unless it is a custom version of it that I can apply myself. I hope your echo issue gets better. I'm guessing it didn't echo before the update? Maybe you should look at reverting to 2.0.1 its not hard to do. Verizon uses this method when your phone wont boot. there are ways to shut off update notifications also just search these forums and you will find it :-)
    04-07-2010 05:06 PM