06-15-2017 09:04 PM
42 12
tools
  1. Robin Hebert's Avatar
    While reactivating my current DT2, it would get data but not make or receive calls. I had to remove and reinsert the SIM to get it to place calls. I think this is the source of the problem. There is some defect inside this phone where it is losing connection with the SIM card.
    Wow well so glad you are getting that resolved.

    Posted via the Android Central App
    11-13-2015 06:36 PM
  2. viper8315's Avatar
    I should have posted sooner, but as a last ditch effort did you try a FDR?

    Posted via the Android Central App
    11-13-2015 10:09 PM
  3. Sandman333's Avatar
    Yes, we tried a FDR. Made no difference. It's a physical problem of the phone losing connection with the SIM.
    11-13-2015 11:07 PM
  4. viper8315's Avatar
    Gotcha, sorry to hear. I hope your replacement device works flawlessly. It's a great phone. Good luck.

    Posted via the Android Central App
    11-14-2015 10:42 AM
  5. udazavlanje's Avatar
    That's why I buy only from Best Buy. 2 week headache free returns

    via AC App on
    VZW Moto X DE/N7
    11-14-2015 01:53 PM
  6. doogald's Avatar
    That's why I buy only from Best Buy. 2 week headache free returns

    via AC App on
    VZW Moto X DE/N7
    With Motomaker customization?
    11-14-2015 03:51 PM
  7. Sandman333's Avatar
    Got the replacement DT2 and activated it today. So far no more dropped data or calls. The old phone was slowly getting worse. This is much better.

    Posted via the Android Central App
    11-21-2015 03:01 AM
  8. viper8315's Avatar
    Got the replacement DT2 and activated it today. So far no more dropped data or calls. The old phone was slowly getting worse. This is much better.

    Posted via the Android Central App
    Glad to hear, what design did you get? I hope things go much better for you.

    Posted via the Android Central App
    11-21-2015 06:27 PM
  9. Robin Hebert's Avatar
    Got the replacement DT2 and activated it today. So far no more dropped data or calls. The old phone was slowly getting worse. This is much better.

    Posted via the Android Central App
    Wunderbar

    Posted via the Android Central App
    11-21-2015 06:30 PM
  10. Sandman333's Avatar
    Glad to hear, what design did you get? I hope things go much better for you.

    Posted via the Android Central App
    Same as before- black/champagne frame, royal blue accent, black ballistic nylon back, and "By your command..." welcome phrase. I'm going to avoid a FDR at all costs on this phone, as that wiped out my welcome phrase last time and I do not see any way to get it back.
    11-21-2015 06:58 PM
  11. Robin Hebert's Avatar
    Same as before- black/champagne frame, royal blue accent, black ballistic nylon back, and "By your command..." welcome phrase. I'm going to avoid a FDR at all costs on this phone, as that wiped out my welcome phrase last time and I do not see any way to get it back.
    Same thing happened to me. Lost the phrase.

    Posted via the Android Central App
    11-21-2015 07:09 PM
  12. viper8315's Avatar
    Same as before- black/champagne frame, royal blue accent, black ballistic nylon back, and "By your command..." welcome phrase. I'm going to avoid a FDR at all costs on this phone, as that wiped out my welcome phrase last time and I do not see any way to get it back.
    Hey Sandman, how's the new phone working out?
    11-25-2015 10:06 PM
  13. Sandman333's Avatar
    Hey Sandman, how's the new phone working out?
    Second defective phone I've gotten. This one has no problem with network connections, but the vibration motor is loose inside and it makes an annoying buzzing sound every time it activates. I always get the defective products.
    11-26-2015 05:14 PM
  14. carter17's Avatar
    So I'm not the only one this really sucks because I use my device as a hotspot/router at home for internet and it will have good signal the just go to 3g. I have to turn airplane mode one for 2 seconds then turn it right back off there is 4g. It would seam that it would be a software issue but if some of you have got new phones and it quit doing it and they have the same software as the old one then I guess it's hardware

    Posted via the Android Central App
    11-28-2015 05:16 PM
  15. carter17's Avatar
    So I'm not the only one this really sucks because I use my device as a hotspot/router at home for internet and it will have good signal the just go to 3g. I have to turn airplane mode one for 2 seconds then turn it right back off there is 4g. It would
    seam that it would be a software issue but if some of you have got new phones and it quit doing it and they have the same software as the old one then I guess it's hardware

    Posted via the Android Central App
    11-28-2015 05:16 PM
  16. Sandman333's Avatar
    In my case it wasn't that it was dropping to 3G, it was dropping to absolutely nothing. No signal at all.
    11-28-2015 10:29 PM
  17. Wellsy01's Avatar
    My ZTE BLADE A110 keep's losing service & don't know why it how & it's getting annoying
    06-15-2017 09:04 PM
42 12

Similar Threads

  1. Why can't my G-Tab 4 connect to wifi?
    By AC Question in forum Samsung Galaxy Tab4 7.0
    Replies: 1
    Last Post: 11-25-2015, 09:45 AM
  2. Losing sound on Nexus 9 w/ Marshmallow
    By rllor in forum Google Nexus 9
    Replies: 8
    Last Post: 11-16-2015, 05:44 PM
  3. Why won't my Gear S2 smartwatch connect to my Galaxy S6?
    By AC Question in forum Samsung Gear S2
    Replies: 1
    Last Post: 11-12-2015, 08:46 PM
  4. Why won't my Gear S2 connect?
    By AC Question in forum Samsung Gear S2
    Replies: 1
    Last Post: 11-11-2015, 11:28 AM
  5. Why does my Galaxy S4 Mini keep losing home wifi?
    By AC Question in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 11-11-2015, 11:08 AM
LINK TO POST COPIED TO CLIPBOARD