12-01-2015 10:09 PM
61 123
tools
  1. Moto0685's Avatar
    Anyone coming from the original Turbo notice that with the screen on, the Turbo 2 drains significantly faster than the original Turbo? Sadly, the difference is significant.
    I would think the it being a Quad HD screen would be the culprit, but yes the screen does cause a big hit on the battery, but I do not see any crazy drains comming from the radios, usually WiFi and cell can cause mass drains also

    Posted via the Android Central App
    11-26-2015 12:46 PM
  2. 1901Madison's Avatar
    I would think the it being a Quad HD screen would be the culprit, but yes the screen does cause a big hit on the battery, but I do not see any crazy drains comming from the radios, usually WiFi and cell can cause mass drains also

    Posted via the Android Central App
    Agreed. Outside of the screen, battery life is just as good as the first Turbo. But the screen drains battery much faster than the OG Turbo.
    11-26-2015 01:09 PM
  3. Masheen's Avatar
    Also depends what your adaptive brightness is on, but apples to apples it does drain a bit faster.
    11-26-2015 01:11 PM
  4. RichardJTesla's Avatar
    I have not been impressed with the battery life. honestly I am seemingly getting the same life as I do on my note 5.
    11-26-2015 01:35 PM
  5. CharlieL3's Avatar
    I haven't seen the screen drain problem at all. The Turbo is a quad screen as is the Turbo 2. The Turbo 2 has a slightly larger screen, but it has the same resolution, so the only real difference would be the larger backlight, and that shouldn't cause that much of a drain.
    11-26-2015 02:42 PM
  6. KeithLa's Avatar
    Yes I definitely notice faster battery drain while in use, vs. my Droid Maxx. Overall, not a big battery life improvement for me, which has been an unpleasant surprise, esp. vs. two year old phone.

    Posted via the Android Central App
    11-26-2015 04:18 PM
  7. RichardJTesla's Avatar
    Ya hopefully there is a fix in the works.
    11-26-2015 05:17 PM
  8. beeare's Avatar
    I'm getting about the same battery life as my Turbo 1. When I first got the Turbo 1 on Kit kat I broke 6 hours SOT a couple times over about 18 hours off the charger. I'm getting about 5 on this phone, which is better than I was getting on my Turbo 1 on lollipop. The idle drain is significantly better on this phone. I've gone 36 hours with 4 hours screen time and over an hour call time a couple times, which I definitely couldn't have gotten with my Turbo 1. I've also gotten 3.5 hours call time and 4 hours SOT over a 24 hour period, which I'm pretty happy with. And that's all on 4g with multiple emails pushing and a ton of other apps.
    11-26-2015 10:20 PM
  9. beeare's Avatar
    I'm pretty happy with this. Never got this good on my Turbo.
    Attached Thumbnails Battery Drain Issues &  Resolutions-1448599686487.jpg  
    11-26-2015 10:48 PM
  10. RichardJTesla's Avatar
    I just wasn't impressed. I had the Turbo 1 and I remember getting better life out of it.
    11-27-2015 12:39 AM
  11. ozgur781sen's Avatar
    Voice over LTE fixed it for my Galaxy S6 T-Mobile stock rom
    Before my phone was going from 100% to 75% without any usage(Sot) within 5 hours even when the data, location and sync was disabled

    After I disable Voice over LTE it decreased to 87% from 100% in 5 hours

    I rooted my phone after and installed Xtrelolite deodexed rom with Performance mode on the kernel and the battery usage not even dropped 1% in 5 hours with WIFI, bluetooth, data, sync and location on. This time the phone actually deep sleeps when before on the stock rom when the phone was in idle it would still use battery as if I had the screen turned on.

    This is my experience. Now I get 6+ hours of Screen on time vs on stock it was 3.
    So my suggestion is try rooting your phone and find a stable rom that you like.
    11-28-2015 05:50 PM
  12. doogald's Avatar
    Rooting the turbo 2 and installing any custom rom is not a solution at the moment, and may never be (based on the last two generations of droid phones.)
    11-28-2015 06:14 PM
  13. Masheen's Avatar
    Aye, rooting has done wonders on other phones, but the last couple generations of Droids made the bootloader too difficult to crack. I do like the native unlocking ability in developer options; that is a good start, but we still need support from Moto to provide an official unlock code.

    So atm were left with fiddling with app disabling and toggling different system settings to optimize our device.
    11-28-2015 06:22 PM
  14. Moto0685's Avatar
    At its current performance no need to root the turbo 2 i have everything I want turned on and no unusual battery drain.

    Posted via the Android Central App
    Masheen likes this.
    11-29-2015 01:24 PM
  15. Masheen's Avatar
    At its current performance no need to root the turbo 2 i have everything I want turned on and no unusual battery drain.

    Posted via the Android Central App
    This.

    The Droid Maxx was the first phone I had no desire to root
    11-29-2015 01:26 PM
  16. dmark44's Avatar
    I had it checked to avoid poor connections. This is an all of the sudden thing though. I've had the phone for two weeks and this is the first time cell standby is chunking down my battery life. Reset didn't work, might just factory reset for fun.
    I've had the same problem for about the last 4 daysv with my Moto X Pure. I have also had the avoid poor WiFi connections setting checked, but it has been that way since I've had the phone.

    I'm going to try to reboot and see if it helps. Statistically, cell stand-by doesn't look bad as a percentage, but I don't think it should be on so much (as a top 3 or 4 battery drainer even when I'm on WiFi.)
    11-29-2015 01:34 PM
  17. beeare's Avatar
    This is what I got yesterday with about 2.5 hours of YouTube and everything turned on. I'm content with this. With normal usage I should never be to charge before the end of the night. And that's pretty much all I ask for.
    Attached Thumbnails Battery Drain Issues &  Resolutions-1448825629803.jpg  
    11-29-2015 01:34 PM
  18. Masheen's Avatar
    I've had the same problem for about the last 4 daysv with my Moto X Pure. I have also had the avoid poor WiFi connections setting checked, but it has been that way since I've had the phone.

    I'm going to try to reboot and see if it helps. Statistically, cell stand-by doesn't look bad as a percentage, but I don't think it should be on so much (as a top 3 or 4 battery drainer even when I'm on WiFi.)
    The way I eventually fixed this was by switching location from high accuracy to battery saving mode (unless using gps). The DT2 has a very aggressive LTE radio, and it will try and hold LTE in areas where we really should be on 3G bc the LTE speed isn't attainable anyway.

    Note that this cell standby drain/ mobile radio active doesn't appear when there is a strong LTE signal even with high accuracy selected and allow scanning turned on
    dmark44 likes this.
    11-29-2015 03:33 PM
  19. dmark44's Avatar
    The way I eventually fixed this was by switching location from high accuracy to battery saving mode (unless using gps). The DT2 has a very aggressive LTE radio, and it will try and hold LTE in areas where we really should be on 3G bc the LTE speed isn't attainable anyway.

    Note that this cell standby drain/ mobile radio active doesn't appear when there is a strong LTE signal even with high accuracy selected and allow scanning turned on
    You're right. I did the same and the last 3 hours have been a noticeable improvement.
    11-29-2015 04:20 PM
  20. THEPRFCT10's Avatar
    How do you get to the process stats page? Can't find developer menu!
    11-29-2015 05:07 PM
  21. Masheen's Avatar
    How do you get to the process stats page? Can't find developer menu!
    It's the 5th selection from the top.
    11-29-2015 05:09 PM
  22. 18t's Avatar
    How do you get to the process stats page? Can't find developer menu!
    You have to tap on the build number several times consecutively to unlock the dev menu. Settings -> About phone -> Build number -> taptaptaptap...

    Posted via the Android Central App
    11-29-2015 05:27 PM
  23. THEPRFCT10's Avatar
    You have to tap on the build number several times consecutively to unlock the dev menu. Settings -> About phone -> Build number -> taptaptaptap...

    Posted via the Android Central App
    Got it thanks!
    11-30-2015 03:21 PM
  24. DonGreyface's Avatar
    I just got the DT2 last night after shattering the screen on my DT1 Sunday night. So today is my first full day of use, and I am a little disappointed right now. I have 38% left with just 2hr35m SOT. I'm using it the same as my old phone since I don't have to get used to a new UI and my DT1 would only be down to roughly 65% by now. I'm hoping I didn't get a bad phone. As a matter of fact my battery dropped to 36% just while typing this. And ideas? I don't seem to have a rogue app and all other settings are how I had them on the DT1.
    12-01-2015 08:19 PM
  25. Masheen's Avatar
    I just got the DT2 last night after shattering the screen on my DT1 Sunday night. So today is my first full day of use, and I am a little disappointed right now. I have 38% left with just 2hr35m SOT. I'm using it the same as my old phone since I don't have to get used to a new UI and my DT1 would only be down to roughly 65% by now. I'm hoping I didn't get a bad phone. As a matter of fact my battery dropped to 36% just while typing this. And ideas? I don't seem to have a rogue app and all other settings are how I had them on the DT1.
    Understood. But you gotta post battery stats from GSam or Process Stats so we can help.
    12-01-2015 08:38 PM
61 123

Similar Threads

  1. What is this showing on my battery usage?
    By Marto1985 in forum Android 6.0 Marshmallow
    Replies: 3
    Last Post: 11-27-2015, 10:05 PM
  2. Factory Reset for better Battery!
    By 1dtbrown in forum Samsung Galaxy S6 edge
    Replies: 3
    Last Post: 11-21-2015, 06:37 PM
  3. Why am I getting battery over temperature messages?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-20-2015, 04:47 PM
  4. Nexus 6p headphone jack issue
    By Fiasco62 in forum Nexus 6P
    Replies: 2
    Last Post: 11-20-2015, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD