1. mgullick's Avatar
    I never have my phone delete email from the server but the Droid 2 seems to do it constantly. I have never had this problem with any other phone. Is there a fix for this or a known work-around?
    12-14-2015 10:58 AM
  2. doogald's Avatar
    IMAP server, Exchange, or POP3? If it is POP3 (which I suspect), can you switch it to IMAP?

    If not, have you tried a mail app from the Play Store? (K9 Mail, Aquamail, Typemail)?
    12-14-2015 11:23 AM
  3. mgullick's Avatar
    POP 3. I have a comcast.net address and it's a POP3 account. I find this really annoying as none of my previous phones had this issue. I believe it to be an issue with the mail app but, in the past, haven't been impressed with other mail apps I've tried. (I'm not real impressed with the stock app on the Turbo 2 seither though. It looks more like a GMail app and I really don't like GMail.) The mail on my Droid MAXX was perfect.

    After posting above I started looking around online and I see that this was an issue with the original Turbo. I can't believe it hasn't been fixed!
    12-14-2015 11:54 AM
  4. doogald's Avatar
    Try another email app. Which is more important: having your mail be deleted or using an app that you like the looks of?

    Or, as an alternate, manually set the mail app to use IMAP. Comcast mail can use IMAP: Using Email Client Programs with Comcast Email , or this page should help: Switching Email Settings from POP to IMAP - Google Nexus

    This will keep all of your mail synced between all of your devices. I strongly suggest not using POP3 for anything if you can at all avoid it.
    12-14-2015 12:23 PM
  5. mgullick's Avatar
    Try another email app. Which is more important: having your mail be deleted or using an app that you like the looks of?

    Or, as an alternate, manually set the mail app to use IMAP. Comcast mail can use IMAP: Using Email Client Programs with Comcast Email , or this page should help: Switching Email Settings from POP to IMAP - Google Nexus

    This will keep all of your mail synced between all of your devices. I strongly suggest not using POP3 for anything if you can at all avoid it.
    GAH! Removed account. Restarted phone. Reinstalled account as IMAP. Tested. Same issue.

    I guess I will have to start playing with alternate email programs as the one included on the phone seems to be the cause of the issue.
    12-14-2015 12:57 PM
  6. Toes Up's Avatar
    I had the same problem with my Turbo and therefore I took the advice of others on the forum (including Doogald, if I recall correctly) and switched email apps. Couldn't be happier. I'm using K9, but there are a lot of other good email apps. It's all personal preference.

    Give it a try..........
    doogald likes this.
    12-14-2015 12:59 PM
  7. doogald's Avatar
    Frankly, it's impossible for an IMAP mail client to delete mail from a mail server unless you delete it from the phone first, unless the mail app is just a piece of junk. If the default email app removes mail from the server when you use IMAP, then there is something even more wrong with that piece of junk than I thought.
    12-14-2015 01:38 PM
  8. mgullick's Avatar
    Hmm... Looks like the actual problem is that the phone originally automagically setup the mail as SMTP so, when I deleted it and put it back as SMTP, it was still set the same. I deleted it again and did a manual config as a POP3 account and I "think" that has fixed the problem.

    I check mail on multiple devices and don't want the phone to delete it from the server.
    12-14-2015 03:26 PM

Similar Threads

  1. How can i stop or delete shortcuts Web games?
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 01-17-2016, 12:07 AM
  2. Can i turn on my phones gps from my computer?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-14-2015, 03:04 PM
  3. Replies: 1
    Last Post: 12-14-2015, 12:00 PM
  4. Replies: 3
    Last Post: 12-14-2015, 06:11 AM
  5. Replies: 1
    Last Post: 12-14-2015, 05:55 AM
LINK TO POST COPIED TO CLIPBOARD