1. THEPRFCT10's Avatar
    Ok so I selected WiFi OFF as my screenshot shows yet the battery stats page clearly shows it ON. What am I missing?! Thanks.
    02-19-2016 04:04 PM
  2. BlackHawkA4's Avatar
    I thought advanced wifi always scanning. But minec still stays on.
    02-19-2016 04:13 PM
  3. THEPRFCT10's Avatar
    Hmmmmm, not sure. Are you saying or suggesting there may be a way to shut off the constant scanning for wifi even though the button has it as selected off?! Bizarre.
    02-19-2016 05:02 PM
  4. THEPRFCT10's Avatar
    I thought advanced wifi always scanning. But minec still stays on.
    found it, but I have it turned off already.
    02-19-2016 05:04 PM
  5. BlackHawkA4's Avatar
    Yea. I turned mine off. And it stayed on. Yesterday it turned off. Today it didn't turn off. Well towards the end but 90% of the time it was on. Not sure why. And I have location history and Google now disabled. And battery saving mode is on for location.
    02-19-2016 05:11 PM
  6. THEPRFCT10's Avatar
    That's weird, if I / you want it off, it should be off. Clearly it adds to the battery drain.
    02-19-2016 05:12 PM
  7. BlackHawkA4's Avatar
    Right. That's what I think at least.... And just as I looked after recharging my phone and after typing that... It was on all day..and now it's been off since full charge... No idea what it is and what keeping it on.

    I've been messing with the settings to try and get it off and save battery. But it just doesn't seem to helping any in either aspect. Not sure if turning off locations history helped today as I used my phone more than normal.
    02-19-2016 05:19 PM
  8. THEPRFCT10's Avatar
    Wow that's bizarre hopefully someone here can shed some light on this!
    02-19-2016 07:19 PM
  9. BlackHawkA4's Avatar
    So my wifi shows its been off all day since unplug. I don't think it made a difference in battery life. And neither has turning off location history. I'm at 1 hour sot @ 76%. Mathematically speaking. I should be at 3 hours of sot @ 29% battery. That's what I had yesterday with the wifi staying on all day when I did make it to 30% physically.
    02-20-2016 10:19 PM
  10. THEPRFCT10's Avatar
    My stats are eerily similar to yours and I'm disappointed. I'm thinking once marshmallow rolls out I'll be factory data reset
    02-20-2016 10:55 PM
  11. THEPRFCT10's Avatar
    Bump please.
    02-26-2016 11:22 PM
  12. srkmagnus's Avatar
    Try rebooting the device and see if that helps. Can you also post the screen shot of the battery stats page showing the percentage/time in which apps/services are using battery. I think it's the screen before this.
    02-26-2016 11:29 PM
  13. doogald's Avatar
    Bump please.
    It's possible that you have an app that has the permission to keep wifi on. Without looking at your phone it's impossible to tell which app that is.

    So, you can go into settings / apps, tap each one in the downloaded list, and see if any of them have the permission to turn wifi on or off. That app would be suspected in making this happen.

    If it's not that, then it's probably a bug in android and there's nothing you can do about until marshmallow. I know that was an issue with 5.0.x, but 5.1.1 I thought didn't have this problem, so I suspect the app problem.

    (I've also read somebody who said that using the app Power Toggles to toggle wifi rather than the standard settings toggle will keep it off, but I think that's not true if you have an app problem. Still, maybe it's worth a try.)

    https://play.google.com/store/apps/d...inless.pc&hl=e

    I am pretty sure that wifi only consumes battery when you are using it, particularly when the signal is weak, so if you're trying to improve battery by toggling wifi when you are not connected to an access point I have a feeling you'll be disappointed if you get this worked out.
    02-27-2016 07:22 AM
  14. THEPRFCT10's Avatar
    I looked at my downloaded apps many which have plenty of permissions but none from what I saw say anything with regards to keeping our turning WiFi on
    02-27-2016 08:31 AM
  15. beeare's Avatar
    I looked at my downloaded apps many which have plenty of permissions but none from what I saw say anything with regards to keeping our turning WiFi on
    I've had this problem when wifi scanning is on, and occasionally it's persisted even when I've turned it off. The only problem is, when I use Google maps it often prompts you to turn wifi scanning on, and I accidentally reactivate it. Turn off wifi scanning, and then reboot the phone afterwards. Leave wifi off to ensure its connected to your data instead of wifi, and then it shouldn't do this anymore. This has always worked for me. I should note though that I've noticed very little difference in battery performance whether this is present or not.
    02-28-2016 03:39 PM
  16. THEPRFCT10's Avatar
    I've had this problem when wifi scanning is on, and occasionally it's persisted even when I've turned it off. The only problem is, when I use Google maps it often prompts you to turn wifi scanning on, and I accidentally reactivate it. Turn off wifi scanning, and then reboot the phone afterwards. Leave wifi off to ensure its connected to your data instead of wifi, and then it shouldn't do this anymore. This has always worked for me. I should note though that I've noticed very little difference in battery performance whether this is present or not.
    I'll try thanks!
    02-28-2016 05:59 PM
  17. eLCruz's Avatar
    I had this problem, it was driving me nuts! Goto Location settings, find improve accuracy:


    Then turn off wifi and Bluetooth scanning.


    These are what keep wifi (and Bluetooth) on even when you turn them off.
    12-05-2016 12:08 PM
  18. Soundtallica's Avatar
    This issue happened to my old Turbo 2, and it's happening to my current Z Play as well and it's kinda annoying... Maybe it's an inherent problem with Moto's software? Nothing fixes it, not reboots, not turning off scanning.
    12-05-2016 10:24 PM
  19. Moo Cow's Avatar
    I had this problem, it was driving me nuts! Goto Location settings, find improve accuracy:
    https://uploads.tapatalk-cdn.com/2016...2f7c4f90a9.jpg

    Then turn off wifi and Bluetooth scanning.
    https://uploads.tapatalk-cdn.com/2016...6453304035.jpg

    These are what keep wifi (and Bluetooth) on even when you turn them off.
    Yeah doesn't work. Had this issue ever since I got the DT2, and I've done everything. Even rebooting it doesn't always work.
    12-18-2016 04:41 PM
  20. CEStanley's Avatar
    Yea. I turned mine off. And it stayed on. Yesterday it turned off. Today it didn't turn off. Well towards the end but 90% of the time it was on. Not sure why. And I have location history and Google now disabled. And battery saving mode is on for location.
    On my S5, if I turn the WiFi off and restart my phone, the WiFi stays off when the phone comes back up.
    01-21-2017 07:49 PM

Similar Threads

  1. Messages only received on wifi
    By Lamp23 in forum Sony Xperia Z3v
    Replies: 4
    Last Post: 05-11-2016, 09:29 AM
  2. Lg g won't charge to 100%
    By Keith Johnson6 in forum LG G Watch
    Replies: 1
    Last Post: 03-21-2016, 01:07 AM
  3. WiFi calling
    By Bildriver in forum HTC One M9
    Replies: 5
    Last Post: 02-23-2016, 09:23 PM
  4. Replies: 3
    Last Post: 02-23-2016, 04:28 PM
  5. Phone won't turn off, 360 security notification. What do I do?
    By AC Question in forum LG Android Phones
    Replies: 1
    Last Post: 02-19-2016, 12:56 PM
LINK TO POST COPIED TO CLIPBOARD