1. Damian Flare's Avatar
    Been having an odd issue where even I connect my turbo 2 to a PC (let's go with win10 for simplicity sake since I have the same issue on a Linux distro), the PC doesn't bring up a "new device window" or bubble, or recognize a new device was connected.

    The phone will start charging like normal, but does not give me a "USB connection" notification in the notification bar either.

    I've tried several cables, my desktop, laptop, and windows surface (all windows 10) and an open Pandora portable (if you know what that is.) that all have the same reaction .
    (it'll charge but not do anything else.)

    Any help would be appreciated.

    Posted via the Android Central App
    02-21-2016 07:38 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Use a can of compressed air to blow out the microUSB port, in case there's any debris in there. Also inspect the port's pin to make sure it isn't damaged.
    02-21-2016 10:28 PM
  3. Damian Flare's Avatar
    Thanks!

    But no, blew out any debris that may have been in there and cleaned the pins, it still charges, but gives no indication of connection.

    Posted via the Android Central App
    02-22-2016 03:17 PM
  4. B. Diddy's Avatar
    Just to be sure--you've tried the original cable that came with the phone, right?
    02-22-2016 04:00 PM
  5. Damian Flare's Avatar
    And several others, yup.

    Posted via the Android Central App
    02-22-2016 04:01 PM
  6. jimbo1mcm's Avatar
    Make sure you have gone into developer options and allowed for USB de-bugging. If all else fails, do a reset.
    02-23-2016 03:04 AM
  7. B. Diddy's Avatar
    If none of that works, then the actual microUSB port may be faulty, and needs to be replaced.
    02-23-2016 10:50 AM
  8. Jur4551c's Avatar
    Have you checked the notification panel on your phone? The phone defaults to charging only and you have to choose MTP from the notification on the phone.
    03-28-2016 02:47 PM
  9. Gurol's Avatar
    Been having an odd issue where even I connect my turbo 2 to a PC (let's go with win10 for simplicity sake since I have the same issue on a Linux distro), the PC doesn't bring up a "new device window" or bubble, or recognize a new device was connected.

    The phone will start charging like normal, but does not give me a "USB connection" notification in the notification bar either.

    I've tried several cables, my desktop, laptop, and windows surface (all windows 10) and an open Pandora portable (if you know what that is.) that all have the same reaction .
    (it'll charge but not do anything else.)

    Any help would be appreciated.

    Posted via the Android Central App
    I got same problem on my dt2. After marshmallow start this problem. When I use my old phone droid turbo charge cable it's working. I think system choose ing cable after marshmallow as iPhone.
    03-29-2016 12:40 AM
  10. Gurol's Avatar
    Have you pulled down the notification shade and changed from the default usb charging connection with marshmallow, as per the previous post?
    I did. Pulled down. nothing there if using any cable. It's just posiable to with droid turbo cable.
    03-29-2016 06:24 AM
  11. millerman61's Avatar
    This may apply or may not apply. The Verizon Upgrade Assistant will not work if the phone is plugged unto a USB 3 port. Are you plugging into a 2 or 3 port?
    03-29-2016 07:00 AM
  12. Gurol's Avatar
    I'm confused about what phone and which cable, or wait you can connect with your old Droid turbo cable .. which? But the Droid turbo 2 on marshmallow won't connect with either cable?

    Check this out to be sure, ta be sure begorrah (I'm Irish) :

    Inside Marshmallow: USB connection options | Android Central
    I'm using droid turbo 2. Also I have droid turbo. U know turbo 2 charge cable can not use connect to PC but with droid turbo cable posiable. So I'm using droid turbo cable to connect for my droid turbo 2 for PC connect. ... I have many cable and I connect many time with any cable. It was working. After marshmallow working only original cable also to day tried with a Samsung original cable for connect to PC and it is working..
    03-29-2016 03:50 PM
  13. mrpatandro's Avatar
    I am not having a mounting issue. Mine mounts and shows both internal and SD Card. Internal works just as expected and can be navigated via file manager. The SD card shows 17 Gb of 32 used, but it won't list any files when opened. It shows nothing.
    04-19-2016 07:50 AM
  14. Anusien's Avatar
    I'm having a similar problem, but it's not related to cables. I have two Droid 2 Turbos (one is a replacement from Verizon to hopefully fix some speaker issues). They're running the same version of the OS and everything. If I plug the new one in, I can see it with adb devices and it will prompt for USB debugging. The old one won't connect. I've tried PTP and MTP, and I've tried two separate computers: one running Win7 and one running Ubuntu. I've tried putting the old phone into safe mode, rebooted, changed cables, changed USB ports, cleaned the cache, blown compressed air into the port, nothing.

    When I first got this phone I was able to connect via USB debugging because I did a backup restore onto this one.
    09-16-2016 01:03 AM
  15. George Citizen's Avatar
    I have the same issue with my turbo2. Haven't had the time to play with it.
    09-22-2016 10:24 PM

Similar Threads

  1. Nexus 5 connects in fastboot mode but not in MTP
    By drbubbles in forum Google Nexus 5
    Replies: 4
    Last Post: 03-18-2016, 09:57 PM
  2. Replies: 18
    Last Post: 02-23-2016, 01:01 PM
  3. New phone old wifi no connection
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-21-2016, 11:53 PM
  4. Why can't I usb tether my LG G4?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-21-2016, 06:12 PM
  5. Why is my SD card not being recognized? (UMX MXW1)
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-21-2016, 05:10 PM
LINK TO POST COPIED TO CLIPBOARD