09-08-2017 07:58 AM
27 12
tools
  1. aviodwarf's Avatar
    After the 6.0 update my mom has been experiencing slow charging on her Turbo 2. Last night she left it on the charger and when she woke up it was only at 30 percent. I tried a restart and it did not seem to help. So far it seems to be a software problem since it is right after an update, but there is a chance it could be a hardware problem that came at just the right time. I am thinking of trying a factory reset but I wanted to see if you guys have anything to add before I do so. Thanks in advance.
    I am having the same issue with my car charger. I am using the factory charger but get an error message saying "slow charge use factory charger to charge faster' or something like that. It charges ok with the home charger but drops to 97% the minute I open it after charging. And yes, this did start after the 6.0 update and I cleared the cache.
    05-27-2017 02:11 AM
  2. E Dolehide's Avatar
    I know most likely this is long since dead...but I'd like to point out that in my experience with repairing Motorola smart phones is that they consistently have USB port quality issues. The fact that it seems like folks here aren't having issues with wireless charging, but are having slow charging problems with USB would be an indication that the charging port was/is the problem. I had that exact issue with a previous Motorola device ....and it was USB the charging port and replacing it resolved my troubles. Replacing the charging port for the device will more than likely resolve the issue for many of those listing issues with slow charging as well, I would hazard a guess.
    09-08-2017 07:58 AM
27 12

Similar Threads

  1. Samsung Fast Charge Wireless Charging Stand, Black
    By Zendroid1 in forum Marketplace Archive
    Replies: 1
    Last Post: 04-26-2016, 01:59 PM
  2. S7 Charging
    By xTrey in forum Samsung Galaxy S7
    Replies: 4
    Last Post: 04-25-2016, 11:49 PM
  3. Wireless In-Car Charging
    By R_hino in forum Accessories
    Replies: 1
    Last Post: 04-25-2016, 06:16 PM
  4. How to fix the booting error on my Droid Turbo?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-25-2016, 10:21 AM
  5. headphone butten have a really slow response time
    By bomboy2121 in forum Ask a Question
    Replies: 0
    Last Post: 04-25-2016, 09:01 AM
LINK TO POST COPIED TO CLIPBOARD