1. conan1071's Avatar
    Ive had the turbo 2 since December. I always have advanced calling on and never had issues with calls. On Wednesday, I dropped 22 calls while driving about 8 miles. Went to Verizon store, they changed my SIM card and deactivated and then re activated HD calling and all was well. The next day, went to another Verizon store to make sure all on the account was correct. Rep put a new SIM in. Driving and home and at home kept dropping calls, I have wifi on at home. Went back to store, they call tech, tech says its a known issue with the turbo2 and a patch being worked on. He said it has to do with Marshmallow and I explain, Im still on lollipop. He still says is an issue. Now, if I want to make calls and not drop, I have to turn off HD calling. I use that a lot.

    Anyone else have this? How could it just all of the sudden start having problems. Why did it work fine the first day?
    05-06-2016 10:22 AM
  2. doogald's Avatar
    It could be (temporary) network issues on Verizon's end. (Or maybe permanent; see my note below.)

    If the second SIM was working fine, why did you have the rep put a third SIM in? Have you considered asking for a new SIM one more time and then doing a few test calls while you are still in the store?

    I turned on AC last month and was using it for a while. The first phone call I received - I could not hear the other person, she could hear me. She called me back a couple more times (I was on my way to her house) - the same thing. I turned off AC and calling has been fine ever since. Now I will only turn in on when I am driving long distance and know that I'll be using navigation (and that I'll be in likely good LTE coverage), otherwise I just keep it off. PITA.
    05-06-2016 10:44 AM
  3. conan1071's Avatar
    It could be (temporary) network issues on Verizon's end. (Or maybe permanent; see my note below.)

    If the second SIM was working fine, why did you have the rep put a third SIM in? Have you considered asking for a new SIM one more time and then doing a few test calls while you are still in the store?

    I turned on AC last month and was using it for a while. The first phone call I received - I could not hear the other person, she could hear me. She called me back a couple more times (I was on my way to her house) - the same thing. I turned off AC and calling has been fine ever since. Now I will only turn in on when I am driving long distance and know that I'll be using navigation (and that I'll be in likely good LTE coverage), otherwise I just keep it off. PITA.

    The Verizon store rep recommended a new SIM to be safe.

    I did make test calls from the store and it was fine. Its when I left that the issues started again.
    05-06-2016 10:56 AM
  4. gemery#CB's Avatar
    Eight miles could keep you on the same tower.. I wonder if they are having LTE issues on that one tower..

    Posted via the Android Central App
    05-07-2016 12:00 PM
  5. steveg2112's Avatar
    What is the probability that they have a micro cell in store to provide the best possible signal?

    Posted via the Android Central App
    05-07-2016 02:13 PM
  6. Jaingo5150's Avatar
    Mine has the same issue so don't believe it is tower related at all.

    We have three T2s in the house and mine is the only one with this issue. The other two are still on lollipop.

    I'm so disappointed in my purchases of the T2 as I never would have thought about asking how many radios the phone has in 2016. My loss....

    Moto has said they will replace my unit if call drops continue, but I am guessing it is a software related issue. Phone works perfectly fine if not on advanced calling, but I often need to use lte while on a call.

    Posted via the Android Central App
    05-07-2016 09:19 PM
  7. twojosh's Avatar
    Mine has the same issue so don't believe it is tower related at all.

    We have three T2s in the house and mine is the only one with this issue. The other two are still on lollipop.

    I'm so disappointed in my purchases of the T2 as I never would have thought about asking how many radios the phone has in 2016. My loss....

    Moto has said they will replace my unit if call drops continue, but I am guessing it is a software related issue. Phone works perfectly fine if not on advanced calling, but I often need to use lte while on a call.

    Posted via the Android Central App
    I'm still on lollipop as well. Tech support said it's a software issue. Mine has been fine the past few days.
    05-09-2016 09:02 PM

Similar Threads

  1. Replies: 1
    Last Post: 05-17-2016, 05:57 AM
  2. Verizon S7 and S7 Edge update
    By Tatt2014 in forum Ask a Question
    Replies: 1
    Last Post: 05-06-2016, 11:03 AM
  3. is nextbook a good and worthy tab?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-06-2016, 09:20 AM
  4. Replies: 1
    Last Post: 05-06-2016, 06:53 AM
LINK TO POST COPIED TO CLIPBOARD