1. Farmer Brad's Avatar
    Miracasting Netflix has quit working properly with the latest Netflix app update. I have been screen mirroring netflix from my Motorola Droid Turbo 2 cell phone to "belkin" HDMI wifi screen mirror adapter plugged into my TV for several months without problems.

    I've recently updated the netflix app and no longer can screen mirror netflix properly. The connection/mirror works fine until the movies starts to play and the only images that are cast is the subtitles and audio. The movie picture and subtitles can still be seen on the phone screen and audio and subtitles are mirrored on the TV screen. It is clear the mirror connection is still established because the subtitles and audio track the movie on the TV.

    Here is a link to a video showing what I'm talking about.

    All other screen mirroring/Miracasts work fine , Amazon Prime movies, YouTube... Netflix is the only app that does not screen mirror correctly.

    While browsing forms online I observed a similar issue reported when using Chromecast "mirror screen" feature and attempting to play netflix unfortunately with no reported fix...

    My main concern is this was something that was working and now it doest work properly.

    Anyone else having this problem?
    Any known fixes?
    06-02-2016 11:22 AM
  2. Farmer Brad's Avatar
    While continuing to try and get this working again, I notice if I fast forward the video picture will show a frame until video starts to play again...
    06-02-2016 11:48 AM
  3. Farmer Brad's Avatar
    Just for clarification, belkin uses wifi to connect directly to my phone. We do not have wifi or Internet at the house.

    My phone is receiving data on the version 4g network and miracast to tv via wifi to the belkin HDMI adapter.
    06-02-2016 11:57 AM
  4. Mfiala949's Avatar
    I have same issue. Just bought Actiontec screenbeam mini 2 for my car stereo. Everything works but Netflix from my turbo 2. Only get subtitles and sound when video is playing. One of the main reasons I bought it. Haven't found a solution anywhere yet.
    06-02-2016 03:42 PM
  5. Sonpower's Avatar
    I have tried two different dongles - the Yuntab CX-A3S and the Microsoft Wireless Display Adapter, both connect fine and display everything but Netflix video (sound and subtitles work fine) I have used an Ellipsis 10 Tablet from Verizon and a Motorola Droid Turbo and get the same results. Netflix wouldbe a great convenience when staying in hotels and so forth - Anyone has an answer, I would really like to know
    06-30-2016 12:06 AM
  6. slooowr6's Avatar
    Any update on this issue?
    I've a LG G pad running Android 4.x and with Netflex 4.4.1 App. Miracast works fine with Netflix on that setup.
    I've a OnePlus One running Cyanegen 13 (Android 6.1), Miiracast can't even connect to my projector. I found out google secretly disable Miracast in Android 6.0. I switch to Oxygen 2.1.4 (Android 5.1) and Miracast works now but run into this issue on Netflix. There is definitely some compatibility issue between Netflix app and Android OS.
    07-19-2016 03:53 PM

Similar Threads

  1. netflix is litteraly the only app not working on chromecast
    By sjsmith1708 in forum Google Chromecast
    Replies: 1
    Last Post: 06-03-2016, 12:56 AM
  2. Android Calculator not working
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 06-02-2016, 03:37 PM
  3. Replies: 1
    Last Post: 06-02-2016, 02:22 PM
  4. How do I transfer videos from my camera to a disc?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-02-2016, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD