1. AC Question's Avatar
    I've tried different chargers and have a 2.1 amp charger, but it still doesn't charge.
    02-23-2017 11:59 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! The battery might be failing. Does the lightning bolt show up in the battery icon when you plug it in?
    02-23-2017 04:36 PM
  3. Sandman333's Avatar
    Have you tried a wireless charger? Your USB port may have failed. They are rather fragile on this phone for some reason.
    02-26-2017 03:28 AM
  4. doogald's Avatar
    02-26-2017 06:14 AM
  5. CreeperCraft137's Avatar
    My usb port broke as well. Use a wireless charger, as that was MY only option to charge it for about a month.
    02-26-2017 10:50 AM
  6. Bob Mohney's Avatar
    Is there a fast wireless charger that works for the Turbo 2?
    03-02-2017 07:18 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-23-2017, 02:48 PM
  2. Help using Helium to backup game data on Droid Razr Maxx
    By glitterninja in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 02-23-2017, 11:58 AM
  3. How can I change the cellular network band in my Nexus 6p?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-23-2017, 11:01 AM
  4. Replies: 0
    Last Post: 02-23-2017, 10:46 AM
  5. Replies: 0
    Last Post: 02-23-2017, 10:46 AM
LINK TO POST COPIED TO CLIPBOARD