1. pwnyxpr3ss's Avatar
    I just updated my phone last night to Android 7.0 after postponing the update for the past week. Now the phone will not turbocharge at all, it just says charging at the bottom instead of turbo power connected. I checked that the cord is working fine as it turbocharges another Turbo 2 that just updated to Android 7.0 earlier this morning as well. The other phone turbocharges with this charger just fine, but mine will not. I already tried clearing the cache in the settings menu as well as booting in recovery mode to wipe the cache partition, neither of which fixed it.
    04-18-2017 03:33 PM
  2. Lucy Davies's Avatar
    Mine does this sometimes & all i do is pull it off the charger & plug it back in & it's fine then. Have you tried that?
    04-18-2017 06:22 PM
  3. Ry's Avatar
    Did you try other Turbo Chargers?
    04-18-2017 08:29 PM
  4. pwnyxpr3ss's Avatar
    I have tried a ton of stuff, everthing Verizon customer support could come up with. I have tried multiple turbochargers (3 in total, all of which turbocharge my girlfriends Turbo 2 just fine). I have restored the phone back to factory settings (which made it still have 7.0 Nougat installed after setup), I cleared the cache partition, tried booting up in safe mode, everything they could come up with, none of it making it turbocharge. I have tried putting different chargers that are turbochargers into the phone multiple times and it still does not work. The only thing that is different since when it last was turbocharging (last night before the update) is the fact that I updated to 7.0 Nougat.
    04-18-2017 09:08 PM
  5. Ry's Avatar
    I have tried a ton of stuff, everthing Verizon customer support could come up with. I have tried multiple turbochargers (3 in total, all of which turbocharge my girlfriends Turbo 2 just fine). I have restored the phone back to factory settings (which made it still have 7.0 Nougat installed after setup), I cleared the cache partition, tried booting up in safe mode, everything they could come up with, none of it making it turbocharge. I have tried putting different chargers that are turbochargers into the phone multiple times and it still does not work. The only thing that is different since when it last was turbocharging (last night before the update) is the fact that I updated to 7.0 Nougat.
    Try using the Verizon/Motorola Upgrade Assistant to repair the Nougat update.

    It sounds like a hardware issue though.
    04-18-2017 09:11 PM
  6. pwnyxpr3ss's Avatar
    It is a hardware issue (caused by the software update), I have tried everything (Verizon even had me try the repair assistant and it did no good). And since it isn't under warranty anymore (expired last month ffs) Verizon won't replace the phone, so unless I can figure out a way to get it turbocharging again it looks like I will have a phone that takes 7 hours to fully charge.
    04-18-2017 09:15 PM
  7. doogald's Avatar
    My suspicion in all of these cases is that the actual USB port has some sort of issue that prevents the phone from turbo charging. Whether it's a short in one of the pins or just dirt or damage to one or some of them, the software upgrade was likely just an unfortunate coincidence.

    The Turbo 2 is notorious for this problem. See https://forums.lenovo.com/t5/DROID-T...e/td-p/3261260

    Frankly, it's disappointing that Motorola never recalled this phone for this issue.
    Sandman333 likes this.
    04-18-2017 09:50 PM

Similar Threads

  1. Do Not Disturb Until Next Alarm
    By exapplerep in forum Android 7.0 Nougat
    Replies: 2
    Last Post: 04-23-2017, 04:48 PM
  2. Has anyone else on Sprint not received a shipping confirmation?
    By AC Question in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 04-18-2017, 03:26 PM
  3. Replies: 1
    Last Post: 04-18-2017, 02:44 PM
  4. Replies: 0
    Last Post: 04-18-2017, 02:08 PM
  5. Downloaded apps are not visible ?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2017, 01:29 PM
LINK TO POST COPIED TO CLIPBOARD