12-16-2015 02:05 AM
32 12
tools
  1. UrbanLegend777's Avatar
    Best solution may be to recalibrate the battery monitoring by:

    1. Clear Cache Partition (mine took 15+ minutes the first time I did it)
    2. Power the phone off and put on a wall charger plugged directly into the phone, leave charging to 100% and then let it keep charging another hour or more wile powered off.

    This cured it for me, although I haven't been charging on Qi long enough since doing it to see if the problem will keep cropping up or not.
    12-24-2014 11:59 AM
  2. D._Manley's Avatar
    I wonder how prevalent this problem is with Qi charging the Turbo & if it matters whether the phone is on or off when charging comes into play?
    12-24-2014 02:56 PM
  3. Valaire's Avatar
    Hi guys. I have had this bug since day 1, exclusively charging on Qi. I've gotten frustrated with the unreliable nature of Qi and posted on their forums about it, after having some useless person on chat tell me "we do not recommend qi charging." As far as I can tell, there is no fix on our end for what is essentially a bug in Moto software.

    I can't post a link to it because of my account privileges, but if you go to Moto support forums for this phone, you'll see it listed as "Qi Charging Critical Bug."

    forums.motorola.com/posts/a029dc63a5
    01-08-2015 11:21 AM
  4. Cody Evans's Avatar
    I just recently started having the same issue, and it started immediately after I started using a Qi wireless charger. I've had the phone for over a year, but this was the first time I used wireless charging, and the problems with the battery indicator started immediately after the first use. I can't help but think the wireless charger has something to do with it...
    12-09-2015 03:52 PM
  5. zagato27's Avatar
    I had the same problem when using a "generic" Qi charger that I bought from Amazon. Switched to a Tylt charge ($$) and have had no problems with my Turbo.
    D._Manley likes this.
    12-09-2015 04:54 PM
  6. HowardShap's Avatar
    No such issues using a Tylt Wireless Charger. So sorry you are experiencing problems.

    Posted via the Android Central App
    D._Manley likes this.
    12-10-2015 02:22 AM
  7. YonWong's Avatar
    i hv using wireless charging as well. mine is the original Nokia Qi charger, which was for Nokia 820.
    i've been using for a week now with my refurbished Droid Turbo.
    So far it's still very fine without problem.
    12-16-2015 02:05 AM
32 12

Similar Threads

  1. What is a good Non OEM Battery for the S5?
    By neil154 in forum Samsung Galaxy S5
    Replies: 26
    Last Post: 12-16-2014, 04:07 PM
  2. once good battery life. where did it go?
    By ejones2010 in forum Samsung Galaxy S5
    Replies: 14
    Last Post: 11-15-2014, 12:34 AM
  3. Battery charging bundle
    By qbnkelt in forum Samsung Galaxy Note 4
    Replies: 8
    Last Post: 11-11-2014, 06:37 AM
  4. Battery Charge Status Incorrect Galaxy Mega
    By GMartinson in forum Samsung Galaxy Mega 6.3
    Replies: 0
    Last Post: 11-10-2014, 10:31 AM
  5. SMS Message Read Indicator
    By hannsoft in forum Motorola Droid Turbo
    Replies: 0
    Last Post: 11-10-2014, 10:18 AM
LINK TO POST COPIED TO CLIPBOARD