12-16-2015 02:05 AM
32 12
tools
  1. javiram's Avatar
    I got the 64GB Droid Turbo last week and have been loving it so far. Before going to bed last night, my battery was around 70%. I put the phone on my Choe Stadium wireless charger, which I got a few days ago and have liked so far. When I woke, up the battery was at 3%, which was very odd, since the phone was supposed to be charging. Even if it had not been charging, there is no way it should got from 70 to 3% while idling. I plugged it into the Turbo Charger for a few minutes and it went to 9%. I unplugged it and after a minute, it said it was at 100%. I was confused but this, but took the phone to work. 20 minutes later, on the subway, the phone was at 55% and then a few seconds later 42%. Within a few minutes, it was at 1%, but seemed to be working ok because the phone remained on. I tried rebooting several times and the battery was still going crazy. Now the status goes down and then back up and then down again. If I plug in the phone, it puts me at 100% and then once uncharged starts draining a percentage point every few seconds. What is going on here?
    11-10-2014 11:57 AM
  2. dungoyle's Avatar
    I may have missed it in your post, but did you power cycle the phone? That would be the first thing I'd do in conjunction with re-charging it. If the symptom persists after that, either factory reset, or just take it back to the store for an exchange would be my advice.
    11-10-2014 12:05 PM
  3. javiram's Avatar
    Yes, I did. Multiple times. No effect.
    11-10-2014 12:09 PM
  4. javiram's Avatar
    Motorola Tech Support told me to wipe the Cache Partition, but that did not work.
    11-10-2014 12:10 PM
  5. mightyfacundo's Avatar
    I think it's time to return it to Verizon and exchange it.

    Posted via the Android Central App
    11-10-2014 12:56 PM
  6. javiram's Avatar
    I am doing a Factory Reset now, which is really annoying. If that doesn't fix it, I will return it tomorrow.
    11-10-2014 12:58 PM
  7. javiram's Avatar
    Factory Reset did not work. Will have to return the phone.
    11-10-2014 01:21 PM
  8. dungoyle's Avatar
    Factory Reset did not work. Will have to return the phone.
    Definitely. Tough luck man.
    11-10-2014 01:22 PM
  9. donniegood's Avatar
    Had the same issue. Had to swap

    Posted via the Android Central App
    11-10-2014 03:15 PM
  10. javiram's Avatar
    Got a new Turbo from Verizon. Seems to be working fine. I wonder if it was the Qi charger that somehow caused the issue. I am probably not going to use it again.
    11-11-2014 08:16 AM
  11. javiram's Avatar
    Wondering if you used the included Turbo Charger or a Qi wireless charger or both with the defective phone?

    Posted via the Android Central App
    I used both.
    11-11-2014 08:17 AM
  12. baus-one's Avatar
    I am having the same problem...yesterday it would only report 100% battery, even after 15 hours. It refused to charge last night because it thought it was at 100%, so by 9am today it shut off, 0% battery. 10 minutes on the charger and it showed 100% again, and won't charge anymore...Just did a factory reset. Now it shows 67%, which isn't realistic having only had 10 minutes on the charger...Seems this is a common problem from my quick check on google...Guess I'll be going out in the snow to get a replacement unit...several other posters have said that their replacements started having the same problem :-( Hope its just software and will be fixed with a speedy update to 5.0
    11-12-2014 12:48 PM
  13. javiram's Avatar
    I am having the same problem...yesterday it would only report 100% battery, even after 15 hours. It refused to charge last night because it thought it was at 100%, so by 9am today it shut off, 0% battery. 10 minutes on the charger and it showed 100% again, and won't charge anymore...Just did a factory reset. Now it shows 67%, which isn't realistic having only had 10 minutes on the charger...Seems this is a common problem from my quick check on google...Guess I'll be going out in the snow to get a replacement unit...several other posters have said that their replacements started having the same problem :-( Hope its just software and will be fixed with a speedy update to 5.0
    That stinks. So far, so good with my replacement. I hope this doesn't happen again.
    11-12-2014 09:06 PM
  14. Richard R1's Avatar
    I'm on my 2nd Droid Turbo. 1st one would only last 2 hours, then would be fully charged in 10 mins. 2nd one started acting up now. Went from 40% to 0 in 5 mins. It flashed the battery icon and shut off. Charged it for 2 mins and it showed full charge. Used it for 5 mins, dead again. I'm a little pissed. .

    Can someone tell me if watching YouTube for 2 hours on WiFi with everything else shut off (location, Bluetooth, data, etc) and your battery goes from 100% to zero- is this normal? Or am I expecting too much from my droid?
    11-16-2014 10:01 PM
  15. Eclipse2K's Avatar
    I'm on my 2nd Droid Turbo. 1st one would only last 2 hours, then would be fully charged in 10 mins. 2nd one started acting up now. Went from 40% to 0 in 5 mins. It flashed the battery icon and shut off. Charged it for 2 mins and it showed full charge. Used it for 5 mins, dead again. I'm a little pissed. .

    Can someone tell me if watching YouTube for 2 hours on WiFi with everything else shut off (location, Bluetooth, data, etc) and your battery goes from 100% to zero- is this normal? Or am I expecting too much from my droid?
    I could get almost 6 hours of Hulu on my Droid Maxx so I'll say its not normal.

    Sent from my Motorola Droid Turbo
    11-16-2014 10:17 PM
  16. jsieplinga's Avatar
    Having the same problem. The first day was great--battery lasted pretty well. Today has gone from "100%" to zero twice. Trying a cache wipe with overnight charge on turbo charger. Otherwise will be going in to store this week.

    Posted via the Android Central App
    11-16-2014 10:19 PM
  17. Moto Edit's Avatar
    Wife's turbo did this crap this morning. I'm going to tell her to head to Verizon, and maybe consider a different phone. I had high hopes for the turbo, and was super jealous when she got it (I have first gen motox). Not so jealous now!
    11-29-2014 12:11 PM
  18. Inders99's Avatar
    Anybody get the idea that this phone is just one huge Beta test?
    11-29-2014 12:16 PM
  19. rxgadget's Avatar
    How do I wipe the cache?

    Sent using my Verizon Turbo charged 64GB Ballistic Nylon phone unfortunately with a case on back
    11-29-2014 08:33 PM
  20. tvouge's Avatar
    How do I wipe the cache?

    Sent using my Verizon Turbo charged 64GB Ballistic Nylon phone unfortunately with a case on back
    Power off the phone.

    Hold volume down and power until you see a screen with boot options. Release the power and volume down. Using the volume up or down keys select the option "recovery" by pressing the power key. Wait until you see a small android lying down with his chest open. Hold volume up and tap the power button a few times. You'll now see a menu. Using the volume down button, highlight "wipe cache partition" (the last option I believe) and press the power button to start. The phone should tell you "wiping cache partition."

    It took my phone about 15 minutes to wipe the partition. There is no status bar. Just chill and let it do its thing.

    Posted via the Android Central App
    11-29-2014 08:49 PM
  21. Moto Edit's Avatar
    Wife went to Verizon, and they replaced the phone.

    Verizon rant:
    Get this crap...
    When she got the Turbo the first time, she had a ton of pics transferred over to it from her old phone.
    The turbo was set to auto backup everything on the verizon cloud, so if filled up the 5 gig with pictures.
    She had pic's from Thanksgiving (kids) that she didn't want to loose on the phone that had the bad battery, so instead of having her email the pics to herself, or backing them up on google, they UPSOLD HER ON MORE VERIZON CLOUD STORAGE.
    Then, the sales guy asks her if she would like a free speaker for her trouble. Duh, yeah. So now that the turbo was on sale for $99 (she paid $199) they should have given her $100 back. Nope. She paid for the speaker per the receipt. $99 turbo + $99 speaker = $.01 credit back.
    JERKS!

    She's going to take the speaker back today and get her $99. What a F'n hassle.
    11-30-2014 09:48 AM
  22. dungoyle's Avatar
    For all of you with crazy battery readings, did you first drain your battery until the phone shut down (regardless of battery indicator reading) before clearing your cache? That's what worked for me several weeks ago when I had that problem. Just clearing the cache did not work, but I finally decided to discharge the battery completely to zero buy running a video stream constantly until the battery finally caved in from actual depletion. Then I charged the phone (power off) to 100% using the Turbo Charger, then cleared the cache. It has behaved very well since then with one or two minor hiccups -- I have had two incidents where the battery indicator clearly was wrong, and a simple cache clear fixed it. In my case, I suspect it is Qi charging which I hope will be resolved with a future system update.
    11-30-2014 10:08 AM
  23. fonger13's Avatar
    Battery also went crazy on me on Thanksgiving day, actually, it gave a wrong reading 2 weeks before that, I had to reboot it several time to get it to display the correct data. This time rebooting didn't work. It would whole at 100% for 6 hrs, then drop down quickly, once I plugged in the charger it went back to 100 in about 2 minutes, then drop down to 0 in about the same amount of time. I wiped the cache, didn't help, reboot 3-4 times, didn't help, eventually I just left it on the charger over night, continue to be wonky the next day, I was going to bring it in for an exchange/replacement on the 3rd day but it started working normally again.

    I'm considering bringing it in and just asking to replace it with a different brand phone. The battery has already messed up twice in one month, since the battery is not replaceable I'm concerned for the longevity of this phone.
    12-01-2014 12:13 PM
  24. David Baum2's Avatar
    Its Qi, screwing up the charging status.

    I am on my 3rd Turbo and an investor in wireless charging company.

    Power cycle then use Turbo charger.

    Stop using Qi.

    DWB
    rxgadget likes this.
    12-09-2014 10:57 PM
  25. kamikass's Avatar
    Had the same issue, seems it's not related only to qi, but also with usb 3.0 ports.

    Try this:

    Plug into turbo charger, hold power till it cycles on it's own (you'll see the real %), leave plugged in and walk away for an hour.

    Solved my issue...
    12-13-2014 11:19 PM
32 12

Similar Threads

  1. What is a good Non OEM Battery for the S5?
    By neil154 in forum Samsung Galaxy S5
    Replies: 26
    Last Post: 12-16-2014, 04:07 PM
  2. once good battery life. where did it go?
    By ejones2010 in forum Samsung Galaxy S5
    Replies: 14
    Last Post: 11-15-2014, 12:34 AM
  3. Battery charging bundle
    By qbnkelt in forum Samsung Galaxy Note 4
    Replies: 8
    Last Post: 11-11-2014, 06:37 AM
  4. Battery Charge Status Incorrect Galaxy Mega
    By GMartinson in forum Samsung Galaxy Mega 6.3
    Replies: 0
    Last Post: 11-10-2014, 10:31 AM
  5. SMS Message Read Indicator
    By hannsoft in forum Motorola Droid Turbo
    Replies: 0
    Last Post: 11-10-2014, 10:18 AM
LINK TO POST COPIED TO CLIPBOARD