1. delrey1900's Avatar
    My father recently purchased a Turbo based on my recommendation. I currently own a '14 X and he loved the features it offered but liked the extra battery life that the Turbo offered. After helping him set up the phone and messing with the settings, I noticed that the WiFi and cell signals were both showing and performing quite poorly. The phone's connection would time out a lot whether on WiFi or LTE. During these issues, my X would perform normally on WiFi and LTE. In other words, how has the signal/radio performance been for you guys? I expected the Turbo to perform similarly to the X in terms of the radios. Do we have a bad apple or are others having this issue?
    11-16-2014 02:24 PM
  2. Rukbat's Avatar
    Same carrier? If not, you're comparing apples to cars. If it's the same carrier, I'd bring the phone back. The phone should perform, whether everyone else's does or not.
    11-16-2014 02:44 PM
  3. BlueBlazer60's Avatar
    My father recently purchased a Turbo based on my recommendation. I currently own a '14 X and he loved the features it offered but liked the extra battery life that the Turbo offered. After helping him set up the phone and messing with the settings, I noticed that the WiFi and cell signals were both showing and performing quite poorly. The phone's connection would time out a lot whether on WiFi or LTE. During these issues, my X would perform normally on WiFi and LTE. In other words, how has the signal/radio performance been for you guys? I expected the Turbo to perform similarly to the X in terms of the radios. Do we have a bad apple or are others having this issue?
    If you are saying the WiFi and 4G/3G indicators are bright lit at the same time, I think there is an issue. It was my impression you should be either on WiFi or 4G/3G data. Not both at the same time. If mobile data is turned off and WiFi is dropping and the reverse, I would think about asking to have the phone replaced. Especially of you can duplicate the problems at other WiFi spot. And you should be able to be duplicate it in the store.

    Since I don't have a Turbo in front of me I can not actually check right now.

    But I agree with the prior answer. If you are both on the same network, those two phones should work close to the same. I would not say exact duplication because we have a couple Razr M phones. They are usually in sync but not always.
    11-16-2014 03:07 PM
  4. delrey1900's Avatar
    I should have clarified, it is the same carrier. The WiFi signal issue is on both his network at his house and my network at my house. As for the the data and WiFi on at the same time, I have never turned off data to use WiFi on any phone and never had issues doing it that way.
    If you are both on the same network, those two phones should work close to the same. I would not say exact duplication because we have a couple Razr M phones. They are usually in sync but not always.
    I would think that the Turbo and '14 X would use the same hardware as far as the radios would go. I could be wrong but you never know. If it doesn't improve by end of the week, we will replace it.
    11-16-2014 03:17 PM
  5. BlueBlazer60's Avatar
    I should have clarified, it is the same carrier. The WiFi signal issue is on both his network at his house and my network at my house. As for the the data and WiFi on at the same time, I have never turned off data to use WiFi on any phone and never had issues doing it that way.
    I expected it was the same carrier. I agree with you - I have never had a problem with WiFi and mobile not handing off to each other correctly. Reason I ask is that some people have posted that they believed both were on at the same time. Since I can not see their situation, it might be a problem with some phones. Tend to doubt it but .......

    Hope it all works out for him. Knock on wood, over the years I have been lucky with phones. Of course I rarely purchase in the first couple months. It will be a first this time - am milking the last life out of a Razr M to reach the end of the contract.
    11-16-2014 03:28 PM
  6. doogald's Avatar
    I would think that the Turbo and '14 X would use the same hardware as far as the radios would go. I could be wrong but you never know. If it doesn't improve by end of the week, we will replace it.
    it could be the antennas. The new X is using iPhone style antennas in the metal band that surrounds the phone. Since the Turbo does not have that band, they must be using traditional internal antennas.
    11-16-2014 03:38 PM
  7. BlueBlazer60's Avatar
    You might find this post interesting if you have not seen it.
    http://forums.androidcentral.com/mot...ml#post4016075
    delrey1900 likes this.
    11-16-2014 03:50 PM
  8. mimsiesboy's Avatar
    Pretty fast

    Posted via the Android Central App
    Attached Thumbnails Cell and WiFi Performance?-7546.jpg  
    11-16-2014 03:58 PM
  9. maxman1's Avatar
    I have a suspicion that the router has a lot to do with some of the problems. I read a thread where many of the Turbo users with issues shared a commonality of Cisco routers and that Cisco made an updated firmware available which corrected the issue.

    My personal experience could not be more different. My signal strength measured by WiFi Analyzer is at the very least as good as my previous Maxx with actual link speeds far better. Download throughput virtually doubled on 2.4G and 5G is even better (than 2.4) although I have no direct comparison since my Maxx was 2.4G only. I switched to an Asus AC68U a few months ago to boost range streaming to Roku and AFTV (it did) but aside from the streaming boxes, had no other devices to capitalize on the router's abilities. I have a 50Mbps Comcast account and until the Turbo, could not approach that level except on hardwired computers. I've ran speed test every day since getting the DT and have exceeded 50Mbps easily every day. If there is a problem with the phone's WiFi, it's certainly not universal.
    11-16-2014 10:50 PM
  10. delrey1900's Avatar
    You might find this post interesting if you have not seen it.
    http://forums.androidcentral.com/mot...ml#post4016075
    After reading the other AC post and the one on Motorola's site, this only covers part of the issue we are seeing. The LTE connection is the unique issue we are seeing with the phone. The connection timeouts are quite frequent and independent of the app (Play Store, browser, etc..) used. Again, like stated above, my '14 X on VZW does not act like this sitting in the same room and side by side. BTW, there has been no additional apps installed as I told him not to install any until I find out what's going on. I'm going to give it another day or so to see if anything improves, if not, then the phone is being exchanged or he's getting another phone. Thanks again for all of the help.
    11-17-2014 11:40 AM
  11. BlueBlazer60's Avatar
    Let us know what happens. Hope it all works out for your Dad.
    11-17-2014 07:49 PM
  12. tvouge's Avatar
    After reading the other AC post and the one on Motorola's site, this only covers part of the issue we are seeing. The LTE connection is the unique issue we are seeing with the phone. The connection timeouts are quite frequent and independent of the app (Play Store, browser, etc..) used. Again, like stated above, my '14 X on VZW does not act like this sitting in the same room and side by side. BTW, there has been no additional apps installed as I told him not to install any until I find out what's going on. I'm going to give it another day or so to see if anything improves, if not, then the phone is being exchanged or he's getting another phone. Thanks again for all of the help.
    This may or may not help, but go to settings...more...mobile networks..
    preferred network and type... Select the middle one "LTE/CDMA." The default is "global", but unless you travel internationally this setting may (or may not) cause problems with networking handoffs. Can't hurt to try right?

    Posted via the Android Central App
    11-17-2014 08:17 PM
  13. jnb5531's Avatar
    I've been having similar issues with hand off. Some messages are hanging and I have to toggle airplane mode

    Posted via the Android Central App
    11-17-2014 08:35 PM

Similar Threads

  1. S pen and tempered glass screen protector
    By M3Stang in forum Samsung Galaxy Note 4
    Replies: 9
    Last Post: 12-03-2014, 07:48 PM
  2. Double curved Edge display on Samsung S6 and Note 5?
    By SHIVA77 in forum Samsung Galaxy Note Edge
    Replies: 2
    Last Post: 11-27-2014, 11:01 AM
  3. What is turning on my wifi?
    By MikiSunshine in forum Ask a Question
    Replies: 11
    Last Post: 11-18-2014, 02:36 PM
  4. Clicking Noise by Verizon and Droid Logo
    By kansasandroid1 in forum Motorola Droid Turbo
    Replies: 9
    Last Post: 11-16-2014, 06:28 PM
  5. Replies: 2
    Last Post: 11-16-2014, 04:01 PM
LINK TO POST COPIED TO CLIPBOARD