1. Racing24's Avatar
    I'm using my Droid Turbo on TMobile and overall the experience of using the phone on a GSM carrier has been a smooth one with the exception of one very big annoyance.

    When I'm on wifi (I have tried 5 different wifi networks at both work and home), my cellular data connection defaults to "G" from "4g LTE." The only way to restore 4G connectivity is to to toggle wifi off and then everything goes back to working as it should.

    Any ideas from the group as to what's causing this issue?

    Posted via the Android Central App
    12-02-2014 04:17 PM
  2. VZWsucks's Avatar
    You have given me hope that I can leave vzw with my turbo. Thank you.

    Sent from my DROID Turbo64
    12-05-2014 03:36 PM
  3. Racing24's Avatar
    You're welcome. It's a great device.

    Posted via the Android Central App
    12-05-2014 08:41 PM
  4. mrshamoozoo's Avatar
    What are the apn settings you used? I'm trying to help my friend get his phone to work on t-mobile. Please and thank you
    12-09-2014 04:59 PM
  5. Racing24's Avatar
    If you Google the APN settings for LTE enabled devices on TMobile, you should be good to go.

    Posted via the Android Central App
    12-09-2014 07:02 PM
  6. Racing24's Avatar
    I forgot to mention that when you get your friend's phone up and running, please PM me. I'm interested to learn if he/she experiences a particularly nagging problem I have experienced where I lose LTE connectivity ONLY when connected to a wifi network. I'm curious to know if your friend experiences the same issue.

    Posted via the Android Central App
    12-09-2014 07:06 PM
  7. ChadKnight's Avatar
    thats a tmobile thing i guess even with iPhone while on wifi you only get the phone network no 4g/lte 3g or 2g. not really an annoyance since im using my wifi for data plus wifi calling on devices that have the feature. I need the wifi calling since in my home i get 1 bar or none.
    02-01-2015 12:33 PM
  8. Aibo1990's Avatar
    It's tough finding real life reviews on how the Turbo works on Tmobile. Anyone or the OP still like using the Turbo on Tmobile? Do the missing bands make much of a difference in everyday use?
    02-02-2015 09:06 PM
  9. Mad Money's Avatar
    It's tough finding real life reviews on how the Turbo works on Tmobile. Anyone or the OP still like using the Turbo on Tmobile? Do the missing bands make much of a difference in everyday use?
    I just recently switched my turbo to T-Mobile from Verizon as my bill for 2gb was insane and I have to say t mobile is great so far. I have noticed the WiFi issue u have but other then that its been great
    02-07-2015 01:42 AM
  10. thekurrgan#AC's Avatar
    This phone is not going to do well with T-Mobile. Its missing the 1700 WCDMA band, which is what Tmobile uses in a lot of areas. If you arent a road warrior you may not notice the missing band. I'm not a t mobile fan. I had them for 22 days. Worked good in cities but was pretty much **** everywhere else. Verizon is far from perfect, but after 3 years of never working in an area Verizon didnt work, I'm sold and will pay the premium. 9 out of 10 places I seem to get sent AT&T doesnt even work.
    doogald likes this.
    02-08-2015 11:26 PM
  11. Lev1athan12's Avatar
    I have T-Mobile and that's completely normal. Every time I'd use any WI-FI on my Nexus 5, it would switch my network to a lower version, but once I turned WI-FI off it would go back to 4G LTE.
    08-30-2015 02:10 AM
  12. Tommy Wright1's Avatar
    I am using the Drpid turbo from vzn n have my tmobile sim installed. It wont make or receive calls...will jabe the 4glte lit up in corner for a bit but then goes away...Im stumped
    01-08-2017 01:40 PM

Similar Threads

  1. Is My Turbo Defective? Battery, Heat, and Stability Issues
    By MayonnaiseOreo in forum Motorola Droid Turbo
    Replies: 7
    Last Post: 04-06-2015, 10:16 AM
  2. Droid Maxx battery not even lasting a full day
    By pessen in forum Motorola Droid MAXX
    Replies: 18
    Last Post: 12-07-2014, 02:21 PM
  3. Wifi, Bluetooth, mobile hot spot no longer turn on
    By craigb_ma in forum Motorola Droid MAXX
    Replies: 2
    Last Post: 12-04-2014, 07:52 AM
  4. fails on boot downloading screen
    By Daniel Estrada1 in forum Ask a Question
    Replies: 2
    Last Post: 12-03-2014, 01:14 AM
  5. Turbo LED possibility?
    By mobrules in forum Motorola Droid Turbo
    Replies: 4
    Last Post: 12-02-2014, 09:35 PM
LINK TO POST COPIED TO CLIPBOARD