1. Brian Singleton's Avatar
    I suppose this is more a general Android question, but it seems to be happening more on my Turbo than my Nexus 7. Google Now seems too be awakening my phone extremely often. While the wakelocks in and of themselves aren't draining the battery much, it doesn't allow for much deep sleep processor time, which seems to be the key to optimal battery life. I'm not saying my battery time is bad, but it isn't great considering how little screen on time I have in the course of a normal day. Any suggestions on how to still actually use Google Now without having it wake my phone so much? Note that I'm not getting constant notifications or have any location based reminders going at the moment. Not sure if this screen show does it justice, but I've had an insane amount of wakelocks with the screen off. I think I have it narrowed down to Google Now.

    Google Now / Play Services Wakelocks-screenshot_2014-12-04-16-33-08.jpg
    12-04-2014 04:38 PM
  2. cyberr8der's Avatar
    Go to Google settings in your app drawer, select security and uncheck the top two boxes. Then go to Android settings, location, Google location reporting and turn both options off.
    12-04-2014 04:42 PM

Similar Threads

  1. Motorola camera vs google camera
    By bjbaker in forum Moto X (2014)
    Replies: 19
    Last Post: 12-08-2014, 08:44 AM
  2. Yes Yes Yes ,5.0.1 now downloading to my n7 wifi
    By Mick Bond in forum Google Nexus 7 Tablet (2013)
    Replies: 15
    Last Post: 12-06-2014, 03:23 PM
  3. Replies: 4
    Last Post: 12-04-2014, 04:33 PM
  4. Why doesn't the Play Store app allow me to make an account?
    By Emmanuel Hernandez4 in forum Ask a Question
    Replies: 6
    Last Post: 12-04-2014, 04:15 PM
  5. Why won't my Galaxy Tab 3 play videos?
    By FrankGarner in forum General Help and How To
    Replies: 1
    Last Post: 12-04-2014, 03:49 PM