1. Drewence's Avatar
    I'm wondering if anyone is having the same issue that I am - within the last week the gmail app on my turbo is effectively useless. The app works fine on other devices, but on my Turbo it won't stay open long enough to read even one email; it will then repeatedly crash, often without any further input from me.

    Is anyone else getting this problem? I am open any 'work-arounds' and fixes... Thanks!
    12-18-2014 12:17 PM
  2. doogald's Avatar
    I'm wondering if anyone is having the same issue that I am - within the last week the gmail app on my turbo is effectively useless. The app works fine on other devices, but on my Turbo it won't stay open long enough to read even one email; it will then repeatedly crash, often without any further input from me.

    Is anyone else getting this problem? I am open any 'work-arounds' and fixes... Thanks!
    That's weird. Try settings / apps, scroll down to Gmail and tap it, and tap the "uninstall updates". This will remove the Play Store installed update - see if that works better. If so, then you should see the update again in the Play Store - try installing it. It may be that something was corrupted on the update.

    If that doesn't help, settings / apps / Gmail again, Tap the "clear data" button in the middle (it takes a little while for the settings app to calculate how much data is being used - it should take about a minute at most) - that will remove all messages and settings from the Gmail app. It may be that there was data corruption. They will resync shortly after. You'll have to set up any custom ringtones or notifications again, but hopefully that will fix it, if the uninstall update above did not.
    Drewence likes this.
    12-18-2014 12:56 PM
  3. sofryj's Avatar
    I have moved all my emails over to the GMail app on my Turbo. I am definitely not having the issues you are. It has acted up a few times though. The app is set to never delete mail off the server for my work email, and twice recently it has in fact cleared the server. If it happens again, I will no longer be using it.

    You can try uninstalling the app, then re-installing. It may have somehow been corrupted.
    12-18-2014 12:56 PM
  4. Drewence's Avatar
    Per Doogald's comments - I uninstalled the updates, and also cleared the cache (not 'clear data'). I opened the app and it worked fine. After a period of time (the drive to work) I updated the app from the Play store - and all is working perfectly!

    Thanks!
    12-19-2014 11:15 AM
  5. doogald's Avatar
    You bet. I'm glad it was an easy enough fix.
    12-19-2014 11:34 AM

Similar Threads

  1. Note 4 notification light problem ?
    By iAmDroiDz in forum Ask a Question
    Replies: 1
    Last Post: 01-31-2015, 09:57 PM
  2. Getting turbo for Xmas... couple of questions
    By RabidDawg in forum Motorola Droid Turbo
    Replies: 7
    Last Post: 12-18-2014, 09:15 PM
  3. Problems since update
    By samdem in forum Sony Xperia Z3
    Replies: 4
    Last Post: 12-18-2014, 05:41 AM
  4. Gmail notification issues
    By Billy Bixby in forum Motorola Droid Turbo
    Replies: 3
    Last Post: 12-17-2014, 10:08 PM
  5. with exchange now built into gmail, why is there no conversation view
    By Fuzzy761210 in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 12-17-2014, 07:37 PM
LINK TO POST COPIED TO CLIPBOARD