1. jpdaballa's Avatar
    Hey all, just switched from my s5 to the droid turbo and I'm loving every bit of it. Just ran into an issue with my first droid turbo where it would crash and reboot under stress or phone calls (like 10 times a day), so I got a replacement from Verizon the next day. This new phone also crashes randomly but much less around 3-4 times a day. I have the ballistic nylon 64gb version and thought I should mention my brother has the same phone and he has the same issues with rebooting.

    Does anyone else have this issue? I have a feeling it has to do with the different memory. Has moto said anything?

    Thanks for any input

    Posted via the Android Central App
    12-25-2014 11:05 PM
  2. JJ Jones's Avatar
    May or may not help, but I also have the 64 BN and haven't had one crash yet.

    Sent from my Ballistic Turbo
    12-26-2014 12:49 AM
  3. KSDroid01's Avatar
    FWIW, I've got the 64gb also and have never had this problem.

    Posted via the Turbo
    12-26-2014 12:58 AM
  4. jpdaballa's Avatar
    I guess the best thing for me to do is try for one more replacement a quick Google search with some digging showed some people with the same problem as me but since moto hasn't said a thing about it I doubt they'll issue an update or fix

    Posted via the Android Central App
    12-26-2014 03:43 AM
  5. ckelly33's Avatar
    I've got the same phone and had it happen maybe 5-6 times since Oct 31
    12-26-2014 10:06 AM
  6. Davidoo's Avatar
    I have also had it happen about 5-6 times since I got the phone on Nov 1. For me it always rebooted during a call. I took my Turbo in on the 14th day and the manager at the Verizon store convinced me to keep it and they put in a new SIM card. I haven't had this happen since. I would try this first. Here's the thread I started due to my experiences.... http://forums.androidcentral.com/mot...ml#post4121326
    jpdaballa likes this.
    12-26-2014 10:27 AM
  7. jpdaballa's Avatar
    I just left the Verizon store with a new sim and I'll let everyone know if the problem still persists thanks so much for the information Davidoo1

    Posted via the Android Central App
    12-26-2014 04:31 PM
  8. Davidoo's Avatar
    I just left the Verizon store with a new sim and I'll let everyone know if the problem still persists thanks so much for the information Davidoo1

    Posted via the Android Central App
    Good luck jp. I even wonder if it was the SIM at all as I think with the way this is designed behind the volume rocker it could just have been loose.
    12-26-2014 05:53 PM
  9. jpdaballa's Avatar
    After a day I can say that that it happens much less often. It happened when I left my house and it disconnected from my airport extreme on WiFi. And another time when I was making a phone call. It happened two times yesterday and I'm going to try taking the sim card out and back in. If it still reboots I'll get a replacement.

    Posted via the Android Central App
    12-27-2014 03:49 PM
  10. D._Manley's Avatar
    For whatever reason, there's been more than one post about issues with the Apple Airport.
    12-27-2014 04:26 PM
  11. anon(9228075)'s Avatar
    Hey all, just switched from my s5 to the droid turbo and I'm loving every bit of it. Just ran into an issue with my first droid turbo where it would crash and reboot under stress or phone calls (like 10 times a day), so I got a replacement from Verizon the next day. This new phone also crashes randomly but much less around 3-4 times a day. I have the ballistic nylon 64gb version and thought I should mention my brother has the same phone and he has the same issues with rebooting.

    Does anyone else have this issue? I have a feeling it has to do with the different memory. Has moto said anything?

    Thanks for any input

    Posted via the Android Central App
    Never happened here and I also have the 64 gb BN edition.

    Posted via the Android Central App
    12-27-2014 07:23 PM
  12. jpdaballa's Avatar
    It happened again after leaving my house and not disconnecting from my airport extreme. Its whenever I lose connection from the airport and don't disconnect the WiFi. After replacing the sim that seems to be the only time it reboots but I couldn't recreate the issue. I'll see if it resets for any other reason

    Posted via the Android Central App
    12-28-2014 12:28 AM
  13. jpdaballa's Avatar
    It just reset when I swiped away the notification that its connected to my airport network. I'll get a replacement just for the heck of it. Anyone else experiencing the same issue with an apple airport extreme or any other router?

    Posted via the Android Central App
    12-28-2014 04:08 AM
  14. gdflynn1's Avatar
    It just reset when I swiped away the notification that its connected to my airport network. I'll get a replacement just for the heck of it. Anyone else experiencing the same issue with an apple airport extreme or any other router?

    Posted via the Android Central App
    I am. Search my posts under gdflynn1. Replacing the device wont help I am on number 3 and can consistently recreate issue with the apple airport. The best thing to do is for those who experience this please report the issue to VZW tier 2 so they let moto know and hopefully a fix comes.
    jpdaballa likes this.
    12-28-2014 08:14 AM
  15. jpdaballa's Avatar
    Thanks for the input gd I'll call today. Last question I have is for daviddoo, if you get a chance can you check what kind of sim card you have? The manager at the Verizon store told me its important to have a sim card that has the letters NFC imprinted on it. Can you check what letter sequence sim card you have?

    Posted via the Android Central App
    12-28-2014 03:08 PM
  16. Davidoo's Avatar
    Sorry jp......I will do most things I can to help, but no way do I want to pull out the volume rocker and disturb my SIM card after now having zero reboots since they put the new one in my Turbo back on November 14th. Just can't take a chance on not getting it in perfectly as it is now. Dave
    12-28-2014 07:25 PM
  17. jpdaballa's Avatar
    No problem I completely understand, I wouldn't either. I got a replacement today and it's absolutely flawless. The two I had replaced at the beginning were the same build date this one was November 24
    12-28-2014 11:21 PM
  18. gdflynn1's Avatar
    I'm jealous jpd I got to work today and like clockwork, it connected to the airport wifi and immediately rebooted. Ugggg......
    12-29-2014 09:47 AM
  19. jpdaballa's Avatar
    Don't be jealous, my phone reboot not once but twice today when connecting to the airport. I spoke to soon. I hope enough people complain to Verizon about this issue, we can't be the only ones with an airport!
    12-29-2014 12:58 PM
  20. gdflynn1's Avatar
    Don't be jealous, my phone reboot not once but twice today when connecting to the airport. I spoke to soon. I hope enough people complain to Verizon about this issue, we can't be the only ones with an airport!
    Damn, sorry to hear that ! Its effing annoying, isnt it? Keep on calling and complaining, that's the only hope. Or maybe lollipop will resolve it. Keep me posted. And I will do likewise.
    12-29-2014 06:38 PM
  21. jpdaballa's Avatar
    Just spoke to Motorola they said we should post in their forums, so I'll start the thread and update this post with the link to the thread for any one experiencing the same issue.

    Posted via the Android Central App
    01-02-2015 07:50 PM

Similar Threads

  1. New to Samsung and Android
    By emailslipknot-0 in forum Samsung Galaxy S5
    Replies: 17
    Last Post: 01-21-2016, 06:38 PM
  2. Replies: 3
    Last Post: 12-30-2014, 08:25 AM
  3. I need help choosing security and cleaning software
    By PDX97229 in forum Motorola Droid MAXX
    Replies: 2
    Last Post: 12-26-2014, 10:52 AM
  4. On my Tab pro 8.4, why do I have a random buzzing noise from the speakers?
    By WonderMousePC in forum Samsung Galaxy Tab Pro 8.4
    Replies: 2
    Last Post: 12-26-2014, 05:49 AM
  5. Blu Life One (L120) Problem
    By Antony Guan in forum General Help and How To
    Replies: 2
    Last Post: 12-25-2014, 08:59 PM
LINK TO POST COPIED TO CLIPBOARD