1. fofjjsr's Avatar
    Anyone else getting terrible wifi signal strength? Using the same router and everything my Turbo gets terrible reception everywhere minus right next to the router. My S5 I got decent signal everywhere. Anyone else had/seen or know a fix for this?
    01-17-2015 08:36 PM
  2. Rukbat's Avatar
    Bring it back. You could have a bad radio or an antenna that's not connected.
    01-17-2015 08:38 PM
  3. Eclipse2K's Avatar
    Nope, same as my Note 3 and S5 were. Asus Wireless AC router.

    Great signal. Do you use 5 or 2.4 GHz?
    01-18-2015 05:46 AM
  4. fofjjsr's Avatar
    I have tried both 5 (which I know has a week signal strength but higher end speeds) and 2.4
    01-18-2015 05:49 AM
  5. Eclipse2K's Avatar
    I have tried both 5 (which I know has a week signal strength but higher end speeds) and 2.4
    I know you used your S5 and had no issues but consider this.

    2.4 GHz is great for environments with minimal interference. If you live in an apartment this band will be congested and your speeds and possibly signal may suffer. Range is generally greater than 5GHz.

    5 GHz provides top tier speeds at any distance within its range but does not reach as far as the 2.4 GHz band. Less appliances use this band so it may indeed be the best option if you live in a congested environment.

    Of course none of this matters if your WiFi radio is struggling. It can be the phone, router or both. What brand and model router do you have? Is it a Gateway (Modem + Router in 1 unit) or separate modem/routers?
    01-18-2015 05:59 AM
  6. UnlockedOnly's Avatar
    is your router dual band ?? I have in home verizon fios, my wifi signal on my turbo is rarely at full signal and is still blazing fast even with 1-2 bars of signal. mostly due to the strong signal of fios I assume. My fios router is not dual band and I still have average speeds of 48.76 down/ 43.18 up.
    01-18-2015 11:19 AM
  7. wolf_walker's Avatar
    Been there done that, it's demonstrably less sensitive than my Nexus 7 or S4, and even an early motoG.
    2ghz is worse than 5, or harder to tell the diff at least. I sent a bunch of info to moto support awhile back,
    they didn't suggest an answer but confirmed my findings. Hopefully something will happen with L.
    If I'd got this phone out of the blue and not had anything to compare it to, or if I was never in finge wifi areas
    that I was used to getting reception in previously, I might not have noticed. It's not crazy bad, but it's there on
    more than a few examples. I have a number of side by side photos and videos showing signal strength
    via wifi analyzer app and have cross checked results with netgears apps. I replaced my pretty good Asus
    router with a very good Netgear, factory reset, channels are ideal and not very congested here, etc, etc, etc.
    It's the phone. I'm prepared to believe at this point it is not all, or even a majority of them, but it's by far not just one here or there.
    I see someone online almost weekly coming across the same problem.

    All that said, I'd exchange it if I were you, and try to document if the 2nd one has the same issues via controlled situation dba readings.
    01-18-2015 04:29 PM

Similar Threads

  1. Motherboard Issue with Samsung Galaxy S4
    By yojake in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 01-18-2015, 10:14 AM
  2. Slingbox/Slingplayer connection issues
    By rockytt in forum LG G3
    Replies: 1
    Last Post: 01-17-2015, 06:49 PM
  3. Missed call on lock screen issue.
    By hogdog62000 in forum Verizon Samsung Galaxy S4
    Replies: 0
    Last Post: 01-17-2015, 06:01 PM
  4. Is it possible to make my ZTE phone a wifi access point?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-17-2015, 03:10 PM
  5. Replies: 0
    Last Post: 01-17-2015, 12:17 PM
LINK TO POST COPIED TO CLIPBOARD