1. not_max's Avatar
    I'm having a very odd experience with my new Droid Turbo trying to get bluetooth audio to work as expected.

    Expected behavior:

    1. Pair your bluetooth headset to your phone
    2. Make a call, the audio & mike are routed through the headset
    3. Hang up the call and open any app that makes a sound (say "Play Music" or "Youtube"). You see an icon showing your headset is connected and audio will be played via the bluetooth headset
    4. Press PLAY and the audio is heard through the headset


    Actual behavior: as expected for steps 1-3 but the audio plays through the speaker and not the headset. Step 4 fails.

    I can select 'disconnect' and 'connect' but nothing makes the media audio to come out of the headset. Please note: the headset is pairing and I can successfully make/take phone calls via the headset. I just can't seem to get the media audio to route correctly.

    It's hard to explain, I made a video on Youtube but my score on here isn't high enough yet to post a link so this might not work: youtube.com/watch?v=gFuNpopLlSo You'll notice that no matter what the app says about being connected to the headset the audio always plays out the speaker.

    I've tried:

    • Moto Hint and another bluetooth headset (the PS210 BTNC - full stereo A2DP)
    • Factory reset of the headset
    • Wiping the cache partition on my phone
    • Rebooting
    • Disabling and re-enabling bluetooth
    • Disabling and re-enabling the Media Audio option under the Bluetooth settings for the headset (it is set to ON "use for media audio")
    • Trying this test with another Android phone (LG G3 running Android 4.4.2) - it works as expected and does not display this issue
    • Different apps (Play Music, Youtube, BeyondPod)
    • Ensuring the headset is not connected to my Moto 360
    • Removing all paired bluetooth devices except for the headset in question
    • Disabling the Moto Connect features (e.g. silence during meetings, play via headphones while driving, etc.)


    The only thing I haven't tried is a factory reset of the phone. I really don't want to do that: it's only a few days old and it took me the better part of a day to install all the apps, copy data, etc.

    The behavior is so consistent I'm coming reluctantly to the conclusion that I may have just missed some obvious option in the settings or audio control.

    Interestingly, in desperation I tried installing 'SoundAbout', an app on the Play store that allows you to force certain things about bluetooth audio. With that app I was able to get the audio to play for a while, but when I went back (thinking I'd fixed the issue) it stopped working and even a remove/reboot/reinstall/reboot didn't make it work again.

    Is this a bug? Or am I being dumb and missing some obvious setting?

    Everything worked fine on my LG G3 and I'm puzzled why I can't route my audio out of my bluetooth headset on my Droid Turbo in the same way.
    01-29-2015 01:26 AM
  2. doogald's Avatar
    Just to ask the question, you've gone into settings / Bluetooth, tapped the setting icon to the right of the headset, and made sure that "media audio" is checked?
    01-29-2015 08:48 AM
  3. not_max's Avatar
    Yes, it is checked. I tried unchecking & rechecking.

    The problem was Voxer. It was silently taking over the media audio channel. No running notification, didn't even open up the app. It would do this about 60-90 seconds are a reboot. Unselecting the bluetooth option on voxer solved the problem. Feels like they are breaking some kind of app store rules the way they do this, and I wasted a lot of time trying to find the cause of the problem, but all good now.
    xx_shipwrecked_xx likes this.
    01-30-2015 01:40 PM
  4. xx_shipwrecked_xx's Avatar
    not_max,
    Dude, you're the awesome! You just helped me solve a problem that's been driving me nuts for a few weeks now! Thank you so much!
    not_max likes this.
    02-16-2015 12:23 AM

Similar Threads

  1. How is this with people with glasses?
    By dt81 in forum VR Headsets
    Replies: 5
    Last Post: 02-14-2015, 01:33 PM
  2. Replies: 0
    Last Post: 01-28-2015, 10:22 PM
  3. Replies: 0
    Last Post: 01-28-2015, 10:19 PM
  4. Replies: 0
    Last Post: 01-28-2015, 10:14 PM
  5. Why don't I have audio when screen mirroring?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-28-2015, 10:08 PM
LINK TO POST COPIED TO CLIPBOARD