1. AC Question's Avatar
    I have the 32GB Ballistic Nylon Droid Turbo for a while now but I have just now run into a problem. Whenever I plug in my phone to the turbo charger it doesn't always charge, It might say charging but when I go into the battery section it still thinks it running on battery. Other times it will charge then stop, then I have to plug it back in all over again. I really need help because this is the 5th time I have woken up to a dead phone while its sitting on the charger.
    04-07-2015 10:02 AM
  2. belodion's Avatar
    Welcome to Android Central.

    A faulty USB lead or a faulty or dirty USB port are quite likely possibilities, but it could be anything in the charging circuit, from wall socket to battery.

    Posted via the Android Central App
    04-07-2015 10:18 AM
  3. TimCasey27's Avatar
    I have the same problem. Sometimes unplugging and plugging it back in at the phone end will start it charging again, other times it won't. I've tried several different chargers, but I get the same result with all of them.
    06-04-2015 11:20 PM
  4. hyzer400's Avatar
    I have the same problem. It seems to be happening more frequently with each passing week.
    09-24-2015 04:38 PM
  5. Austin Reed2's Avatar
    I've bought 5 new chargers. It's etremely hard to keep it charging and when it is charging, it charges slow as hell.
    12-29-2015 07:39 PM
  6. Jim Buster's Avatar
    Any ideas on practical solutions or actions to take?
    02-26-2016 01:16 PM
  7. Laura Knotek's Avatar
    Could the USB port be damaged? Have you taken it to a repair shop to get it checked out?
    02-26-2016 01:28 PM
  8. slowmyke's Avatar
    I suddenly have this issue with my 32 gig Turbo today. I just went through the "optimizing apps" booting issue, which drained my battery. I think I got passed that by wiping the cache partition (not entirely sure, but it was suggested and seems to have helped since this morning) but now my phone won't charge properly. It will not charge when plugged into the wall, even though it recognizes it is plugged in. I get the lightning icon over the battery, the battery menu indicates it's plugged in, and the low battery warning goes away, but the battery continues to drain. It will charge when plugged into my computer at work, but extremely slowly. I know charging from a computer is slower in general, but I used to charge off the computer on a regular basis before I brought a wall unit in to work. It took about 4 hours for a full charge, but it's been plugged in about 4 hours now and only made it to 35%. If I am using the phone, the charging cannot keep up and the battery will go down. I've checked both chargers on my tablet, and they charge it fine. I haven't dropped my phone recently or abused it, I'm pretty careful with it. I can't think of any reason it should suddenly have these issues. Any ideas? I sincerely don't want to go spend my evening at a Verizon store or on another phone to get this one dealt with.
    04-01-2016 03:25 PM
  9. gigemags's Avatar
    I'm curious to know if slowmyke found any answers? My Droid Turbo does that exact same thing.
    04-27-2016 02:26 AM
  10. slowmyke's Avatar
    I'm curious to know if slowmyke found any answers? My Droid Turbo does that exact same thing.
    Not exactly. I've pitched the charger I had at work and brought in a new cord to charge off the my computer when needed. It's still unbelievably slow, but until I get around to buying another wall charger it'll suffice. The phone seems to charge alright at home and in my car, so I'm not sure what's going on at work.

    As for the optimizing apps issue, I haven't had it since that day, but I make sure not to restart while on a charger, which is supposedly a trigger for the problem.
    04-27-2016 08:17 AM
  11. rharvey3002's Avatar
    When I upgraded to marshmallow I stated having charging issues.
    how many of you that are having charging issues, upgraded to marshmallow?
    did your problem start before or after the upgrade.
    mine started after the upgrade.

    if you google it you will see many others are in the same boat.
    thanks
    Robert
    05-12-2016 12:53 PM
  12. bigbadwulff's Avatar
    I called Verizon. They sent me a new Turbo after jumping a couple hurdles. Easy squeezy.
    05-12-2016 07:39 PM
  13. Alex Ortiz27's Avatar
    When I upgraded to marshmallow I stated having charging issues.
    how many of you that are having charging issues, upgraded to marshmallow?
    did your problem start before or after the upgrade.
    mine started after the upgrade.

    if you google it you will see many others are in the same boat.
    thanks
    Robert
    05-18-2016 10:16 PM
  14. Alex Ortiz27's Avatar
    Same here. After update turbo charge doesn't work anymore. Is there a fix for this?
    05-18-2016 10:17 PM
  15. 1Coopgt's Avatar
    "When I upgraded to marshmallow I stated having charging issues.
    how many of you that are having charging issues, upgraded to marshmallow?
    did your problem start before or after the upgrade.
    mine started after the upgrade.

    if you google it you will see many others are in the same boat.
    thanks
    Robert "

    Same here. After update turbo charge doesn't work anymore. Is there a fix for this?
    So how are you guys on Marshmallow ? The Turbo hasn't gotten Marshmallow yet . By chance do the 2 of you have the Turbo 2 ? If so you're in the wrong forum.
    05-19-2016 05:56 PM
  16. Joe1013110's Avatar
    I called Verizon. They sent me a new Turbo after jumping a couple hurdles. Easy squeezy.
    Did they make you use your upgrade for the new phone?
    09-08-2016 08:10 AM

Similar Threads

  1. Replies: 6
    Last Post: 06-23-2015, 12:16 AM
  2. Replies: 2
    Last Post: 04-09-2015, 06:03 AM
  3. When I press the home key I get Ok Google. Why?
    By Cathy Carnell Chapman in forum General Help and How To
    Replies: 1
    Last Post: 04-07-2015, 09:43 AM
  4. How do I locate my lost phone if it's off?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-07-2015, 09:42 AM
  5. Replies: 1
    Last Post: 04-07-2015, 09:41 AM
LINK TO POST COPIED TO CLIPBOARD