1. MikeLip's Avatar
    Yeah, I know. It's bizarre. SO I have a couple phones. Well, quite a few. It started when I could not download books to the Turbo. It just put an exclamation point in the title and says sorry, try again later. I try again later for several days, and nothing changes. On the other hand everything works fine on my other phones, and I can log into Amazon no problem. So I tried uninstalling and reinstalling Kindle. This is not a complete uninstall of course since Kindle is pre-installed and unless you root, you're stuck with it. But after I uninstalled the updates it still would not work. So I nuked from orbit by wiping the phone and reinstalling Kindle (well, updating the built-in version). Well, THAT changed it. Now it won't take the password. It allows me to CHANGE the password, and I did that. But even after changing it (successfully it said) and verifying that the new PW worked on another phone and on my laptop, it still won't take it. It says that username/password combination does not exist.

    I called Amazon support and, after fussing with it for an hour they said "Huh. Never seen this before. I need to talk to the developers." That was last week and I've had no contact from them since. I assume they just flushed the problem down the toilet and forgot about it.

    At this point I'm out of ideas. The thing is it USED to work. Until a couple weeks ago when it decided to stop downloading books.
    04-28-2015 06:36 PM
  2. B. Diddy's Avatar
    Do you have any other Amazon apps installed? Are you able to log into Amazon Appstore, or the Amazon app, using that same username and password on the Turbo?
    04-28-2015 06:49 PM
  3. rich_r's Avatar
    Did you check your Amazon account, you can only have 10 devices. When you uninstall it treats that as a new device. You might need to deregister some old devices.
    doogald, B. Diddy and rxgadget like this.
    04-28-2015 07:49 PM
  4. MikeLip's Avatar
    OK thanks. I have five registered devices on my Kindle account, so that should be OK. The fifth ws just added and it signs on fine. As for other Amazon apps, yes I do. They won't sign on either. I'm kinda out of ideas here.
    04-29-2015 05:34 PM
  5. B. Diddy's Avatar
    Not sure if this will work, but go to Settings>Security, and Clear Credentials.
    04-29-2015 06:02 PM
  6. MikeLip's Avatar
    It's worth a shot! Thanks!
    04-29-2015 06:23 PM

Similar Threads

  1. Which Unlocked model for use in USA, SM-G920i or SM-G920f?
    By mrZoSo in forum Samsung Galaxy S6
    Replies: 16
    Last Post: 12-20-2017, 10:17 PM
  2. Turbo Has Incorrect Time
    By rjr1049 in forum Motorola Droid Turbo
    Replies: 4
    Last Post: 04-29-2015, 02:10 AM
  3. Vibration notification only for Facebook How to stop that ?
    By Malartic2012 in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 04-28-2015, 07:00 PM
  4. Extra long band for Gear 2 Neo?
    By Douglas Yarnold in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 1
    Last Post: 04-28-2015, 06:32 PM
LINK TO POST COPIED TO CLIPBOARD