1. AC Question's Avatar
    I have a new Droid Turbo, and when I connect the USB cable to my Win 8.1 PC, the Turbo says, "Connected as a media device", but I can't see it in file explorer. In "USB computer connection", I've checked "Media Device (MTP)", but nothing on my PC. Also, my Turbo will charge with the included charger or an old Samsung charger, but not just when connected via USB to my win 8.1 PC. Thanks.
    GADA 50 likes this.
    05-20-2015 10:20 PM
  2. Golfdriver97's Avatar
    Welcome to the forums. You might need to install Moto drivers. That might help with the devices seeing each other. However, about the charging thing..I am not sure.
    05-20-2015 10:24 PM
  3. doogald's Avatar
    Also, my Turbo will charge with the included charger or an old Samsung charger, but not just when connected via USB to my win 8.1 PC. Thanks.
    That's probably because the USB connection on your PC cannot supply enough amps to charge the Turbo when it is connected. I believe that the standard for USB 2.0 ports on laptops/computers is to supply only half an amp at 5V to each connected device. That is likely not enough current to charge the device, even with the display off.

    You can try connecting to another USB port to see if that changes anything, but do note that USB 3.0 ports may not work with the Turbo for carrying data (though they should be better at charging - devices can draw up to 900 mA, which is enough to charge a Turbo.)

    You are far, far better off plugging into a wall outlet, or using wireless Qi charging as a second choice, over using a computer's USB port to charge your phone on a regular basis.
    05-21-2015 10:30 AM
  4. goodideadave's Avatar
    My Samsung would charge just fine through the same USB port and cable, so I just assumed...

    I'm also trying to figure out why the phone doesn't appear in Windows Explorer. I am using Win 8.1, 64 bit. When I first got the phone, I plugged it in to a USB port and it came up in explorer as a CD drive. It prompted me to install Motorola Device Manager, so I did. But now it doesn't connect. Elsewhere on this site it says to uninstall MDM and reinstall, but now when I download from Moto's site, the installation hangs at "Extracting files 1 of 3". Any ideas?
    05-21-2015 09:01 PM
  5. doogald's Avatar
    Do you have antivirus/antimalware on your computer? Try disabling it while you install the moto drivers and see if that helps...
    05-21-2015 09:35 PM
  6. goodideadave's Avatar
    Good thought, but nah, still hangs at the same place.
    05-21-2015 09:49 PM
  7. zen45's Avatar
    I got my droid turbo about 10 days ago and hooked it up to my usb 2.0 and it charged just fine, but then again its problem could be the motherboard they are all made a little different I have usb 2 and 3 on mine, also at the start I couldn't see any files on the phone only xt1254 and when I clicked on it there was nothing there, I got my phone from Verizon when I went to there web site I downloaded their Verizon wireless upgrade assistant it loaded some drivers and when it was done then I could see some files in the xt1254 also I found I could put .apk files In the download file and install them. don't know if that helps you any hope it does !
    05-22-2015 11:19 AM
  8. RJ_Butler's Avatar
    Try tapping on the notification in the status bar, where it says connected as a Media Device. It'll bring up a menu that gives you an option to switch to connect as a camera, and a checkbox at the bottom that says something like install device driver software. Make sure that box is checked, or else it won't do anything
    05-22-2015 12:58 PM
  9. goodideadave's Avatar
    RJ: Did all those things, but the PC still doesn't see it in Win Explorer. Thanks.
    05-22-2015 07:33 PM
  10. goodideadave's Avatar
    Spent 40 minutes chatting with Motorola customer help on their support site. The bottom line is that it's a problem with Motorola device manager, and there is no expected resolution. So, thanks for the money, but you're stuck. I think I've got a few days left to return the phone at the Verizon store and get a Samsung.
    05-23-2015 04:53 PM
  11. Emperor's Avatar
    I had the same problem. Are you using the USB cable that came with the phone? I was using USB cable that came with a BT ear piece. Once I swapped the cables and started using a higher grade cable, problem was solved.


    64GB Beast
    05-24-2015 04:21 PM
  12. goodideadave's Avatar
    Thanks, Emperor, but no joy. I am certain that it has something to do with my PC not having the right drivers, and Motorola unable to give me the right drivers. Apparently I have a really rare, one-of-a-kind, unicorn PC, hmmm? No one else runs win 8.1 64 bit, or else there'd be drivers readily available, right?
    05-24-2015 09:33 PM
  13. nine11c2's Avatar
    Have you tried unlocking your phone? As in putting in the password on the security screen.
    06-22-2015 04:16 PM
  14. zen45's Avatar
    im running windows 8.1 64 bit and my computer has 3.0 and 2.0 usb ports, to charge and have access to my phone its connected as a media devise . I think when I installed the Verizon wireless upgrade assistant it installed usb drivers make sure you are using a usb 2.0 port I can add or delete music tones , add and remove directories all from the PC. so it will work, also when I plug my phone in the little Verizon icon pops up on my task bar, hope that helps some !!
    06-24-2015 07:32 AM
  15. ryanidcomm's Avatar
    drivers .. what is this 2009? and you should never install verizon software on your PC!! and there should be no issues with hardware and drivers... drivers is a OS thing....maybe updating your bios firmware.

    here are some real troubleshooting questions

    Have you tried a different computer with your phone?
    are you running windows 8.1 RT? off a surface?
    is your phone encrypted?

    Options.
    use a wifi transfer tool/ app
    try a powered usb hub?
    06-24-2015 11:29 AM
  16. zen45's Avatar
    2009 huh ? I also use a garmin gps which installs usb drivers to comuncate with the pc, and the droid turbo is a Verizon flagship devise made by Motorola who by the way also has there own usb drivers for talking to a pc thank you !!
    06-25-2015 08:57 AM
  17. ryanidcomm's Avatar
    Of course there are things that have obscure drivers.

    lets pump the breaks here...
    it was a joke.. but true in a way.

    windows 7 and 8.1 are very good at finding their own drivers..
    we are not rooting a phone here. we are transferring data.

    should not be this hard.. but the info supplied here is no good .. cant really help without stabbing in the dark.
    limeyinusa likes this.
    06-25-2015 04:27 PM
  18. limeyinusa's Avatar
    I had same issues with my Turbo. Tried connecting with 2 different USB cables to Win7 pc and iMac Air. Neither could see the phone.
    And slightly related. My Turbo charger that came with the phone would not charge the phone. Never mind in Turbo mode. Called Moto and they shipped a new cable /charger and all fine. Still no pc connection tho.
    I gave up on that.
    What are the best options for transferring GB's of date wirelessly?

    Posted via the Android Central App
    06-26-2015 08:05 PM
  19. NoICon's Avatar
    I've used the AirDroid app for wireless transfers...seemed to work OK but I only transferred relatively small files.
    06-27-2015 10:14 AM
  20. doogald's Avatar
    What are the best options for transferring GB's of date wirelessly?
    If by "wirelessly" you mean "by WiFi", I'd say the new app Portal (from Pushbullet) is the best bet: https://play.google.com/store/apps/d...android.portal
    06-27-2015 10:55 AM

Similar Threads

  1. why cant i see my keypad numbers to enter my pin
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-26-2015, 01:37 PM
  2. Why isn't my Nexus 7 charging?
    By AC Question in forum Google Nexus 7 Tablet (2012)
    Replies: 3
    Last Post: 05-23-2015, 10:14 AM
  3. Why won't my phone charge?
    By Chantelle_w in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 05-22-2015, 10:37 AM
  4. video won't play on galaxy s5
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2015, 10:20 PM
  5. Can't boot into system epic 4g t after twrp flash
    By kgash in forum Epic 4G Touch Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 05-20-2015, 09:35 PM
LINK TO POST COPIED TO CLIPBOARD