1. Phoenix212's Avatar
    Has anyone else experienced GPS issues recently with their Turbo? The past two I've had issues using both Waze and Google Maps for navigation. It was jumping around constantly and yesterday it thought I was driving in a river for five minutes! This is the first time I've experienced GPS-related issues with my Turbo. No recent app updates to Waze or Google Maps as far as I recall. No changes to settings on my end.
    Any thoughts on this?
    06-19-2015 10:17 AM
  2. KSDroid01's Avatar
    Finished an 11-hour drive yesterday and Google Maps was all over the place, several times it showed my arrow on my route but was about 5-6 miles behind my actual turns. A couple of other times it showed me traveling a half-mile or so offset from my route, and I knew darn well I was on the correct route. Very good thing I knew the route OK, or it would have been a mess.

    I'd updated Maps several days before, so I had been blaming it in the update.

    Posted via the Turbo
    06-20-2015 10:41 PM
  3. ckelly33's Avatar
    Had the same issue on an S6 yesterday.
    06-21-2015 08:36 AM
  4. Phoenix212's Avatar
    Had the same issue on an S6 yesterday.
    Was your issue using Waze or Google Maps or both? Do you have/use Waze?
    06-22-2015 11:20 AM
  5. ckelly33's Avatar
    Google maps. I've never used waze

    Sent from my SM-G925V using Tapatalk
    06-22-2015 11:46 AM
  6. wseyller's Avatar
    I came here to post my GPS issue and found this thread. On saturday 6/20 it was working fine since I got my Turbo last November. The issue started on Sunday and I cannot get a GPS lock. Navigation is unusable and I use it for work everyday as I service copiers.

    Google Maps, Waze, and a GPS toolbox app say searching for gps in status bar. Also searching for location notification in status bar. I have all location settings on with high accuracy set. GPS apps show zero satellites, but I got it to show 1 and 2 off them at one time. You need at least 4 to have accurate location.

    I wiped the cache partition no help. Then I factory reset and immediately tried again with no luck. There was a verizon store nearby today during lunch and they had me update all by google apps since my factory reset. No help. Lunch period ended.

    After work I went to a corporate store near my house. They tried a new sim card no help. They called an advanced tech on phone and it is believed I did everything I could. They factory reset again just to satisfy them and still no good.

    I get a factory recertified replacement in a couple days.
    Phoenix212 likes this.
    06-22-2015 07:25 PM
  7. Phoenix212's Avatar
    My GPS issues seem to have resolved. I used Waze yesterday and today without issue. Hopefully it was just a momentary lapse of reason and the GPS will work going forward.

    What have other people experienced? GPS working again? Issue remains?
    06-23-2015 10:13 AM
  8. wseyller's Avatar
    Mine hasnt work at all in about 4 days. Got my replacement which works like it should.

    Sent from my XT1254 using Tapatalk
    06-24-2015 11:26 PM

Similar Threads

  1. Huge Battery and charging issues
    By Shoji1199 in forum Sony Xperia Z3v
    Replies: 16
    Last Post: 07-12-2015, 08:32 PM
  2. Texting issue. Can't receive messages
    By sicario666 in forum Verizon LG G2
    Replies: 4
    Last Post: 06-21-2015, 04:00 PM
  3. Help to anyone without heating issues
    By TechGod2014 in forum LG G4
    Replies: 6
    Last Post: 06-20-2015, 04:28 PM
  4. Theme store issue
    By Keith Wardlow in forum Samsung Galaxy S6
    Replies: 2
    Last Post: 06-19-2015, 08:58 PM
  5. Replies: 0
    Last Post: 06-19-2015, 02:13 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD