1. xweb10's Avatar
    I just updated to 5.1. In the past (KitKat) I had Bluetooth devices set as Trusted Devices. My phone is set with a PIN password, but when attached to a Trusted Device, this was not needed. I have setup the new Lollipop "Smart Lock" to do the same, however, the behavior is different. For example, when the phone is locked and not attached to a trusted device, I wake the phone using the power button. I have to swipe then enter the pin. In the past, the pin screen appeared without the need to swipe first. Is there a way to remove the need to swipe first? It is a minor annoyance.

    That being said, when it is attached to a trusted Bluetooth device, pressing the power button used to get me right into the home screen. Now I have the "swipe to unlock" screen first. Again, a minor annoyance. I do not want to swipe if I am already "unlocked". I like to press the power button and get placed into the home screen. Has anyone figured our a way to do this?

    Separately, is there any icon indicating the Smart Lock is connected? In KitKat (with Trusted Devices) there was a lock icon.

    I apologize in advance if I have not been clear.
    07-01-2015 02:46 PM
  2. antk90's Avatar
    You have to register your bluetooth devices again as trusted in the new smart lock feature. It's under security in settings.
    07-01-2015 02:49 PM
  3. xweb10's Avatar
    You have to register your bluetooth devices again as trusted in the new smart lock feature. It's under security in settings.
    I have done this. The feature is "working" but there is an additional swipe screen.
    07-01-2015 02:51 PM
  4. antk90's Avatar
    When I use the unlock from front screen, not the lock button, it takes you to the home screen.
    07-01-2015 02:53 PM
  5. xweb10's Avatar
    When I use the unlock from front screen, not the lock button, it takes you to the home screen.
    Correct. I am talking about the power/lock button. I tend to use that alot.
    07-01-2015 02:57 PM
  6. tdizzel's Avatar
    For example, when the phone is locked and not attached to a trusted device, I wake the phone using the power button. I have to swipe then enter the pin. In the past, the pin screen appeared without the need to swipe first. Is there a way to remove the need to swipe first? It is a minor annoyance.
    .
    Go to settings>security and turn on Power button shows lock screen. That should do the trick.
    07-01-2015 06:16 PM
  7. xweb10's Avatar
    Go to settings>security and turn on Power button shows lock screen. That should do the trick.
    I tried that, but thanks for the suggestion. It seems that the swipe up,left,right screen always wants to show when using the power button to unlock and already unlocked Turbo (via Smart Lock).
    07-01-2015 06:19 PM
  8. AMTrombley0924's Avatar
    I noticed this too. It is a little annoying, but it's minor. Perhaps Moto can eventually fix this with an update to the Moto app?
    xweb10 likes this.
    07-01-2015 06:52 PM
  9. doogald's Avatar
    I have to be honest: I prefer this behavior. I do like BT keeping my phone unlocked, but I also don't want my phone subject to an accidental press if I press power. I want a swipe screen first. I always wanted KK to have this.

    That said, they should make it an option.
    xweb10 and Ry like this.
    07-01-2015 10:42 PM

Similar Threads

  1. When I unroot my rooted device a network error occurs
    By xylon1010 in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 08-07-2015, 10:41 PM
  2. galaxy note 3 with lollipop 5
    By Harry Myhre in forum Verizon Samsung Galaxy Note 3
    Replies: 1
    Last Post: 07-01-2015, 09:37 PM
  3. How do I remove the CM Security lock on my Galaxy s 4 phone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-01-2015, 07:23 PM
  4. Replies: 0
    Last Post: 07-01-2015, 01:39 PM
  5. Notofication Screen not working since Lollipop Upgrade
    By waterwalker23 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-01-2015, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD