1. xdollface8's Avatar
    I just switched from a 2014 Moto X to Droid Turbo this morning. I updated the phone to lollipop and started to set things up how I like them. However, I cannot find the smart lock feature anywhere to set up trusted locations. I did set up my lock screen with a pin.

    I googled to make sure this model has smart lock on lollipop and it does. I went through the steps on my moto x to make sure I wasn't missing it on the turbo.

    It just seems to be missing. Help!
    07-03-2015 02:15 PM
  2. B. Diddy's Avatar
    Welcome back! Go to Settings>Security>Trust Agents​, and make sure Smart Lock is turned on.
    07-03-2015 02:18 PM
  3. xdollface8's Avatar
    I tried that no luck. I think I am going to uninstall the update and do a factory reset... and start over.

    Posted via the Android Central App
    07-03-2015 02:27 PM
  4. xdollface8's Avatar
    I uninstalled the update, factory reset the phone, reinstalled the update and still was missing the smart lock.

    I connected my moto 360, set that up and then went back to the phone settings and smart lock randomly appeared.

    I am not sure what the issue it is but it has been solved!

    Thank you!

    Posted via the Android Central App
    B. Diddy likes this.
    07-03-2015 03:43 PM
  5. limeyinusa's Avatar
    Does the smart lock feature allow Wi-Fi networks to be trusted and unlock phone? Or is it just BT devices?

    Posted via the Android Central App
    07-03-2015 03:48 PM
  6. B. Diddy's Avatar
    No, that's one of the deficiencies of Smart Lock, and one area where the SkipLock app has an advantage. Smart Lock uses Trusted Bluetooth Devices, Trusted Places (based on location services, not wi-fi connection), Trusted Faces/Trusted Voice (not available on all devices), and On Body Detection.
    07-03-2015 04:08 PM
  7. tdizzel's Avatar
    I uninstalled the update, factory reset the phone, reinstalled the update and still was missing the smart lock.

    I connected my moto 360, set that up and then went back to the phone settings and smart lock randomly appeared.

    I am not sure what the issue it is but it has been solved!

    Thank you!

    Posted via the Android Central App
    How did you uninstall the update?
    07-03-2015 04:30 PM
  8. legendarydog's Avatar
    Keep checking the trust agents until Smart Lock appears

    Sent from my XT1254 using Tapatalk
    07-03-2015 05:01 PM
  9. xdollface8's Avatar
    I didn't uninstall any application.

    I found a YouTube video on how to remove the update before I did the factory reset. I will see of I can find the video again.

    After that I did the factory reset. Reinstalled lollipop. Checked it was still missing so I took a break from it out if frustration and set up my 360. After that I decided to continue to try and fix it and it was there. I am not sure what changed but it seems that connecting the 360 did something.

    Posted via the Android Central App
    07-03-2015 05:22 PM
  10. xdollface8's Avatar
    Smart Lock allows trusted locations, devices, voices and faces.

    Posted via the Android Central App
    07-03-2015 05:23 PM
  11. 1Coopgt's Avatar
    Does the smart lock feature allow Wi-Fi networks to be trusted and unlock phone? Or is it just BT devices?

    Posted via the Android Central App
    If you have Smart Lock turned on you can go in and set up Trusted places . Then you can set up your home and other places to not enter a pin or pattern . It's a great little feature .
    07-03-2015 05:28 PM
  12. mahers's Avatar
    Skiplock actually does work with 5.1. I had it set up before the update, and it's still working fine. Smart Lock, however, won't work if you keep Skiplock active as a Device Administrator on the phone. I prefer Skiplock because of the wifi unlock, as well as the automatic off/on for my BT devices. Smart Lock is cool, but not as rich for me.

    Sent with Turbo speed!
    07-03-2015 07:28 PM
  13. optaka's Avatar
    I can now see smart lock on my security settings screen and I have trusted faces set up, but I have no option to use it in the screen lock page. Body detection seems to be working fine, I just can't use face unlock. Any suggestions?
    07-07-2015 11:04 AM
  14. Phoenix212's Avatar
    How do you set up "trusted places"? Under the Smart Lock settings the "Trusted places" is grayed out and says "Disabled by administrator" ... in fact, all of the Smart Lock settings say that.
    07-07-2015 12:54 PM
  15. Mikey D_PhD's Avatar
    How do you set up "trusted places"? Under the Smart Lock settings the "Trusted places" is grayed out and says "Disabled by administrator" ... in fact, all of the Smart Lock settings say that.
    Do you have an exchange account set up on your device? If so, the exchange administrator may have disabled that capability. It's that way on my device with a university exchange account.
    07-07-2015 02:35 PM
  16. Phoenix212's Avatar
    Do you have an exchange account set up on your device? If so, the exchange administrator may have disabled that capability. It's that way on my device with a university exchange account.
    I do have Exchange on my phone for work email/calendar. That blows but is understandable. Thanks for the info.
    07-07-2015 09:12 PM
  17. Ken Long4's Avatar
    I just switched from a 2014 Moto X to Droid Turbo this morning. I updated the phone to lollipop and started to set things up how I like them. However, I cannot find the smart lock feature anywhere to set up trusted locations. I did set up my lock screen with a pin.

    I googled to make sure this model has smart lock on lollipop and it does. I went through the steps on my moto x to make sure I wasn't missing it on the turbo.

    It just seems to be missing. Help!
    07-12-2015 09:33 PM
  18. Ken Long4's Avatar
    You have to go to trust agents and then you will see activation for smart lock. Then go back and smart lock is there
    07-12-2015 09:35 PM
  19. Blake Thompson3's Avatar
    Same issue here. I have enabled the feature in trust agents, smart lock is in my security options. Face lock turned ON and when I go to choose my screen lock it still isn't an option shown
    07-25-2015 09:04 AM
  20. Blake Thompson3's Avatar
    Did you figure this out? Same problem here
    07-25-2015 09:31 AM
  21. trueislander's Avatar
    Bump for optaka and Blake Thompson3's question
    I can now see smart lock on my security settings screen and I have trusted faces set up, but I have no option to use it in the screen lock page. Body detection seems to be working fine, I just can't use face unlock. Any suggestions?
    08-02-2015 06:42 PM
  22. deesugar's Avatar
    One thing that is not mentioned in any of the documentation or in forums is that you must turn off Moto Voice first before Trusted Voice will work. Then go back to trusted voice and enable & setup in order:

    • From the Google App
    • From Any Screen
    • And then you will be allowed to enable Trusted Voice
    08-18-2016 12:52 AM

Similar Threads

  1. Replies: 6
    Last Post: 07-13-2015, 09:11 PM
  2. On Bluetooth Connect, Open Pandora?
    By IFeelYourPain in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 07-06-2015, 10:12 PM
  3. Replies: 1
    Last Post: 07-03-2015, 03:04 PM
  4. How do I install apk files on Android Lollipop?
    By AC Question in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 07-03-2015, 03:04 PM
  5. How can I clear storage on my Droid Mini?
    By AC Question in forum Motorola Droid Mini
    Replies: 1
    Last Post: 07-03-2015, 02:20 PM
LINK TO POST COPIED TO CLIPBOARD