1. DSTurbo's Avatar
    There are 2 Droid Turbo's in my house, both are less than 2 months old. Both have totally lost 2.0 quick/ turbo charging after the lollipop update!! This is using oem chargers and cords. I have performed FDR's and Cache wipes on both...What gives?!?
    08-01-2015 09:04 AM
  2. ScottyDog's Avatar
    I would take them into Verizon and show them. They should fix it or give you a replacement.
    DSTurbo likes this.
    08-01-2015 09:29 AM
  3. DSTurbo's Avatar
    I would take them into Verizon and show them. They should fix it or give you a replacement.
    I just got home from the Verizon store. We tested some of their demos running 5.1 using my quick charger and they all worked. Then we plugged in both of mine and as expected no quick charge. The manager said this is the first case of this he has seen and on 2 units even weirder. He ordered 2 new units same color and all free of charge!! Awesome CS. Motorola was trying to charge me $24.99 per unit for replacement.
    08-01-2015 11:20 AM

Similar Threads

  1. Replies: 2
    Last Post: 08-05-2015, 11:53 AM
  2. Replies: 3
    Last Post: 08-01-2015, 01:32 PM
  3. Is there a wireless charging pad for the S5?
    By AC Question in forum Wireless Charging
    Replies: 1
    Last Post: 08-01-2015, 09:11 AM
  4. Replies: 1
    Last Post: 08-01-2015, 09:08 AM
  5. updated and killed
    By Kellie Harley in forum Ask a Question
    Replies: 1
    Last Post: 08-01-2015, 08:44 AM
LINK TO POST COPIED TO CLIPBOARD