1. silverbullet40sw's Avatar
    After connecting to the guest WiFi at work, I try to login to the network and a padlock comes up on the screen where I would normally enter my login credentials. I can connect to this network with other phones and my tablet. My Droid turbo is the only device that I'm having this problem with!
    11-10-2015 06:46 PM
  2. Davidoo's Avatar
    The same thing happened with my Turbo with my work WiFi, but I finally figured it out. When the red padlock is on the screen tap the 3 dots on the top right of the screen. One of the options is something such as "proceed anyway with this network as is." The first time it does nothing, then the screen pops up again after a few seconds, then pick the same option to proceed anyway again. I think mine did this 3 times before another screen finally came up and gave me a warning that the network was not secure and it was dangerous to proceed. I did it anyway, then I was connected to the work WiFi. Not sure why the Turbo has to go through all these warnings. I thought mine was the only one that did this, but the solution here has got me connected several times.
    11-10-2015 07:50 PM
  3. silverbullet40sw's Avatar
    So I just tried your method. I turned on WiFi, connected to my work network, then the sign in screen came up with the padlock, I tapped the three dots and selected "use network as is." I tried this 5 times in a row and every time I try to use the internet, the sign in screen pops up with the padlock again!
    11-11-2015 05:48 PM
  4. Davidoo's Avatar
    Sorry about that. Not sure why we even get the idiotic padlock, but after the 3rd time for me it changes to a browser screen warning me about an unsecured connection. Have you tried opening Chrome during this process to see if it will bring up the warning or perhaps a sign in screen?
    11-11-2015 08:08 PM
  5. silverbullet40sw's Avatar
    I agree about the idiotic padlock! I appreciate your help, unfortunately I haven't had much time at work to tinker with it. I thought for sure it was something in the browser settings or security or some sort of settings, but I haven't found jack! Anyway, if you figure out anything else, please let me know. Otherwise, I will keep tinkering with it as I get time at work. Thanks
    11-12-2015 01:41 AM

Similar Threads

  1. Replies: 1
    Last Post: 01-22-2016, 03:09 PM
  2. Wifi problem on my Nexus 6p
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 11-17-2015, 07:16 AM
  3. How do I transfer contacts and photos from Galaxy 2 to Galaxy Grand?
    By AC Question in forum Samsung Galaxy Grand
    Replies: 1
    Last Post: 11-11-2015, 01:32 AM
  4. Replies: 0
    Last Post: 11-10-2015, 06:44 PM
  5. Best phone to Root?
    By Vinnycas in forum General Help and How To
    Replies: 1
    Last Post: 11-10-2015, 05:34 PM
LINK TO POST COPIED TO CLIPBOARD