1. mpgo4th's Avatar
    My replacement turbo started today doing the same thing my first one was replaced for. I don't get a ring or a missed call in the call log, the only way I know I had a call is of they left a voicemail. This has happened randomly for months and vzw says its a device problem and replaces my device. The kicker is I can't take a cheaper device or change phones until I pay of the balance of my phone on the edge plan. Lucky me I guess. I'll just keep paying my bill in full and wonder if I'm getting a call or not. That's service with a smile.

    Posted via the Android Central App
    11-20-2015 01:05 PM
  2. doogald's Avatar
    My replacement turbo started today doing the same thing my first one was replaced for. I don't get a ring or a missed call in the call log, the only way I know I had a call is of they left a voicemail. This has happened randomly for months and vzw says its a device problem and replaces my device. The kicker is I can't take a cheaper device or change phones until I pay of the balance of my phone on the edge plan. Lucky me I guess. I'll just keep paying my bill in full and wonder if I'm getting a call or not. That's service with a smile.
    Here is a guess: you have an app that you've installed that is somehow taking up so much processor that when a phone call is received the phone is too busy to actually ring the phone. One thought is to look at your settings / battery and see if you have an app that is high on the list that might be doing that.

    Another idea, especially if you just took the SIM card out of your old Turbo and put it in the replacement: it is a bad SIM card that is not holding a connection to Verizon reliably. If the new Turbo came with its own SIM that you activated, never mind that one.
    11-20-2015 03:14 PM
  3. mpgo4th's Avatar
    It's still using the original sim card but the replacement due here tomorrow will have a new sim with it. This is not a fix for this problem. If you look at the forums on vzw website this problem is pretty common. It's on the moto side and not Verizon's fault. The only way this is a fix for me is if I get the lucky device that has no bugs and works right.

    Posted via the Android Central App
    11-20-2015 04:39 PM
  4. 1Coopgt's Avatar
    There is nothing wrong with your phone or your original one . Hold down one of your volume buttons make sure all is selected. Also check your settings under Sounds and Notifications (notifications).
    Attached Thumbnails Missing calls on second turbo.-2015-11-21-01.19.25.jpg  
    D._Manley likes this.
    11-20-2015 07:24 PM
  5. mpgo4th's Avatar
    Thanks but I've had this phone for almost a year and I know how to set the volumes. The phone itself would still show the call as missed and have it listed in the call log if that was the problem.

    Posted via the Android Central App
    11-20-2015 07:38 PM
  6. JJ Jones's Avatar
    Do you by chance have Advanced Calling turned on? That being active had caused the missed call problem for many. Turn it off and you should get your calls again.

    Posted via the Android Central App
    11-20-2015 10:40 PM
  7. mpgo4th's Avatar
    Nope, not advanced calling either. Thanks for trying. I quit using that in August with the first device.

    Posted via the Android Central App
    11-21-2015 09:21 PM
  8. Jheebs's Avatar
    Nope, not advanced calling either. Thanks for trying. I quit using that in August with the first device.

    Posted via the Android Central App
    This is a known bug with the Turbo. Some folks have it, some don't. When I was using the Turbo, I did have it, on occasion, and a clear system cache and reboot would make the problem go away for a few months.

    Posted via the Android Central App
    11-22-2015 08:12 AM
  9. mpgo4th's Avatar
    So far so good on my third device. This one had some setup problems and a few app bugs but after a factory reset it seems to be running great. Time will tell.

    Posted via the Android Central App
    11-24-2015 11:29 AM
  10. Murph5150's Avatar
    Turn off HD voice and see if that helps.

    Posted via the Android Central App
    11-24-2015 04:12 PM
  11. doogald's Avatar
    Turn off HD voice and see if that helps.

    Posted via the Android Central App
    Look three posts above yours.
    11-24-2015 07:59 PM
  12. mpgo4th's Avatar
    Still going strong. The only thing that scares me is that unless the caller leaves a voicemail, I don't know that I'm missing calls. I really like this phone but I don't trust it. Fool me once kind of thing. I'm really thinking of paying out of this phone and getting my wife a new iPhone so I can take hers over. At least it rings.

    Posted via the Android Central App
    11-26-2015 03:48 PM
  13. SouthernblondeLKS's Avatar
    I had the same issue where I wasn't getting calls (nothing in the call log and the only way to tell was the voicemail), but it was intermittent, so I just chocked it up to smart technology not being so smart. Then I missed a few really important calls. I'm still peeved about missing a call from a possible employer. That's when I went to get my SIM card replaced. That was a few months ago. So far, the issue has not repeated. I've also cleared my cache as needed. It seems like it was the SIM in my phone that was the issue. But like you mentioned in another of your posts, only time will tell.

    I'd say have some of your friends do some test calls to see if they go straight to voicemail or if it rings. When the issue first started I asked my friends who were leaving voicemails if the phone rang on their end or if it sent them directly to voicemail. It was mixed. Some were getting rings, others going directly to voicemail. I couldn't nail down anything solid to explain the issue. I'd say now that you have your new phone to have your friends do some test calls to see if they get through each time.
    mpgo4th likes this.
    11-26-2015 10:51 PM
  14. TiMar99's Avatar
    Yeah, Sim swap was the fix for me when I was having this annoying problem.

    Posted via the Android Central App
    11-27-2015 03:28 PM
  15. mpgo4th's Avatar
    I have a new sim in the drawer that I can try. I guess I'll have to call them to set it to my phone number.

    Posted via the Android Central App
    11-28-2015 10:16 AM

Similar Threads

  1. How do I enable background data on my Asus phone?
    By AC Question in forum More ASUS Phones
    Replies: 3
    Last Post: 11-26-2015, 01:14 AM
  2. Replies: 3
    Last Post: 11-22-2015, 09:07 AM
  3. I am trying to watch Bravo TV on my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-20-2015, 12:36 PM
  4. How do I remove the lock icon on my Samsung mobile phone?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 11-20-2015, 12:35 PM
  5. Part of AirDroid Settings Window is Missing, Any Fix?
    By foghorn101 in forum Android Apps
    Replies: 0
    Last Post: 11-20-2015, 12:19 PM
LINK TO POST COPIED TO CLIPBOARD