1. mrtonk's Avatar
    Okay, techie friends. I have a Netgear C3700-100NAS cable modem / wifi router. My phone, my wife's phone, the laptop, and a desktop computer are all connected. The router is a good one. Each device registers a 38 mbps Internet connection and the router is apparently broadcasting at 72 mbps. Web pages on the laptop and desktop load nearly instantaneously. However, the two phones connected to the WiFi, each less than one year old, are suddenly seeing it take 20+ seconds to load a mobile formatted Web page or any other Web pages. Additionally, when I connected to my Verizon 4G connection, everything loads perfectly AND I suddenly got a bunch of email and news alerts. The router diagnostic logs appear to show a bunch of "critical alerts" that I don't understand, but I don't get why Chrome on a mac and on a PC would load so much faster than Chrome on two different modern Android phones. Other apps that use data are sluggish, too. Thoughts? I have factory reset the router, and I have a Droid Turbo and my wife had a Samsung Galaxy s6 edge.
    01-09-2016 05:46 PM
  2. mrtonk's Avatar
    At the moment:
    01-09-2016 05:51 PM
  3. Rukbat's Avatar
    Connect to the router (192.168.1.1). Check the wifi security - make sure it's AES, not TKIP or TKIP+AES. You'll have to forget all the Android connections and delete the connections on the other devices, then reconnect everything. (At least Netgear routers will work if you do that - the latest Linksys routers still won't, even with AES and Android.)
    01-09-2016 05:58 PM
  4. parthtc09's Avatar
    Who is your ISP? Try first powercycling the unit, while its turned on unplug and wait about 30 seconds then plug back in. While you're waiting restart both affected mobile devices. Give the router about a min or so after plugging in and try again. If that doesn't change try a firmware update. Routerlogin.net> user is admin pass is password (if you haven't set one up) advanced>firmware. If your ISP is xfinity/Comcast/time warner and if its a newly acquired unit call and register the unit with them.
    01-09-2016 06:00 PM
  5. doogald's Avatar
    If you can connect, then security is fine.

    It sounds like maybe a DNS issue. If you can, try changing the default DNS servers for your router to 8.8.8.8 and 8.8.4.4 (those are Google's DNS servers) and restart the router. See if that makes things better for the phone clients.
    mrtonk likes this.
    01-09-2016 06:02 PM
  6. mrtonk's Avatar
    Connect to the router (192.168.1.1). Check the wifi security - make sure it's AES, not TKIP or TKIP+AES. You'll have to forget all the Android connections and delete the connections on the other devices, then reconnect everything. (At least Netgear routers will work if you do that - the latest Linksys routers still won't, even with AES and Android.)
    It's already set that way, unfortunately.
    01-09-2016 06:04 PM
  7. mrtonk's Avatar
    If you can connect, then security is fine.

    It sounds like maybe a DNS issue. If you can, try changing the default DNS servers for your router to 8.8.8.8 and 8.8.4.4 (those are Google's DNS servers) and restart the router. See if that makes things better for the phone clients.
    WOOHOO! That did it! Thanks!
    01-09-2016 09:35 PM
  8. mrtonk's Avatar
    WOOHOO! That did it! Thanks!
    Never mind. Still having problems, based on the number of notifications I just got when I left my wifi.
    01-10-2016 03:36 PM
  9. reildeal's Avatar
    I recently did a cache partition wipe on both my Nexus 4 and 7, hoping to free up some memory on them, since that time I have had issues with wifi. On my Nexus 4 web pages take forever to load if they load at all, I turn off wifi and exact same page loads within seconds, I am not so concerned with the Nexus 7 at this time but a resolution on the Nexus 4 may help fix the 7. Nothing has changed on my router settings for my home network, all of my computers connect and have same download speeds as they have been for some time. I am about to do a Factory Reset on nexus after I completely backup my data and see if this solves some issues. Any suggestions are greatly appreciated.
    03-05-2016 07:16 AM

Similar Threads

  1. whatsapp on wifi only android tablet.
    By SSoffe in forum Ask a Question
    Replies: 3
    Last Post: 04-03-2016, 11:48 AM
  2. Note 4 SD card reading issues *making me mad!*
    By SMN216 in forum Ask a Question
    Replies: 2
    Last Post: 01-09-2016, 09:18 PM
  3. Replies: 1
    Last Post: 01-09-2016, 02:35 PM
  4. Is there a way to send and reive texts using wifi only?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2016, 10:10 AM
  5. Is there a way to send/receive sms texts over wifi?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2016, 09:01 AM
LINK TO POST COPIED TO CLIPBOARD