1. PowrDroid's Avatar
    Can you help me out here? Maybe try this on your Turbo for me?

    I sometimes take a short nap (20-25 minutes or so) in the late afternoon just before dinner. For months I'd kick back in my recliner, phone in pocket, and say:

    "Obey Me, Droid Turbo" (my Moto Voice launch phrase),
    Phone: <Blinging tone, indicating it's ready>
    Me: "Set an alarm for 25 minutes from now."
    Phone: <Blinging tone, then 'plink' tone> "OK, 5:15 pm, setting your alarm."

    I'd then take my nap and would wake up when the alarm went off at 5:15.

    Lately, I do that entire voice command process, ending with getting the confirmation message, "OK, 5:15 pm, setting your alarm" as usual, but when 5:15 rolls around, the alarm doesn't go off. A couple of days ago after I got the confirmation message I checked my alarms and nothing had been set. So I tried it again and the second attempt worked. The difference between my first attempt (failed) and my second attempt (success) was that my phone was locked and then it was unlocked.

    A little experimentation and I've confirmed that if my phone is locked and I go through the process the alarm will not 'stick', but if I unlock my phone and go through the process again, the alarm does get set.

    So what's changed? For months and months I'd been setting an alarm with voice commands while the phone was locked in my pocket. For about the last two weeks I've had to pull my phone out of my pocket, unlock it, then go through the routine of setting the alarm. Having to handle the phone in order to get it to execute Voice Commands is basically defeating the feature of having Voice Commands.

    Would anyone be willing to try this alarm setting using voice command experiment for me and report back your findings?
    03-30-2016 02:48 PM
  2. leehardballer12's Avatar
    I wonder if having the ability to use voice commands to function the phone while locked was considered a security risk and 'fixed'....

    Posted via the Android Central App
    03-30-2016 05:48 PM
  3. Einsteindks's Avatar
    Some actions were allowable while locked, and others you had to authorize. Some actions won't work at all when locked, and there are no bypass options.
    Laura Knotek likes this.
    03-31-2016 12:07 AM
  4. doogald's Avatar
    Can you use it to set a calendar event instead? "Schedule an appointment for today at 5:15", assuming you have your calendar set to automatically remind you with a sound for meetings.

    I know with the droid Maxx that Motorola kept having to update what was first touchless controls and is now moto voice when things stopped working, presumably when Google did something to the Google search app that moto voice depends on that changed how their voice control worked.

    I guess the other way to check (if nobody with a turbo can verify for you - sorry, I don't have one) is to restart in safe mode and see if that changes anything, to rule out something with a third party app.
    03-31-2016 05:30 AM
  5. PowrDroid's Avatar
    Can you use it to set a calendar event instead? "Schedule an appointment for today at 5:15", assuming you have your calendar set to automatically remind you with a sound for meetings.
    Nope. Can't set a calendar event.

    I've been playing around with it on my desk in locked mode. Setting an alarm and setting a calendar event goes through to the very end, the phone asks me, "Do you want to save this event?" I answer, "Yes", the phone sounds a trill (as if it's committed the event) but when I look at the (partially dimmed) screen there is an icon to set the event and an "X" to cancel it which I am supposed to tap. This screen remains until the screen on time out is reached, in my case, two minutes, and then the screen goes black. In other words, the event never gets set.

    I guess they changed something which defeats Voice Commands in locked mode.

    One thing I noticed during the process--the Unlock PIN screen briefly pops up then disappears.
    03-31-2016 10:58 AM
  6. doogald's Avatar
    Try toggling (off, go home, on) the Moto voice settings and see if they reset so it starts working again?

    Look at Google search voice settings and see if toggling them allows this?

    Change security to none, see if it works, then back to pin and see if now works?

    (The sort of troubleshooting I'd do.)

    If you still can't get it to work, make sure to leave a review in the play store for the Moto voice app detailing the problem. If you look at the reviews, you'll see that somebody at Motorola responds to many of the ones mentioning problems. It wouldn't hurt to also add a forum post at Lenovo's forums. https://forums.lenovo.com/t5/DROID-T...e/td-p/3297526

    (Oh, I see that you've already done so... )
    03-31-2016 11:43 AM

Similar Threads

  1. Replies: 1
    Last Post: 03-30-2016, 08:53 PM
  2. How do I get emojis on my LGP705
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2016, 02:37 PM
  3. Why is there a lock symbol beside a visual voicemail?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 03-30-2016, 02:34 PM
  4. Why won't my Moto G2nd gen charge past 85?
    By AC Question in forum Moto G (2014)
    Replies: 0
    Last Post: 03-30-2016, 02:10 PM
  5. How do I delete all calendar events with Marshmallow?
    By AC Question in forum Android 6.0 Marshmallow
    Replies: 0
    Last Post: 03-30-2016, 01:49 PM
LINK TO POST COPIED TO CLIPBOARD